summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-11-29 09:38:39 +0000
committerAlin Năstac <mrness@gentoo.org>2009-11-29 09:38:39 +0000
commite8aa6d5a39050cb1ee6e0fcbbbe0470e6c39218a (patch)
tree0f470de7cfc24a58f48372e792d40f0535a9a9ee /net-dialup
parentFix actionpack dep (diff)
downloadgentoo-2-e8aa6d5a39050cb1ee6e0fcbbbe0470e6c39218a.tar.gz
gentoo-2-e8aa6d5a39050cb1ee6e0fcbbbe0470e6c39218a.tar.bz2
gentoo-2-e8aa6d5a39050cb1ee6e0fcbbbe0470e6c39218a.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/hcfpcimodem/ChangeLog8
-rw-r--r--net-dialup/hcfpcimodem/files/hcfpcimodem-1.20-gentoo.patch29
-rw-r--r--net-dialup/hcfpcimodem/hcfpcimodem-1.20.ebuild92
3 files changed, 128 insertions, 1 deletions
diff --git a/net-dialup/hcfpcimodem/ChangeLog b/net-dialup/hcfpcimodem/ChangeLog
index 3f64eee4bb9f..f769eac7d6f6 100644
--- a/net-dialup/hcfpcimodem/ChangeLog
+++ b/net-dialup/hcfpcimodem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/hcfpcimodem
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.43 2009/09/22 16:34:51 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.44 2009/11/29 09:38:39 mrness Exp $
+
+*hcfpcimodem-1.20 (29 Nov 2009)
+
+ 29 Nov 2009; Alin Năstac <mrness@gentoo.org> +hcfpcimodem-1.20.ebuild,
+ +files/hcfpcimodem-1.20-gentoo.patch:
+ Version bump.
22 Sep 2009; Alin Năstac <mrness@gentoo.org> -hcfpcimodem-1.14-r1.ebuild,
-files/hcfpcimodem-1.14-implicit-declarations.patch,
diff --git a/net-dialup/hcfpcimodem/files/hcfpcimodem-1.20-gentoo.patch b/net-dialup/hcfpcimodem/files/hcfpcimodem-1.20-gentoo.patch
new file mode 100644
index 000000000000..11ce09abfbbc
--- /dev/null
+++ b/net-dialup/hcfpcimodem/files/hcfpcimodem-1.20-gentoo.patch
@@ -0,0 +1,29 @@
+diff -Nru hcfpcimodem-1.20full.orig/diag/makefile hcfpcimodem-1.20full/diag/makefile
+--- hcfpcimodem-1.20full.orig/diag/makefile 2004-12-14 08:50:41.000000000 +0100
++++ hcfpcimodem-1.20full/diag/makefile 2009-11-29 10:35:05.000000000 +0100
+@@ -10,7 +10,7 @@
+ include $(TOP)/config.mak
+ -include $(TOP)/modules/imported/makeflags.mak
+
+-CFLAGS = -I$(TOP)/modules/imported/include -I$(TOP)/modules/include
++CFLAGS += -I$(TOP)/modules/imported/include -I$(TOP)/modules/include
+ CFLAGS += $(IMPORTED_FRAMEWORK_DEFS) $(IMPORTED_GENERAL_DEFS)
+ CFLAGS += -DCNXTTARGET="\"$(CNXTTARGET)\""
+
+@@ -41,13 +41,13 @@
+ $(MKDIR) -p $@
+
+ $(CNXTTARGET)diag: diag.o modemexpert.o
+- $(CC) -o $@ $^
++ $(CC) ${LDFLAGS} -o $@ $^
+
+ $(CNXTTARGET)scr: scr.o
+- $(CC) -o $@ $^
++ $(CC) ${CFLAGS} ${LDFLAGS} -o $@ $^
+
+ $(CNXTTARGET)dmp: dmp.o
+- $(CC) -o $@ $^
++ $(CC) ${CFLAGS} ${LDFLAGS} -o $@ $^
+
+ clean:
+ rm -f *.o $(ALL)
diff --git a/net-dialup/hcfpcimodem/hcfpcimodem-1.20.ebuild b/net-dialup/hcfpcimodem/hcfpcimodem-1.20.ebuild
new file mode 100644
index 000000000000..ac956686ac78
--- /dev/null
+++ b/net-dialup/hcfpcimodem/hcfpcimodem-1.20.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/hcfpcimodem-1.20.ebuild,v 1.1 2009/11/29 09:38:39 mrness Exp $
+
+inherit eutils linux-info
+
+#The document is the same as in hsfmodem, even if it has a different URL
+MY_DOC="100498D_RM_HxF_Released.pdf"
+
+DESCRIPTION="Linuxant's modem driver for Connexant HCF chipset"
+HOMEPAGE="http://www.linuxant.com/drivers/hcf/index.php"
+SRC_URI="http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${P}full.tar.gz
+ doc? ( http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${MY_DOC} )"
+
+LICENSE="Conexant"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ app-arch/cpio"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}full"
+
+QA_EXECSTACK="usr/lib/hcfpcimodem/modules/imported/hcfblam-i386.O usr/lib/hcfpcimodem/modules/imported/hcfengine-i386.O"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ MOD_N="hcfpci"
+ # Check to see if module is inserted into kernel, otherwise, build fails
+ if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+ eerror
+ eerror "Module is in use by the kernel!!!"
+ eerror "Attempting to unload..."
+ eerror
+
+ # Unloading module...
+ ${MOD_N}stop
+ if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+ eerror "Failed to unload modules from kernel!!!"
+ eerror "Please manualy remove the module from the kernel and emerge again."
+ eerror
+ die
+ fi
+ einfo "Successfuly removed module from memory. Resuming emerge."
+ einfo
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake all || die "make failed"
+}
+
+pkg_preinst() {
+ local NVMDIR="${ROOT}/etc/${PN}/nvm"
+ if [ -d "${NVMDIR}" ]; then
+ einfo "Cleaning ${NVMDIR}..."
+ rm -rf "${NVMDIR}"
+ eend
+ fi
+}
+
+src_install () {
+ make PREFIX="${D}/usr/" ROOT="${D}" install || die "make install failed"
+
+ # in some cases, kernelcompiler.sh does not have x permission (#173414)
+ fperms a+rx /usr/lib/hcfpcimodem/modules/kernelcompiler.sh
+
+ use doc && dodoc "${DISTDIR}/${MY_DOC}"
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]; then
+ elog "To complete the installation and configuration of your HCF modem,"
+ elog "please run hcfpciconfig."
+ fi
+}
+
+pkg_prerm() {
+ if [ "${ROOT}" = / -a -f /etc/init.d/hcfpci ] ; then
+ hcfpciconfig --remove || die "hcfpciconfig --remove failed"
+ fi
+}