summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-11-15 10:11:48 +0000
committerAlin Năstac <mrness@gentoo.org>2007-11-15 10:11:48 +0000
commitf76f1ab3fd25886824b02ef8e06b5b44c304ae07 (patch)
tree2986e3ea484e061911792b197c9921a1b3f10fa2 /net-dialup
parentUpdated lapack-reference patch and added doc use flag now arches are ready. (diff)
downloadgentoo-2-f76f1ab3fd25886824b02ef8e06b5b44c304ae07.tar.gz
gentoo-2-f76f1ab3fd25886824b02ef8e06b5b44c304ae07.tar.bz2
gentoo-2-f76f1ab3fd25886824b02ef8e06b5b44c304ae07.zip
Fix build failure with LDFLAGS=-Wl,--as-needed, thanks to stephan wezel <s.wezel@web.de> (#187534).
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/capisuite/ChangeLog7
-rw-r--r--net-dialup/capisuite/capisuite-0.4.5-r4.ebuild8
-rw-r--r--net-dialup/capisuite/files/capisuite-0.4.5-as-needed.patch11
3 files changed, 22 insertions, 4 deletions
diff --git a/net-dialup/capisuite/ChangeLog b/net-dialup/capisuite/ChangeLog
index cde6fac7c531..16f5a2ca2e70 100644
--- a/net-dialup/capisuite/ChangeLog
+++ b/net-dialup/capisuite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/capisuite
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/ChangeLog,v 1.30 2007/07/13 08:24:48 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/ChangeLog,v 1.31 2007/11/15 10:11:48 mrness Exp $
+
+ 15 Nov 2007; Alin Năstac <mrness@gentoo.org>
+ +files/capisuite-0.4.5-as-needed.patch, capisuite-0.4.5-r4.ebuild:
+ Fix build failure with LDFLAGS=-Wl,--as-needed, thanks to stephan wezel
+ <s.wezel@web.de> (#187534).
13 Jul 2007; Alin Năstac <mrness@gentoo.org> -capisuite-0.4.5-r3.ebuild,
capisuite-0.4.5-r4.ebuild:
diff --git a/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild b/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild
index cab0bbec1b6c..4af2b901328f 100644
--- a/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild
+++ b/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild,v 1.2 2007/07/13 08:24:48 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild,v 1.3 2007/11/15 10:11:48 mrness Exp $
inherit eutils flag-o-matic multilib python
@@ -29,6 +29,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
# taken from capisuite-0.4.5-5.src.rpm (SuSE-9.3)
epatch "${FILESDIR}/${P}-capi4linux_v3.diff"
@@ -81,9 +83,9 @@ src_install() {
pkg_postinst() {
python_version
- python_mod_compile ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/cs_helpers.py
+ python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/cs_helpers.py
}
pkg_postrm() {
- python_mod_cleanup ${ROOT}usr/$(get_libdir)/python*/site-packages
+ python_mod_cleanup "${ROOT}"usr/$(get_libdir)/python*/site-packages
}
diff --git a/net-dialup/capisuite/files/capisuite-0.4.5-as-needed.patch b/net-dialup/capisuite/files/capisuite-0.4.5-as-needed.patch
new file mode 100644
index 000000000000..d740366ddca2
--- /dev/null
+++ b/net-dialup/capisuite/files/capisuite-0.4.5-as-needed.patch
@@ -0,0 +1,11 @@
+--- acinclude.m4.old 2007-08-02 21:34:26.000000000 +0200
++++ acinclude.m4 2007-08-02 21:42:36.000000000 +0200
+@@ -155,7 +155,7 @@
+ _python_libbasemod=`grep '^BASEMODLIBS=' $python_configdir/Makefile | sed 's/^.*=//'`
+
+ pgac_tab=" " # tab character
+-python_libspec=`echo X"$_python_libs $_python_libc $_python_libm -lpython$python_version $_python_liblocalmod $_python_libbasemod" | sed -e 's/^X//' -e "s/[[ $pgac_tab]][[ $pgac_tab]]*/ /g"`
++python_libspec=`echo X"-lpython$python_version $_python_liblocalmod $_python_libbasemod $_python_libm $_python_libs $_python_libc" | sed -e 's/^X//' -e "s/[[ $pgac_tab]][[ $pgac_tab]]*/ /g"`
+ LIBS="$LIBS $python_libspec"
+ LDFLAGS="$LDFLAGS -L$python_configdir $python_linkforshared"
+ AC_MSG_RESULT([${python_libspec}])