summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-15 22:23:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-15 22:23:55 +0000
commitba063b1a7d826ae40e4c57859983d9fe9e868138 (patch)
tree8f7876ea3dc36e08c35897f2cf0eb1cf210dde88 /net-dns/avahi
parentAdd RESTRICT="fetch bindist" on Solaris, since it is no longer open source. (diff)
downloadgentoo-2-ba063b1a7d826ae40e4c57859983d9fe9e868138.tar.gz
gentoo-2-ba063b1a7d826ae40e4c57859983d9fe9e868138.tar.bz2
gentoo-2-ba063b1a7d826ae40e4c57859983d9fe9e868138.zip
Fix build with automake-1.11.2
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/avahi')
-rw-r--r--net-dns/avahi/ChangeLog10
-rw-r--r--net-dns/avahi/avahi-0.6.30-r3.ebuild222
-rw-r--r--net-dns/avahi/files/avahi-0.6.30-automake-1.11.2.patch105
3 files changed, 336 insertions, 1 deletions
diff --git a/net-dns/avahi/ChangeLog b/net-dns/avahi/ChangeLog
index b3d2f8e30215..a6f32ba1cf98 100644
--- a/net-dns/avahi/ChangeLog
+++ b/net-dns/avahi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dns/avahi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.217 2012/01/01 15:35:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.218 2012/01/15 22:23:55 ssuominen Exp $
+
+*avahi-0.6.30-r3 (15 Jan 2012)
+
+ 15 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +avahi-0.6.30-r3.ebuild,
+ +files/avahi-0.6.30-automake-1.11.2.patch:
+ Install services-types file(s) to pkgdatadir instead of pkglibdir. Empty
+ py-compile script instead of pointing the 'make install' to "true". Closing
+ #397477.
01 Jan 2012; Raúl Porcel <armin76@gentoo.org> avahi-0.6.30-r1.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #393009
diff --git a/net-dns/avahi/avahi-0.6.30-r3.ebuild b/net-dns/avahi/avahi-0.6.30-r3.ebuild
new file mode 100644
index 000000000000..880b1d918fbf
--- /dev/null
+++ b/net-dns/avahi/avahi-0.6.30-r3.ebuild
@@ -0,0 +1,222 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.30-r3.ebuild,v 1.1 2012/01/15 22:23:55 ssuominen Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2"
+PYTHON_USE_WITH="gdbm"
+PYTHON_USE_WITH_OPT="python"
+
+inherit autotools eutils mono python multilib flag-o-matic
+
+DESCRIPTION="System which facilitates service discovery on a local network"
+HOMEPAGE="http://avahi.org/"
+SRC_URI="http://avahi.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE="autoipd bookmarks dbus doc gdbm gtk gtk3 howl-compat +introspection ipv6
+kernel_linux mdnsresponder-compat mono python qt4 test utils"
+
+DBUS_DEPEND=">=sys-apps/dbus-0.30"
+COMMON_DEPEND=">=dev-libs/libdaemon-0.14
+ dev-libs/expat
+ dev-libs/glib:2
+ gdbm? ( sys-libs/gdbm )
+ qt4? ( x11-libs/qt-core:4 )
+ gtk? ( >=x11-libs/gtk+-2.14.0:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ dbus? (
+ ${DBUS_DEPEND}
+ python? ( dev-python/dbus-python )
+ )
+ mono? (
+ >=dev-lang/mono-1.1.10
+ gtk? ( >=dev-dotnet/gtk-sharp-2 )
+ )
+ howl-compat? ( ${DBUS_DEPEND} )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ mdnsresponder-compat? ( ${DBUS_DEPEND} )
+ python? (
+ gtk? ( >=dev-python/pygtk-2 )
+ )
+ bookmarks? (
+ dev-python/twisted
+ dev-python/twisted-web
+ )
+ kernel_linux? ( sys-libs/libcap )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.5
+ >=dev-util/pkgconfig-0.9.0
+ doc? (
+ app-doc/doxygen
+ mono? ( >=virtual/monodoc-1.1.8 )
+ )"
+RDEPEND="${COMMON_DEPEND}
+ howl-compat? ( !net-misc/howl )
+ mdnsresponder-compat? ( !net-misc/mDNSResponder )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ if use python && ! use dbus && ! use gtk; then
+ ewarn "For proper python support you should also enable the dbus and gtk USE flags!"
+ fi
+
+ # FIXME: Use REQUIRED_USE once python.eclass gets EAPI 4 support, bug 372255
+ if use utils && ! { use gtk || use gtk3; }; then
+ ewarn "To install the avahi utilities, USE='gtk utils' or USE='gtk3 utils''"
+ fi
+}
+
+pkg_preinst() {
+ enewgroup netdev
+ enewgroup avahi
+ enewuser avahi -1 -1 -1 avahi
+
+ if use autoipd; then
+ enewgroup avahi-autoipd
+ enewuser avahi-autoipd -1 -1 -1 avahi-autoipd
+ fi
+}
+
+src_prepare() {
+ if use ipv6; then
+ sed -i \
+ -e s/use-ipv6=no/use-ipv6=yes/ \
+ avahi-daemon/avahi-daemon.conf || die
+ fi
+
+ sed -i\
+ -e "s:\\.\\./\\.\\./\\.\\./doc/avahi-docs/html/:../../../doc/${PF}/html/:" \
+ doxygen_to_devhelp.xsl || die
+
+ # Make gtk utils optional
+ epatch "${FILESDIR}/${PN}-0.6.30-optional-gtk-utils.patch"
+
+ # Fix init scripts for >=openrc-0.9.0 (bug #383641)
+ epatch "${FILESDIR}/${PN}-0.6.x-openrc-0.9.x-init-scripts-fixes.patch"
+
+ # Drop DEPRECATED flags, bug #384743
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED=1::g' avahi-ui/Makefile.am || die
+
+ # Prevent .pyc files in DESTDIR
+ >py-compile
+
+ epatch "${FILESDIR}"/${P}-automake-1.11.2.patch #397477
+
+ eautoreconf
+}
+
+src_configure() {
+ use sh && replace-flags -O? -O0
+
+ local myconf="--disable-static"
+
+ if use python; then
+ myconf+="
+ $(use_enable dbus python-dbus)
+ $(use_enable gtk pygtk)
+ "
+ fi
+
+ if use mono; then
+ myconf+=" $(use_enable doc monodoc)"
+ fi
+
+ # these require dbus enabled
+ if use mdnsresponder-compat || use howl-compat || use mono; then
+ myconf+=" --enable-dbus"
+ fi
+
+ # We need to unset DISPLAY, else the configure script might have problems detecting the pygtk module
+ unset DISPLAY
+
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --with-distro=gentoo \
+ --disable-python-dbus \
+ --disable-pygtk \
+ --disable-xmltoman \
+ --disable-monodoc \
+ --enable-glib \
+ --enable-gobject \
+ $(use_enable test tests) \
+ $(use_enable autoipd) \
+ $(use_enable mdnsresponder-compat compat-libdns_sd) \
+ $(use_enable howl-compat compat-howl) \
+ $(use_enable doc doxygen-doc) \
+ $(use_enable mono) \
+ $(use_enable dbus) \
+ $(use_enable python) \
+ $(use_enable gtk) \
+ $(use_enable gtk3) \
+ $(use_enable introspection) \
+ $(use_enable utils gtk-utils) \
+ --disable-qt3 \
+ $(use_enable qt4) \
+ $(use_enable gdbm) \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ use doc && { emake avahi.devhelp || die ; }
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ use bookmarks && use python && use dbus && use gtk || \
+ rm -f "${ED}"/usr/bin/avahi-bookmarks
+
+ use howl-compat && ln -s avahi-compat-howl.pc "${ED}"/usr/$(get_libdir)/pkgconfig/howl.pc
+ use mdnsresponder-compat && ln -s avahi-compat-libdns_sd/dns_sd.h "${ED}"/usr/include/dns_sd.h
+
+ if use autoipd; then
+ insinto /$(get_libdir)/rcscripts/net
+ doins "${FILESDIR}"/autoipd.sh || die
+
+ insinto /$(get_libdir)/rc/net
+ newins "${FILESDIR}"/autoipd-openrc.sh autoipd.sh || die
+ fi
+
+ dodoc docs/{AUTHORS,NEWS,README,TODO} || die
+
+ if use doc; then
+ dohtml -r doxygen/html/. || die
+ insinto /usr/share/devhelp/books/avahi
+ doins avahi.devhelp || die
+ fi
+ if use python && use gtk && use dbus; then
+ python_convert_shebangs 2 "${ED}usr/bin/avahi-discover"
+ fi
+
+ # Remove .la files
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup avahi $(use dbus && use gtk && echo avahi_discover)
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize avahi $(use dbus && use gtk && echo avahi_discover)
+
+ if use autoipd; then
+ echo
+ elog "To use avahi-autoipd to configure your interfaces with IPv4LL (RFC3927)"
+ elog "addresses, just set config_<interface>=( autoipd ) in /etc/conf.d/net!"
+ fi
+
+ if use dbus; then
+ echo
+ elog "If this is your first install of avahi please reload your dbus config"
+ elog "with /etc/init.d/dbus reload before starting avahi-daemon!"
+ fi
+}
diff --git a/net-dns/avahi/files/avahi-0.6.30-automake-1.11.2.patch b/net-dns/avahi/files/avahi-0.6.30-automake-1.11.2.patch
new file mode 100644
index 000000000000..2063972247b4
--- /dev/null
+++ b/net-dns/avahi/files/avahi-0.6.30-automake-1.11.2.patch
@@ -0,0 +1,105 @@
+diff -ur avahi-0.6.30.orig/avahi-python/avahi/Makefile.am avahi-0.6.30/avahi-python/avahi/Makefile.am
+--- avahi-0.6.30.orig/avahi-python/avahi/Makefile.am 2010-06-29 06:30:34.000000000 +0300
++++ avahi-0.6.30/avahi-python/avahi/Makefile.am 2012-01-16 00:07:41.159974487 +0200
+@@ -31,7 +31,7 @@
+ -e 's,@FIRST_KEY\@,key = self.db.firstkey(),g' \
+ -e 's,@CHECK_KEY\@,while key is not None:,g' \
+ -e 's,@NEXT_KEY\@,key = self.db.nextkey(key),g' \
+- -e 's,@pkglibdir\@,$(pkglibdir),g' $< > $@ && \
++ -e 's,@pkgdatadir\@,$(pkgdatadir),g' $< > $@ && \
+ chmod +x $@
+ endif
+
+@@ -44,7 +44,7 @@
+ -e 's,@FIRST_KEY\@,keys = self.db.keys(),g' \
+ -e 's,@CHECK_KEY\@,for key in keys:,g' \
+ -e 's,@NEXT_KEY\@,,g' \
+- -e 's,@pkglibdir\@,$(pkglibdir),g' $< > $@ && \
++ -e 's,@pkgdatadir\@,$(pkgdatadir),g' $< > $@ && \
+ chmod +x $@
+ endif
+
+diff -ur avahi-0.6.30.orig/avahi-python/avahi/ServiceTypeDatabase.py.in avahi-0.6.30/avahi-python/avahi/ServiceTypeDatabase.py.in
+--- avahi-0.6.30.orig/avahi-python/avahi/ServiceTypeDatabase.py.in 2010-06-29 06:30:34.000000000 +0300
++++ avahi-0.6.30/avahi-python/avahi/ServiceTypeDatabase.py.in 2012-01-16 00:05:13.440986312 +0200
+@@ -26,7 +26,7 @@
+ class ServiceTypeDatabase:
+ """ServiceTypeDatabase maps service types to descriptions"""
+
+- def __init__(self, filename = "@pkglibdir@/service-types.db"):
++ def __init__(self, filename = "@pkgdatadir@/service-types.db"):
+
+ self.db = @DBM@.open(filename, "r")
+
+diff -ur avahi-0.6.30.orig/avahi-ui/Makefile.am avahi-0.6.30/avahi-ui/Makefile.am
+--- avahi-0.6.30.orig/avahi-ui/Makefile.am 2010-06-29 06:30:35.000000000 +0300
++++ avahi-0.6.30/avahi-ui/Makefile.am 2012-01-16 00:08:41.330969679 +0200
+@@ -62,18 +62,18 @@
+
+ if HAVE_GDBM
+ libavahi_ui_la_SOURCES += ../avahi-utils/stdb.h ../avahi-utils/stdb.c
+-libavahi_ui_la_CFLAGS += -DDATABASE_FILE=\"$(pkglibdir)/service-types.db\"
++libavahi_ui_la_CFLAGS += -DDATABASE_FILE=\"$(pkgdatadir)/service-types.db\"
+ libavahi_ui_la_LIBADD += -lgdbm
+
+-libavahi_ui_gtk3_la_CFLAGS += -DDATABASE_FILE=\"$(pkglibdir)/service-types.db\"
++libavahi_ui_gtk3_la_CFLAGS += -DDATABASE_FILE=\"$(pkgdatadir)/service-types.db\"
+ libavahi_ui_gtk3_la_LIBADD += -lgdbm
+ endif
+
+ if HAVE_DBM
+ libavahi_ui_la_SOURCES += ../avahi-utils/stdb.h ../avahi-utils/stdb.c
+-libavahi_ui_la_CFLAGS += -DDATABASE_FILE=\"$(pkglibdir)/service-types.db\"
++libavahi_ui_la_CFLAGS += -DDATABASE_FILE=\"$(pkgdatadir)/service-types.db\"
+
+-libavahi_ui_gtk3_la_CFLAGS += -DDATABASE_FILE=\"$(pkglibdir)/service-types.db\"
++libavahi_ui_gtk3_la_CFLAGS += -DDATABASE_FILE=\"$(pkgdatadir)/service-types.db\"
+ endif
+
+ bin_PROGRAMS = bssh
+diff -ur avahi-0.6.30.orig/avahi-utils/Makefile.am avahi-0.6.30/avahi-utils/Makefile.am
+--- avahi-0.6.30.orig/avahi-utils/Makefile.am 2010-06-29 06:30:35.000000000 +0300
++++ avahi-0.6.30/avahi-utils/Makefile.am 2012-01-16 00:09:17.816966708 +0200
+@@ -30,13 +30,13 @@
+
+ if HAVE_GDBM
+ avahi_browse_SOURCES += stdb.h stdb.c
+-avahi_browse_CFLAGS += -DDATABASE_FILE=\"$(pkglibdir)/service-types.db\"
++avahi_browse_CFLAGS += -DDATABASE_FILE=\"$(pkgdatadir)/service-types.db\"
+ avahi_browse_LDADD += -lgdbm
+ endif
+
+ if HAVE_DBM
+ avahi_browse_SOURCES += stdb.h stdb.c
+-avahi_browse_CFLAGS += -DDATABASE_FILE=\"$(pkglibdir)/service-types.db\"
++avahi_browse_CFLAGS += -DDATABASE_FILE=\"$(pkgdatadir)/service-types.db\"
+ endif
+
+ avahi_resolve_SOURCES = avahi-resolve.c sigint.c sigint.h
+diff -ur avahi-0.6.30.orig/service-type-database/Makefile.am avahi-0.6.30/service-type-database/Makefile.am
+--- avahi-0.6.30.orig/service-type-database/Makefile.am 2010-06-29 06:30:35.000000000 +0300
++++ avahi-0.6.30/service-type-database/Makefile.am 2012-01-16 00:10:53.704959089 +0200
+@@ -18,13 +18,12 @@
+ EXTRA_DIST=build-db.in service-types
+
+ pkgdata_DATA=service-types
+-pkglib_DATA=
+
+ if HAVE_PYTHON
+ if HAVE_GDBM
+
+ noinst_SCRIPTS=build-db
+-pkglib_DATA+=service-types.db
++pkgdata_DATA+=service-types.db
+
+ build-db: build-db.in
+ $(AM_V_GEN)sed -e 's,@PYTHON\@,$(PYTHON),g' \
+@@ -41,7 +40,7 @@
+ if HAVE_DBM
+
+ noinst_SCRIPTS=build-db
+-pkglib_DATA+=service-types.db.pag service-types.db.dir
++pkgdata_DATA+=service-types.db.pag service-types.db.dir
+
+ build-db: build-db.in
+ $(AM_V_GEN)sed -e 's,@PYTHON\@,$(PYTHON),g' \