summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-08-12 12:29:42 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2011-08-12 12:29:42 +0000
commited17e82081fc057139efd22cb3d550a4419cb881 (patch)
tree423bb21baf7608789f7decfae76095e42c75adbc /net-dns/ddclient
parentx86 stable per bug 355085 (diff)
downloadgentoo-2-ed17e82081fc057139efd22cb3d550a4419cb881.tar.gz
gentoo-2-ed17e82081fc057139efd22cb3d550a4419cb881.tar.bz2
gentoo-2-ed17e82081fc057139efd22cb3d550a4419cb881.zip
Version bump. Fixes bugs 186271, 212840, 296598 and 373183
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'net-dns/ddclient')
-rw-r--r--net-dns/ddclient/ChangeLog10
-rw-r--r--net-dns/ddclient/ddclient-3.8.1.ebuild66
-rw-r--r--net-dns/ddclient/files/ddclient.initd-r144
-rw-r--r--net-dns/ddclient/metadata.xml9
4 files changed, 120 insertions, 9 deletions
diff --git a/net-dns/ddclient/ChangeLog b/net-dns/ddclient/ChangeLog
index 3af099569c2d..a808a8f513c7 100644
--- a/net-dns/ddclient/ChangeLog
+++ b/net-dns/ddclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/ddclient
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.40 2009/02/24 20:53:58 gentoofan23 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.41 2011/08/12 12:29:42 titanofold Exp $
+
+*ddclient-3.8.1 (12 Aug 2011)
+
+ 12 Aug 2011; Aaron W. Swenson <titanofold@gentoo.org> +ddclient-3.8.1.ebuild,
+ +files/ddclient.initd-r1, metadata.xml:
+ Version bump. Fixes bugs 186271, 212840, 296598 and 373183
24 Feb 2009; Thomas Anderson <gentoofan23@gentoo.org>
ddclient-3.7.3-r1.ebuild, ddclient-3.8.0.ebuild:
diff --git a/net-dns/ddclient/ddclient-3.8.1.ebuild b/net-dns/ddclient/ddclient-3.8.1.ebuild
new file mode 100644
index 000000000000..f79b972e852d
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.8.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ddclient-3.8.1.ebuild,v 1.1 2011/08/12 12:29:42 titanofold Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Perl updater client for dynamic DNS services"
+HOMEPAGE="http://ddclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl"
+
+RDEPEND=">=dev-lang/perl-5.1
+ ssl? ( dev-perl/IO-Socket-SSL )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ # Remove pid line, because it is specified in /etc/conf.d/ddclient
+ einfo "Applying PID setup"
+ if ! sed '/^pid/d' -i "sample-etc_${PN}.conf"; then
+ eerror "Failed to remove pid from /etc/${PN}/${PN}.conf"
+ eerror "Please set the PID in /etc/conf.d/${PN}, not /etc/${PN}/${PN}.conf"
+ fi
+
+ if ! use ssl; then
+ einfo "Disabling SSL per your USE flags"
+ sed '/^ssl/,/ssl-library$/d' -i "sample-etc_${PN}.conf" || \
+ eerror "Failed to remove ssl from /etc/$PN/$PN.conf"
+ fi
+}
+
+src_install() {
+ dosbin ${PN}
+ dodoc Change* COPYRIGHT README* RELEASENOTE sample*
+
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ keepdir /var/{cache,run}/${PN}
+ fowners -R ${PN}:${PN} /var/{cache,run}/${PN}
+
+ insinto /etc/${PN}
+ insopts -m 0600 -o ${PN} -g ${PN}
+ newins sample-etc_${PN}.conf ${PN}.conf
+ newins sample-etc_${PN}.conf ${PN}.conf.sample
+ fowners -R ${PN}:${PN} /etc/${PN}
+}
+
+pkg_postinst() {
+ use ssl && return
+ ewarn
+ ewarn "$PN will not have support for ssl, which means your dynamic DNS account"
+ ewarn "information -- including your password -- will be sent over the Internet in the"
+ ewarn "clear. To secure your information, add 'ssl' to your USEflags,"
+ ewarn "emerge -N ddclient, and add 'ssl=yes' to /etc/$PN/$PN.conf"
+ ewarn
+}
diff --git a/net-dns/ddclient/files/ddclient.initd-r1 b/net-dns/ddclient/files/ddclient.initd-r1
new file mode 100644
index 000000000000..dc2cfe1cfa88
--- /dev/null
+++ b/net-dns/ddclient/files/ddclient.initd-r1
@@ -0,0 +1,44 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/files/ddclient.initd-r1,v 1.1 2011/08/12 12:29:42 titanofold Exp $
+
+# Default location if not specified in /etc/conf.d/ddclient
+PIDFILE=${PIDFILE:-/var/run/ddclient/ddclient.pid}
+
+depend() {
+ before cron
+ need net
+ use dns logger squid
+}
+
+checkconfig() {
+ local conf="/etc/ddclient/ddclient.conf"
+
+ if [ -e "${conf}" ] ; then
+ if [ -n "$(find /etc/ddclient -maxdepth 1 -name ddclient.conf -perm -0044)" ] ; then
+ eerror "${conf} must not be world or group readable. Try:"
+ eerror " chmod 600 ${conf}"
+ eerror " chown ddclient:ddclient ${conf}"
+ return 1
+ fi
+ else
+ eerror "${conf} is needed to run ddclient"
+ eerror "There is a sample file in /etc/ddclient/"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --user ddclient --exec /usr/sbin/ddclient \
+ --name ddclient --pidfile "${PIDFILE}" -- -pid="${PIDFILE}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --signal USR1 --pidfile "${PIDFILE}"
+ eend $?
+}
diff --git a/net-dns/ddclient/metadata.xml b/net-dns/ddclient/metadata.xml
index a09ed31953d1..0e15846b229c 100644
--- a/net-dns/ddclient/metadata.xml
+++ b/net-dns/ddclient/metadata.xml
@@ -3,12 +3,7 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>matthewsmith@iinet.net.au</email>
- <name>Matthew Smith</name>
- <description>Once maintained this indirectly through seemant. He retired. CC on bugs till further notice.</description>
-</maintainer>
-<maintainer>
- <email>tanderson@gentoo.org</email>
- <name>Thomas Anderson</name>
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
</maintainer>
</pkgmetadata>