summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-06-23 19:53:54 +0000
committerJon Portnoy <avenj@gentoo.org>2004-06-23 19:53:54 +0000
commit9c4a593617c848f0f9f3572cd099d402f01a9593 (patch)
treea92df4d7cdd4e573a7ffc699f610c89bb6944015 /net-dns/dnsmasq/dnsmasq-2.9.ebuild
parentUpdate TODOs. (Manifest recommit) (diff)
downloadgentoo-2-9c4a593617c848f0f9f3572cd099d402f01a9593.tar.gz
gentoo-2-9c4a593617c848f0f9f3572cd099d402f01a9593.tar.bz2
gentoo-2-9c4a593617c848f0f9f3572cd099d402f01a9593.zip
version bump
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.9.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.9.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.9.ebuild b/net-dns/dnsmasq/dnsmasq-2.9.ebuild
new file mode 100644
index 000000000000..384f0033298f
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.9.ebuild,v 1.1 2004/06/23 19:53:54 avenj Exp $
+
+MY_P="${P/_/}"
+MY_PV="${PV/_rc*/}"
+DESCRIPTION="Small forwarding DNS server for local networks"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~arm ~amd64 ~ia64 ~s390"
+IUSE=""
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:-O2:\"${CFLAGS}\":" Makefile
+ sed -i "s:-O2:\"${CFLAGS}\":" src/Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dosbin src/dnsmasq || die
+ doman dnsmasq.8
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dnsmasq-init dnsmasq
+ insinto /etc/conf.d
+ newins ${FILESDIR}/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+}