summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2009-12-07 21:42:35 +0000
committerPatrick McLean <chutzpah@gentoo.org>2009-12-07 21:42:35 +0000
commit9f7f545d9b9e7789c76517929c57aa65ea346262 (patch)
treefe7172b8b2c73887aea0fb8d03320373399c451d /net-dns/dnsmasq
parentAdd KEYWORDS from Prefix overlay. (diff)
downloadgentoo-2-9f7f545d9b9e7789c76517929c57aa65ea346262.tar.gz
gentoo-2-9f7f545d9b9e7789c76517929c57aa65ea346262.tar.bz2
gentoo-2-9f7f545d9b9e7789c76517929c57aa65ea346262.zip
Version bump (bug #295470).
(Portage version: 2.1.7.11/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/ChangeLog7
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.51.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 7f53f67b6abf..141a7a0c7e4d 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dnsmasq
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.186 2009/09/20 21:11:01 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.187 2009/12/07 21:42:35 chutzpah Exp $
+
+*dnsmasq-2.51 (07 Dec 2009)
+
+ 07 Dec 2009; Patrick McLean <chutzpah@gentoo.org> +dnsmasq-2.51.ebuild:
+ Version bump (bug #295470).
20 Sep 2009; Alex Legler <a3li@gentoo.org> -dnsmasq-2.45.ebuild:
Non-maintainer commit: Removing vulnerable ebuild, GLSA 200909-19
diff --git a/net-dns/dnsmasq/dnsmasq-2.51.ebuild b/net-dns/dnsmasq/dnsmasq-2.51.ebuild
new file mode 100644
index 000000000000..0f248373d2b4
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.51.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.51.ebuild,v 1.1 2009/12/07 21:42:35 chutzpah Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="dbus +dhcp ipv6 nls tftp"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ || ( app-arch/xz-utils app-arch/lzma-utils )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ sed -i '/^AWK/s:nawk:gawk:' Makefile #214865
+
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${PN}-2.47-fbsd-config.patch"
+}
+
+src_configure() {
+ use tftp || append-flags -DNO_TFTP
+ use dhcp || append-flags -DNO_DHCP
+ use ipv6 || append-flags -DNO_IPV6
+ use dbus && sed -i '$ a #define HAVE_DBUS' src/config.h
+}
+
+src_compile() {
+ emake \
+ PREFIX=/usr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ all$(use nls && echo "-i18n") || die
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install$(use nls && echo "-i18n") || die
+
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+}