summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-01-22 02:42:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-01-22 02:42:49 +0000
commitcc98287dc3d54dfb94e6106be286fe13551c0c55 (patch)
tree3e33d33f1fe7770d8ff018604e4d1acba231f8bc /net-dns/ldns-utils
parentBump per bug #447208. Also fix bug #452770. (diff)
downloadgentoo-2-cc98287dc3d54dfb94e6106be286fe13551c0c55.tar.gz
gentoo-2-cc98287dc3d54dfb94e6106be286fe13551c0c55.tar.bz2
gentoo-2-cc98287dc3d54dfb94e6106be286fe13551c0c55.zip
Bump per bug #447210.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-dns/ldns-utils')
-rw-r--r--net-dns/ldns-utils/ChangeLog9
-rw-r--r--net-dns/ldns-utils/ldns-utils-1.6.16.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/net-dns/ldns-utils/ChangeLog b/net-dns/ldns-utils/ChangeLog
index 44f32fe40482..6323cb150587 100644
--- a/net-dns/ldns-utils/ChangeLog
+++ b/net-dns/ldns-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/ldns-utils
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.21 2012/12/19 18:26:11 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.22 2013/01/22 02:42:49 robbat2 Exp $
+
+*ldns-utils-1.6.16 (22 Jan 2013)
+
+ 22 Jan 2013; Robin H. Johnson <robbat2@gentoo.org> +ldns-utils-1.6.16.ebuild:
+ Bump per bug #447210.
19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ldns-utils-1.6.13.ebuild:
Add ~ia64, wrt bug #441688
diff --git a/net-dns/ldns-utils/ldns-utils-1.6.16.ebuild b/net-dns/ldns-utils/ldns-utils-1.6.16.ebuild
new file mode 100644
index 000000000000..7d685c07e9d0
--- /dev/null
+++ b/net-dns/ldns-utils/ldns-utils-1.6.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ldns-utils-1.6.16.ebuild,v 1.1 2013/01/22 02:42:49 robbat2 Exp $
+
+EAPI="3"
+inherit autotools eutils
+
+MY_P="${P/-utils}"
+DESCRIPTION="Set of utilities to simplify various dns(sec) tasks."
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/ldns/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="ecdsa examples gost ssl"
+
+DEPEND=">=net-libs/ldns-${PV}[ecdsa?,gost?,ssl?]
+ examples? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cd "${S}"/drill
+ econf $(use_with ssl) || die
+
+ if use examples; then
+ cd "${S}"/examples
+ econf \
+ $(use_enable ecdsa) \
+ $(use_enable gost) \
+ $(use_enable ssl sha2) \
+ $(use_with ssl) || die
+ fi
+}
+
+src_compile() {
+ emake -C drill || die "emake for drill failed"
+ if use examples; then
+ emake -C examples || die "emake for examples failed"
+ fi
+}
+
+src_install() {
+ cd "${S}"/drill
+ emake DESTDIR="${D}" install || die "emake install for drill failed"
+ dodoc ChangeLog.22-nov-2005 README REGRESSIONS || die
+
+ if use examples; then
+ cd "${S}"/examples
+ emake DESTDIR="${D}" install || die "emake install for examples failed"
+ newdoc README README.examples || die
+ fi
+}