summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-07-19 01:57:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-07-19 01:57:22 +0000
commit93fb42c03c7914ef7cdd376f02ea8a8c70fd834d (patch)
tree3083ccc49f2c28a0d9d32329ed62816f3647cd52 /net-dns/ndu/ndu-0.4-r1.ebuild
parentfix up warnings, stable 82 on x86. (Manifest recommit) (diff)
downloadgentoo-2-93fb42c03c7914ef7cdd376f02ea8a8c70fd834d.tar.gz
gentoo-2-93fb42c03c7914ef7cdd376f02ea8a8c70fd834d.tar.bz2
gentoo-2-93fb42c03c7914ef7cdd376f02ea8a8c70fd834d.zip
minor tweaks, stable on x86.
Diffstat (limited to 'net-dns/ndu/ndu-0.4-r1.ebuild')
-rw-r--r--net-dns/ndu/ndu-0.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-dns/ndu/ndu-0.4-r1.ebuild b/net-dns/ndu/ndu-0.4-r1.ebuild
new file mode 100644
index 000000000000..a0e48a972434
--- /dev/null
+++ b/net-dns/ndu/ndu-0.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ndu/ndu-0.4-r1.ebuild,v 1.1 2004/07/19 01:57:22 robbat2 Exp $
+
+DESCRIPTION="DNS serial number incrementer and reverse zone builder"
+URI_BASE="http://uranus.it.swin.edu.au/~jn/linux/"
+SRC_URI="${URI_BASE}/${P}.tar.gz"
+HOMEPAGE="${URI_BASE}/dns.htm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="sys-apps/sed virtual/libc"
+RDEPEND="virtual/libc"
+
+src_compile() {
+ cd ${S}/src
+ sed -i 's|gcc|$(CXX)|g' Makefile
+ sed -i 's|#define CONFIG_PATH "/etc/"|#define CONFIG_PATH "/etc/bind/"|g' ndc.c
+ emake
+ sed -i 's|VISUAL|EDITOR|g' dnsedit
+ cd ${S}
+ sed -i 's|0.0.127.in-addr.arpa|127.in-addr.arpa|g' ndu.conf
+ echo '## if you use a chrooted setup, then you need to uncomment these lines:' >>ndu.conf
+ echo '#process "/chroot/dns/named.conf"' >>ndu.conf
+ echo '#chroot "/chroot/dns"' >>ndu.conf
+}
+
+src_install () {
+ into /usr
+ dosbin src/{dnsedit,ndu}
+ dobin src/dnstouch
+ into /
+ insinto /etc/bind
+ doins ndu.conf
+ dodoc README INSTALL
+}