summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-12-18 17:33:17 +0000
committerMichał Górny <mgorny@gentoo.org>2010-12-18 17:33:17 +0000
commit316e5512ef199c89a5bf85e4561b799ad3fc806e (patch)
tree74173e9a62db2f76cd9bf7da6ad6c7c94983a174 /net-dns/openresolv
parentpunt (diff)
downloadgentoo-2-316e5512ef199c89a5bf85e4561b799ad3fc806e.tar.gz
gentoo-2-316e5512ef199c89a5bf85e4561b799ad3fc806e.tar.bz2
gentoo-2-316e5512ef199c89a5bf85e4561b799ad3fc806e.zip
Version bump (on darkside's approval). The package now procides a configure script and pdnsd support. Besides that, multilib libdir is now respected.
(Portage version: 2.2.0_alpha9_p3/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/openresolv')
-rw-r--r--net-dns/openresolv/ChangeLog8
-rw-r--r--net-dns/openresolv/openresolv-3.4.0.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/net-dns/openresolv/ChangeLog b/net-dns/openresolv/ChangeLog
index 0b85a2bddc4b..7c3bdc283a45 100644
--- a/net-dns/openresolv/ChangeLog
+++ b/net-dns/openresolv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/openresolv
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/ChangeLog,v 1.61 2010/09/30 21:30:23 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/ChangeLog,v 1.62 2010/12/18 17:33:17 mgorny Exp $
+
+*openresolv-3.4.0 (18 Dec 2010)
+
+ 18 Dec 2010; Michał Górny <mgorny@gentoo.org> +openresolv-3.4.0.ebuild:
+ Version bump (on darkside's approval). The package now procides a configure
+ script and pdnsd support. Besides that, multilib libdir is now respected.
30 Sep 2010; Brent Baude <ranger@gentoo.org> openresolv-3.3.4.ebuild:
stable ppc64, bug 323887
diff --git a/net-dns/openresolv/openresolv-3.4.0.ebuild b/net-dns/openresolv/openresolv-3.4.0.ebuild
new file mode 100644
index 000000000000..5988f44f4b54
--- /dev/null
+++ b/net-dns/openresolv/openresolv-3.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/openresolv-3.4.0.ebuild,v 1.1 2010/12/18 17:33:17 mgorny Exp $
+
+EAPI=2
+
+inherit base multilib
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="http://roy.marples.name/projects/openresolv"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="!net-dns/resolvconf-gentoo
+ !<net-dns/dnsmasq-2.40-r1"
+RDEPEND=""
+
+src_configure() {
+ econf \
+ --prefix= \
+ --libexecdir=/$(get_libdir)
+}
+
+pkg_postinst() {
+ einfo "${PN}-3.0 has a new configuration file /etc/resolvconf.conf"
+ einfo "instead of mini files in different directories."
+ einfo "You should configure /etc/resolvconf.conf if you use a resolver"
+ einfo "other than libc."
+}
+
+pkg_config() {
+ if [ "${ROOT}" != "/" ]; then
+ eerror "We cannot configure unless \$ROOT=/"
+ return 1
+ fi
+
+ if [ -n "$(resolvconf -l)" ]; then
+ einfo "${PN} already has DNS information"
+ else
+ ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
+ resolvconf -a dummy </etc/resolv.conf
+ eend $? || return $?
+ einfo "The dummy interface will disappear when you next reboot"
+ fi
+}