summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-06-15 18:38:20 +0000
committerSven Wegener <swegener@gentoo.org>2008-06-15 18:38:20 +0000
commit41b37f46e9da190493ebd478a4df86b6cf55d073 (patch)
tree375246fca86d3dd0406065a51b3eb3829f103803 /net-dns/pdns-recursor
parentalpha/ia64/sparc/x86 stable wrt #227179 (diff)
downloadgentoo-2-41b37f46e9da190493ebd478a4df86b6cf55d073.tar.gz
gentoo-2-41b37f46e9da190493ebd478a4df86b6cf55d073.tar.bz2
gentoo-2-41b37f46e9da190493ebd478a4df86b6cf55d073.zip
Add gcc-4.3 compability patch.
(Portage version: 2.1.5.5)
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/ChangeLog6
-rw-r--r--net-dns/pdns-recursor/files/pdns-recursor-3.1.6-gcc-4.3.patch12
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.1.6.ebuild5
3 files changed, 21 insertions, 2 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 3e27d7ea7e05..778440bfcc11 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/pdns-recursor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.19 2008/05/03 14:22:31 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.20 2008/06/15 18:38:19 swegener Exp $
+
+ 15 Jun 2008; Sven Wegener <swegener@gentoo.org>
+ +files/pdns-recursor-3.1.6-gcc-4.3.patch, pdns-recursor-3.1.6.ebuild:
+ Add gcc-4.3 compability patch.
*pdns-recursor-3.1.6 (03 May 2008)
diff --git a/net-dns/pdns-recursor/files/pdns-recursor-3.1.6-gcc-4.3.patch b/net-dns/pdns-recursor/files/pdns-recursor-3.1.6-gcc-4.3.patch
new file mode 100644
index 000000000000..f36db1503531
--- /dev/null
+++ b/net-dns/pdns-recursor/files/pdns-recursor-3.1.6-gcc-4.3.patch
@@ -0,0 +1,12 @@
+gcc-4.3 no longer includes this by default.
+
+--- pdns-recursor-3.1.6/dns_random.cc
++++ pdns-recursor-3.1.6/dns_random.cc
+@@ -1,6 +1,7 @@
+ #include "aescpp.h"
+ #include <iostream>
+ #include <cstring>
++#include <limits>
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <sys/time.h>
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.1.6.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.1.6.ebuild
index b57778e19975..c05c5498d1e4 100644
--- a/net-dns/pdns-recursor/pdns-recursor-3.1.6.ebuild
+++ b/net-dns/pdns-recursor/pdns-recursor-3.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.1.6.ebuild,v 1.1 2008/05/03 14:22:31 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.1.6.ebuild,v 1.2 2008/06/15 18:38:19 swegener Exp $
inherit toolchain-funcs flag-o-matic
@@ -19,6 +19,9 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
sed -i -e s:/var/run/:/var/lib/powerdns: "${S}"/config.h || die
}