summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-06-05 03:34:42 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-06-05 03:34:42 +0000
commit6d0f1cc1c615f8cd95fe0096a2ad0c3e4a1952e6 (patch)
treecc25b065795424f4df37a86d9f084959f22641df /net-dns/pdns
parentInitial import of pdns dns server (diff)
downloadgentoo-2-6d0f1cc1c615f8cd95fe0096a2ad0c3e4a1952e6.tar.gz
gentoo-2-6d0f1cc1c615f8cd95fe0096a2ad0c3e4a1952e6.tar.bz2
gentoo-2-6d0f1cc1c615f8cd95fe0096a2ad0c3e4a1952e6.zip
Initial import of pdns dns server
Diffstat (limited to 'net-dns/pdns')
-rw-r--r--net-dns/pdns/ChangeLog7
-rw-r--r--net-dns/pdns/Manifest6
-rw-r--r--net-dns/pdns/files/digest-pdns-2.9.81
-rw-r--r--net-dns/pdns/files/pdns20
-rw-r--r--net-dns/pdns/pdns-2.9.8.ebuild39
5 files changed, 70 insertions, 3 deletions
diff --git a/net-dns/pdns/ChangeLog b/net-dns/pdns/ChangeLog
new file mode 100644
index 000000000000..671c7ef1c7fa
--- /dev/null
+++ b/net-dns/pdns/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-dns/pdns
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.1 2003/06/05 03:34:20 jhhudso Exp $
+*pdns-2.9.8 (04 Jun 2003)
+
+ 04 Jun 2003; Jared Hudson <jhhudso@gentoo.org> : Initial import.
+
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index af4c66b462e1..e7e2b9505afb 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,4 +1,4 @@
-MD5 4b7e56f0dc934d52ab4960b316696404 ChangeLog 210
-MD5 d5ca54368daa6da0f7b8bed1d6069848 pdns-2.9.8.ebuild 966
-MD5 133dff5b1247c9d87413c08622279827 files/pdns 540
+MD5 6370c1e119eef30cb0699af44269a6eb ChangeLog 296
+MD5 df319f39933b20302fc648764c58da4e pdns-2.9.8.ebuild 917
+MD5 0969ab0b2776f09c9aeb74b0996c4426 files/pdns 533
MD5 edc11ac6841533c59818f2c1fb9f2a01 files/digest-pdns-2.9.8 62
diff --git a/net-dns/pdns/files/digest-pdns-2.9.8 b/net-dns/pdns/files/digest-pdns-2.9.8
new file mode 100644
index 000000000000..019d5a0dbc25
--- /dev/null
+++ b/net-dns/pdns/files/digest-pdns-2.9.8
@@ -0,0 +1 @@
+MD5 fdd443276f50520efbe2e2b608499a11 pdns-2.9.8.tar.gz 607934
diff --git a/net-dns/pdns/files/pdns b/net-dns/pdns/files/pdns
new file mode 100644
index 000000000000..52420abe0086
--- /dev/null
+++ b/net-dns/pdns/files/pdns
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/files/pdns,v 1.1 2003/06/05 03:34:20 jhhudso Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting PowerDNS"
+ start-stop-daemon --start --quiet --exec /usr/bin/env -- /usr/sbin/pdns_server --daemon --guardian=yes
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping PowerDNS"
+ start-stop-daemon --stop --quiet --pidfile=/var/run/pdns.pid
+ eend $?
+}
diff --git a/net-dns/pdns/pdns-2.9.8.ebuild b/net-dns/pdns/pdns-2.9.8.ebuild
new file mode 100644
index 000000000000..3c3019ae733e
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.8.ebuild,v 1.1 2003/06/05 03:34:20 jhhudso Exp $
+
+DESCRIPTION="The PowerDNS Daemon."
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="mysql static"
+
+DEPEND="virtual/glibc
+ mysql? ( >=dev-db/mysql-3.23.54a )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf=""
+
+ use mysql && myconf="$myconf --with-modules=gmysql"
+ use static && myconf="$myconf --enable-static-binaries"
+
+ econf $myconf
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog HACKING INSTALL README TODO WARNING pdns/COPYING
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/pdns
+
+ mv ${D}/etc/pdns.conf-dist ${D}/etc/pdns.conf
+}