summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-03-10 14:03:48 +0000
committerAlin Năstac <mrness@gentoo.org>2007-03-10 14:03:48 +0000
commitd6668612292b2cce7e26fc9ef3c18c805710ab68 (patch)
treea82ef15c9e715fafb3c5264f59f17c554dc50a18 /net-dns/pdnsd
parentFix mono deps (diff)
downloadgentoo-2-d6668612292b2cce7e26fc9ef3c18c805710ab68.tar.gz
gentoo-2-d6668612292b2cce7e26fc9ef3c18c805710ab68.tar.bz2
gentoo-2-d6668612292b2cce7e26fc9ef3c18c805710ab68.zip
Remove references to $ROOT from src_* functions (#168039).
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-dns/pdnsd')
-rw-r--r--net-dns/pdnsd/ChangeLog6
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.4-r1.ebuild71
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.4-r3.ebuild77
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.5.ebuild77
4 files changed, 116 insertions, 115 deletions
diff --git a/net-dns/pdnsd/ChangeLog b/net-dns/pdnsd/ChangeLog
index 8b5784e8ee15..e4c9ee3bdc5b 100644
--- a/net-dns/pdnsd/ChangeLog
+++ b/net-dns/pdnsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/pdnsd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.67 2007/01/16 20:47:38 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.68 2007/03/10 14:03:48 mrness Exp $
+
+ 10 Mar 2007; Alin Năstac <mrness@gentoo.org> pdnsd-1.2.4-r1.ebuild,
+ pdnsd-1.2.4-r3.ebuild, pdnsd-1.2.5.ebuild:
+ Remove references to $ROOT from src_* functions (#168039).
16 Jan 2007; Alin Năstac <mrness@gentoo.org> pdnsd-1.2.5.ebuild:
Stable on amd64.
diff --git a/net-dns/pdnsd/pdnsd-1.2.4-r1.ebuild b/net-dns/pdnsd/pdnsd-1.2.4-r1.ebuild
index 0b15fc96614c..04dd5f0b88e5 100644
--- a/net-dns/pdnsd/pdnsd-1.2.4-r1.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.4-r1.ebuild,v 1.5 2006/11/12 04:09:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.4-r1.ebuild,v 1.6 2007/03/10 14:03:48 mrness Exp $
inherit eutils
@@ -47,17 +47,38 @@ src_compile() {
emake all || die "compile problem"
}
-pkg_preinst() {
- # Duplicated so that binary packages work
- enewgroup pdnsd
- enewuser pdnsd -1 -1 /var/lib/pdnsd pdnsd
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog* NEWS README THANKS TODO README.par
+ docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
+ docinto html ; dohtml doc/html/*
+ docinto txt ; dodoc doc/txt/*
+ newdoc doc/pdnsd.conf pdnsd.conf.sample
+
+ newinitd "${FILESDIR}/pdnsd.rc6" pdnsd
+ newinitd "${FILESDIR}/pdnsd.online" pdnsd-online
+
+ keepdir /etc/conf.d
+ local config="${D}/etc/conf.d/pdnsd-online"
+
+ echo -e "# Enter the interface that connects you to the dns servers" >> "${config}"
+ echo "# This will correspond to /etc/init.d/net.${IFACE}" >> "${config}"
+ echo -e "\n# IMPORTANT: Be sure to run depscan.sh after modifiying IFACE" >> "${config}"
+ echo "IFACE=ppp0" >> "${config}"
+
+ config="${D}/etc/conf.d/pdnsd"
+ "${D}/usr/sbin/pdnsd" --help | sed "s/^/# /g" > "${config}"
+ echo "# Command line options" >> "${config}"
+ use ipv6 && echo PDNSDCONFIG="-a" >> "${config}" \
+ || echo PDNSDCONFIG="" >> "${config}"
}
src_test() {
if [ -x /usr/bin/dig ]; then
mkdir "${T}/pdnsd"
echo -n -e "pd12\0\0\0\0" > "${T}/pdnsd/pdnsd.cache"
- IPS=$(grep ^nameserver "${ROOT}/etc/resolv.conf" | sed -e 's/nameserver \(.*\)/\tip=\1;/g' | xargs)
+ IPS=$(grep ^nameserver /etc/resolv.conf | sed -e 's/nameserver \(.*\)/\tip=\1;/g' | xargs)
sed -e "s/\tip=/${IPS}/" -e "s:cache_dir=:cache_dir=${T}/pdnsd:" "${FILESDIR}/pdnsd.conf.test" \
> "${T}/pdnsd.conf.test"
src/pdnsd -c "${T}/pdnsd.conf.test" -g -s -d -p "${T}/pid" || die "couldn't start daemon"
@@ -75,40 +96,18 @@ src_test() {
fi
}
-src_install() {
- emake DESTDIR="${D}" install || die
+pkg_preinst() {
+ # Duplicated so that binary packages work
+ enewgroup pdnsd
+ enewuser pdnsd -1 -1 /var/lib/pdnsd pdnsd
- # Copy cache from prev older versions
+ # Copy cache from older versions
[ -f "${ROOT}/var/lib/pdnsd/pdnsd.cache" ] && \
cp "${ROOT}/var/lib/pdnsd/pdnsd.cache" "${D}/var/cache/pdnsd/pdnsd.cache"
- # Don't clobber existing cache - copy prev cache so unmerging prev version
- # doesn't remove the cache.
+ # Preserve the cache from previous version
[ -f "${ROOT}/var/cache/pdnsd/pdnsd.cache" ] && \
- rm "${D}/var/cache/pdnsd/pdnsd.cache"
-
- dodoc AUTHORS ChangeLog* NEWS README THANKS TODO README.par
- docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
- docinto html ; dohtml doc/html/*
- docinto txt ; dodoc doc/txt/*
- newdoc doc/pdnsd.conf pdnsd.conf.sample
-
- newinitd "${FILESDIR}/pdnsd.rc6" pdnsd
- newinitd "${FILESDIR}/pdnsd.online" pdnsd-online
-
- keepdir /etc/conf.d
- local config="${D}/etc/conf.d/pdnsd-online"
-
- echo -e "# Enter the interface that connects you to the dns servers" >> "${config}"
- echo "# This will correspond to /etc/init.d/net.${IFACE}" >> "${config}"
- echo -e "\n# IMPORTANT: Be sure to run depscan.sh after modifiying IFACE" >> "${config}"
- echo "IFACE=ppp0" >> "${config}"
-
- config="${D}/etc/conf.d/pdnsd"
- "${D}/usr/sbin/pdnsd" --help | sed "s/^/# /g" > "${config}"
- echo "# Command line options" >> "${config}"
- use ipv6 && echo PDNSDCONFIG="-a" >> "${config}" \
- || echo PDNSDCONFIG="" >> "${config}"
+ cp "${ROOT}/var/cache/pdnsd/pdnsd.cache" "${D}/var/cache/pdnsd/pdnsd.cache"
}
pkg_postinst() {
diff --git a/net-dns/pdnsd/pdnsd-1.2.4-r3.ebuild b/net-dns/pdnsd/pdnsd-1.2.4-r3.ebuild
index 83b00a3f86d6..ae3a73e2e980 100644
--- a/net-dns/pdnsd/pdnsd-1.2.4-r3.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.4-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.4-r3.ebuild,v 1.5 2006/11/12 04:09:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.4-r3.ebuild,v 1.6 2007/03/10 14:03:48 mrness Exp $
inherit eutils
@@ -47,46 +47,9 @@ src_compile() {
emake all || die "compile problem"
}
-pkg_preinst() {
- # Duplicated so that binary packages work
- enewgroup pdnsd
- enewuser pdnsd -1 -1 /var/lib/pdnsd pdnsd
-}
-
-src_test() {
- if [ -x /usr/bin/dig ]; then
- mkdir "${T}/pdnsd"
- echo -n -e "pd12\0\0\0\0" > "${T}/pdnsd/pdnsd.cache"
- IPS=$(grep ^nameserver "${ROOT}/etc/resolv.conf" | sed -e 's/nameserver \(.*\)/\tip=\1;/g' | xargs)
- sed -e "s/\tip=/${IPS}/" -e "s:cache_dir=:cache_dir=${T}/pdnsd:" "${FILESDIR}/pdnsd.conf.test" \
- > "${T}/pdnsd.conf.test"
- src/pdnsd -c "${T}/pdnsd.conf.test" -g -s -d -p "${T}/pid" || die "couldn't start daemon"
- sleep 3
-
- find "${T}" -ls
- [ -s "${T}/pid" ] || die "empty or no pid file created"
- [ -S "${T}/pdnsd/pdnsd.status" ] || die "no socket created"
- src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" server all up || die "failed to start the daemon"
- src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" status || die "failed to communicate with the daemon"
- sleep 3
-
- dig @127.0.0.1 -p 33455 www.gentoo.org | fgrep "status: NOERROR" || die "www.gentoo.org lookup failed"
- kill $(<"${T}/pid") || die "failed to terminate daemon"
- fi
-}
-
src_install() {
emake DESTDIR="${D}" install || die
- # Copy cache from prev older versions
- [ -f "${ROOT}/var/lib/pdnsd/pdnsd.cache" ] && \
- cp "${ROOT}/var/lib/pdnsd/pdnsd.cache" "${D}/var/cache/pdnsd/pdnsd.cache"
-
- # Don't clobber existing cache - copy prev cache so unmerging prev version
- # doesn't remove the cache.
- [ -f "${ROOT}/var/cache/pdnsd/pdnsd.cache" ] && \
- rm "${D}/var/cache/pdnsd/pdnsd.cache"
-
dodoc AUTHORS ChangeLog* NEWS README THANKS TODO README.par
docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
docinto html ; dohtml doc/html/*
@@ -115,6 +78,42 @@ src_install() {
newexe "${FILESDIR}/pdnsd.resolvconf" pdnsd
}
+src_test() {
+ if [ -x /usr/bin/dig ]; then
+ mkdir "${T}/pdnsd"
+ echo -n -e "pd12\0\0\0\0" > "${T}/pdnsd/pdnsd.cache"
+ IPS=$(grep ^nameserver /etc/resolv.conf | sed -e 's/nameserver \(.*\)/\tip=\1;/g' | xargs)
+ sed -e "s/\tip=/${IPS}/" -e "s:cache_dir=:cache_dir=${T}/pdnsd:" "${FILESDIR}/pdnsd.conf.test" \
+ > "${T}/pdnsd.conf.test"
+ src/pdnsd -c "${T}/pdnsd.conf.test" -g -s -d -p "${T}/pid" || die "couldn't start daemon"
+ sleep 3
+
+ find "${T}" -ls
+ [ -s "${T}/pid" ] || die "empty or no pid file created"
+ [ -S "${T}/pdnsd/pdnsd.status" ] || die "no socket created"
+ src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" server all up || die "failed to start the daemon"
+ src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" status || die "failed to communicate with the daemon"
+ sleep 3
+
+ dig @127.0.0.1 -p 33455 www.gentoo.org | fgrep "status: NOERROR" || die "www.gentoo.org lookup failed"
+ kill $(<"${T}/pid") || die "failed to terminate daemon"
+ fi
+}
+
+pkg_preinst() {
+ # Duplicated so that binary packages work
+ enewgroup pdnsd
+ enewuser pdnsd -1 -1 /var/lib/pdnsd pdnsd
+
+ # Copy cache from older versions
+ [ -f "${ROOT}/var/lib/pdnsd/pdnsd.cache" ] && \
+ cp "${ROOT}/var/lib/pdnsd/pdnsd.cache" "${D}/var/cache/pdnsd/pdnsd.cache"
+
+ # Preserve the cache from previous version
+ [ -f "${ROOT}/var/cache/pdnsd/pdnsd.cache" ] && \
+ cp "${ROOT}/var/cache/pdnsd/pdnsd.cache" "${D}/var/cache/pdnsd/pdnsd.cache"
+}
+
pkg_postinst() {
einfo
einfo "Add pdnsd to your default runlevel - rc-update add pdnsd default"
diff --git a/net-dns/pdnsd/pdnsd-1.2.5.ebuild b/net-dns/pdnsd/pdnsd-1.2.5.ebuild
index 1299abbd54cf..f7e00fec4e16 100644
--- a/net-dns/pdnsd/pdnsd-1.2.5.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.5.ebuild,v 1.5 2007/01/16 20:47:38 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.5.ebuild,v 1.6 2007/03/10 14:03:48 mrness Exp $
inherit eutils
@@ -40,45 +40,8 @@ src_compile() {
emake all || die "compile problem"
}
-pkg_preinst() {
- # Duplicated so that binary packages work
- enewgroup pdnsd
- enewuser pdnsd -1 -1 /var/lib/pdnsd pdnsd
-}
-
-src_test() {
- if [ -x /usr/bin/dig ]; then
- mkdir "${T}/pdnsd"
- echo -n -e "pd12\0\0\0\0" > "${T}/pdnsd/pdnsd.cache"
- IPS=$(grep ^nameserver "${ROOT}/etc/resolv.conf" | sed -e 's/nameserver \(.*\)/\tip=\1;/g' | xargs)
- sed -e "s/\tip=/${IPS}/" -e "s:cache_dir=:cache_dir=${T}/pdnsd:" "${FILESDIR}/pdnsd.conf.test" \
- > "${T}/pdnsd.conf.test"
- src/pdnsd -c "${T}/pdnsd.conf.test" -g -s -d -p "${T}/pid" || die "couldn't start daemon"
- sleep 3
-
- find "${T}" -ls
- [ -s "${T}/pid" ] || die "empty or no pid file created"
- [ -S "${T}/pdnsd/pdnsd.status" ] || die "no socket created"
- src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" server all up || die "failed to start the daemon"
- src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" status || die "failed to communicate with the daemon"
- sleep 3
-
- dig @127.0.0.1 -p 33455 www.gentoo.org | fgrep "status: NOERROR" || die "www.gentoo.org lookup failed"
- kill $(<"${T}/pid") || die "failed to terminate daemon"
- fi
-}
-
src_install() {
- emake DESTDIR="${D}" install || die
-
- # Copy cache from prev older versions
- [ -f "${ROOT}/var/lib/pdnsd/pdnsd.cache" ] && \
- cp "${ROOT}/var/lib/pdnsd/pdnsd.cache" "${D}/var/cache/pdnsd/pdnsd.cache"
-
- # Don't clobber existing cache - copy prev cache so unmerging prev version
- # doesn't remove the cache.
- [ -f "${ROOT}/var/cache/pdnsd/pdnsd.cache" ] && \
- rm "${D}/var/cache/pdnsd/pdnsd.cache"
+ emake DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog* NEWS README THANKS TODO README.par
docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
@@ -108,6 +71,42 @@ src_install() {
newexe "${FILESDIR}/pdnsd.resolvconf" pdnsd
}
+src_test() {
+ if [ -x /usr/bin/dig ]; then
+ mkdir "${T}/pdnsd"
+ echo -n -e "pd12\0\0\0\0" > "${T}/pdnsd/pdnsd.cache"
+ IPS=$(grep ^nameserver /etc/resolv.conf | sed -e 's/nameserver \(.*\)/\tip=\1;/g' | xargs)
+ sed -e "s/\tip=/${IPS}/" -e "s:cache_dir=:cache_dir=${T}/pdnsd:" "${FILESDIR}/pdnsd.conf.test" \
+ > "${T}/pdnsd.conf.test"
+ src/pdnsd -c "${T}/pdnsd.conf.test" -g -s -d -p "${T}/pid" || die "couldn't start daemon"
+ sleep 3
+
+ find "${T}" -ls
+ [ -s "${T}/pid" ] || die "empty or no pid file created"
+ [ -S "${T}/pdnsd/pdnsd.status" ] || die "no socket created"
+ src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" server all up || die "failed to start the daemon"
+ src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" status || die "failed to communicate with the daemon"
+ sleep 3
+
+ dig @127.0.0.1 -p 33455 www.gentoo.org | fgrep "status: NOERROR" || die "www.gentoo.org lookup failed"
+ kill $(<"${T}/pid") || die "failed to terminate daemon"
+ fi
+}
+
+pkg_preinst() {
+ # Duplicated so that binary packages work
+ enewgroup pdnsd
+ enewuser pdnsd -1 -1 /var/lib/pdnsd pdnsd
+
+ # Copy cache from older versions
+ [ -f "${ROOT}/var/lib/pdnsd/pdnsd.cache" ] && \
+ cp "${ROOT}/var/lib/pdnsd/pdnsd.cache" "${D}/var/cache/pdnsd/pdnsd.cache"
+
+ # Preserve the cache from previous version
+ [ -f "${ROOT}/var/cache/pdnsd/pdnsd.cache" ] && \
+ cp "${ROOT}/var/cache/pdnsd/pdnsd.cache" "${D}/var/cache/pdnsd/pdnsd.cache"
+}
+
pkg_postinst() {
einfo
einfo "Add pdnsd to your default runlevel - rc-update add pdnsd default"