summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-02-15 05:43:14 +0000
committerNick Hadaway <raker@gentoo.org>2003-02-15 05:43:14 +0000
commit07a5711031be5897ac2a2a2df5b9d1e3cb217bd0 (patch)
tree61cf71cc59a745581127f1e623a288bbf57995a5 /net-dns
parentspurious dot (diff)
downloadgentoo-2-07a5711031be5897ac2a2a2df5b9d1e3cb217bd0.tar.gz
gentoo-2-07a5711031be5897ac2a2a2df5b9d1e3cb217bd0.tar.bz2
gentoo-2-07a5711031be5897ac2a2a2df5b9d1e3cb217bd0.zip
version bump for a more robust localhost config
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind/ChangeLog8
-rw-r--r--net-dns/bind/bind-9.2.2_rc1-r2.ebuild145
-rw-r--r--net-dns/bind/files/12711
-rw-r--r--net-dns/bind/files/127.0.04
-rw-r--r--net-dns/bind/files/digest-bind-9.2.2_rc1-r21
-rw-r--r--net-dns/bind/files/named.conf2
-rw-r--r--net-dns/bind/files/named.conf-r142
7 files changed, 207 insertions, 6 deletions
diff --git a/net-dns/bind/ChangeLog b/net-dns/bind/ChangeLog
index f779733be175..b04b35a2331f 100644
--- a/net-dns/bind/ChangeLog
+++ b/net-dns/bind/ChangeLog
@@ -1,9 +1,11 @@
# ChangeLog for net-dns/bind
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.17 2003/02/15 05:14:50 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.18 2003/02/15 05:43:14 raker Exp $
- 14 Feb 2003; Nick Hadaway <raker@gentoo.org> files/127.0.0,
- files/named.conf :
+*bind-9.2.2_rc1-r2 (14 Feb 2003)
+
+ 14 Feb 2003; Nick Hadaway <raker@gentoo.org> bind-9.2.2_rc1-r2.ebuild,
+ files/digest-bind-9.2.2_rc1-r2, files/127, files/named.conf-r1 :
Updated default config so all 127.* traffic is localhost. Thanks
to Rich Edelman on bug #15637 for noticing this.
diff --git a/net-dns/bind/bind-9.2.2_rc1-r2.ebuild b/net-dns/bind/bind-9.2.2_rc1-r2.ebuild
new file mode 100644
index 000000000000..d709da23f718
--- /dev/null
+++ b/net-dns/bind/bind-9.2.2_rc1-r2.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2_rc1-r2.ebuild,v 1.1 2003/02/15 05:43:14 raker Exp $
+
+IUSE="ssl ipv6 doc"
+
+MY_P=${P/_}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV/_}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9-beta.html"
+
+KEYWORDS="x86 ppc sparc alpha"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="sys-apps/groff
+ ssl? ( >=dev-libs/openssl-0.9.6g )"
+
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz && cd ${S}
+
+ # Adjusting PATHs in manpages
+ for i in `echo bin/{named/named.8,check/named-checkconf.8,nsupdate/nsupdate.8,rndc/rndc.8}`; do
+ sed -e 's:/etc/named.conf:/etc/bind/named.conf:g' -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
+ -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' < ${i} > ${i}.new
+ mv --force ${i}.new ${i} ; done
+}
+
+src_compile() {
+ local myconf=""
+
+ use ssl && myconf="${myconf} --with-openssl"
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
+
+ econf --sysconfdir=/etc/bind \
+ --localstatedir=/var \
+ --enable-threads \
+ --with-libtool \
+ ${myconf}
+
+ make || die "failed to compile bind"
+}
+
+src_install() {
+ einstall
+
+ dodoc CHANGES COPYRIGHT FAQ README
+
+ use doc && {
+ docinto misc ; dodoc doc/misc/*
+ docinto html ; dodoc doc/arm/*
+ docinto draft ; dodoc doc/draft/*
+ docinto rfc ; dodoc doc/rfc/*
+ docinto contrib ; dodoc contrib/named-bootconf/named-bootconf.sh \
+ contrib/nanny/nanny.pl
+ }
+
+ # some handy-dandy dynamic dns examples
+ cd ${D}/usr/share/doc/${PF}
+ tar pjxf ${FILESDIR}/dyndns-samples.tbz2
+
+ dodir /etc/bind /var/bind/{pri,sec}
+
+ insinto /etc/bind ; newins ${FILESDIR}/named.conf-r1 named.conf
+ # ftp://ftp.rs.internic.net/domain/named.ca:
+ insinto /var/bind ; doins ${FILESDIR}/named.ca
+ insinto /var/bind/pri ; doins ${FILESDIR}/{127,localhost}
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/named.rc6 named
+ insinto /etc/conf.d ; newins ${FILESDIR}/named.confd named
+
+ dosym ../../var/bind/named.ca /var/bind/root.cache
+ dosym ../../var/bind/pri /etc/bind/pri
+ dosym ../../var/bind/sec /etc/bind/sec
+}
+
+pkg_preinst() {
+ # Let's get rid of those tools and their manpages since they're provided by bind-tools
+ rm -f ${D}/usr/share/man/man1/{dig.1.gz,host.1.gz}
+ rm -f ${D}/usr/bin/{dig,host,nslookup}
+}
+
+pkg_postinst() {
+ if [ ! -f '/etc/bind/rndc.key' ]; then
+ /usr/sbin/rndc-confgen -a -u named
+ fi
+
+ install -d -o named -g named ${ROOT}/var/run/named \
+ ${ROOT}/var/bind/pri ${ROOT}/var/bind/sec
+ chown -R named:named ${ROOT}/var/bind
+
+ echo
+ einfo "You can edit /etc/conf.d/named to customize named settings"
+ echo
+ einfo "The BIND ebuild now includes chroot support."
+ einfo "If you like to run bind in chroot AND this is a new install OR"
+ einfo "your bind doesn't already run in chroot, simply run:"
+ einfo "\`ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\`"
+ einfo "Before running the above command you might want to change the chroot"
+ einfo "dir in /etc/conf.d/named. Otherwise /chroot/dns will be used."
+ echo
+}
+
+pkg_config() {
+
+ CHROOT=`sed -n 's/^[[:blank:]]\?CHROOT="\([^"]\+\)"/\1/p' /etc/conf.d/named 2>/dev/null`
+
+ if [ -z "$CHROOT" -a ! -d "/chroot/dns" ]; then
+ CHROOT="/chroot/dns"
+ elif [ -d ${CHROOT} ]; then
+ eerror; eerror "${CHROOT:-/chroot/dns} already exists. Quitting."; eerror; EXISTS="yes"
+ fi
+
+ if [ ! "$EXISTS" = yes ]; then
+ echo ; einfon "Setting up the chroot directory..."
+ mkdir -m 700 -p ${CHROOT}
+ mkdir -p ${CHROOT}/{dev,etc,var/run/named}
+ chown -R named:named ${CHROOT}/var/run/named
+ cp -R /etc/bind ${CHROOT}/etc/
+ cp /etc/localtime ${CHROOT}/etc/localtime
+ chown named:named ${CHROOT}/etc/bind/rndc.key
+ cp -R /var/bind ${CHROOT}/var/
+ chown -R named:named ${CHROOT}/var/
+ mknod ${CHROOT}/dev/zero c 1 5
+ mknod ${CHROOT}/dev/random c 1 8
+ chmod 666 ${CHROOT}/dev/{random,zero}
+ chown named:named ${CHROOT}
+
+ grep -q "^#[[:blank:]]\?CHROOT" /etc/conf.d/named ; RETVAL=$?
+ if [ $RETVAL = 0 ]; then
+ sed 's/^# \?\(CHROOT.*\)$/\1/' /etc/conf.d/named > /etc/conf.d/named.orig 2>/dev/null
+ mv --force /etc/conf.d/named.orig /etc/conf.d/named
+ fi
+
+ sleep 1; echo " Done."; sleep 1
+ echo
+ einfo "Add the following to your root .bashrc or .bash_profile: "
+ einfo " alias rndc='rndc -k ${CHROOT}/etc/bind/rndc.key'"
+ einfo "Then do the following: "
+ einfo " source /root/.bashrc or .bash_profile"
+ echo
+ fi
+}
diff --git a/net-dns/bind/files/127 b/net-dns/bind/files/127
new file mode 100644
index 000000000000..eeb2af97c524
--- /dev/null
+++ b/net-dns/bind/files/127
@@ -0,0 +1,11 @@
+$ORIGIN 127.in-addr.arpa.
+$TTL 1W
+@ 1D IN SOA localhost. root.localhost. (
+ 2002081601 ; serial
+ 3H ; refresh
+ 15M ; retry
+ 1W ; expiry
+ 1D ) ; minimum
+
+ 1D IN NS localhost.
+* 1D IN PTR localhost.
diff --git a/net-dns/bind/files/127.0.0 b/net-dns/bind/files/127.0.0
index eeb2af97c524..8c37965ae775 100644
--- a/net-dns/bind/files/127.0.0
+++ b/net-dns/bind/files/127.0.0
@@ -1,4 +1,4 @@
-$ORIGIN 127.in-addr.arpa.
+$ORIGIN 127.0.0.in-addr.arpa.
$TTL 1W
@ 1D IN SOA localhost. root.localhost. (
2002081601 ; serial
@@ -8,4 +8,4 @@ $TTL 1W
1D ) ; minimum
1D IN NS localhost.
-* 1D IN PTR localhost.
+1 1D IN PTR localhost.
diff --git a/net-dns/bind/files/digest-bind-9.2.2_rc1-r2 b/net-dns/bind/files/digest-bind-9.2.2_rc1-r2
new file mode 100644
index 000000000000..f599f5e0e918
--- /dev/null
+++ b/net-dns/bind/files/digest-bind-9.2.2_rc1-r2
@@ -0,0 +1 @@
+MD5 e591be8890c53845133577ac7e042fb6 bind-9.2.2rc1.tar.gz 5049320
diff --git a/net-dns/bind/files/named.conf b/net-dns/bind/files/named.conf
index bb4f63809532..eda1564a4c11 100644
--- a/net-dns/bind/files/named.conf
+++ b/net-dns/bind/files/named.conf
@@ -34,7 +34,7 @@ zone "localhost" IN {
notify no;
};
-zone "127.in-addr.arpa" IN {
+zone "127.0.0.in-addr.arpa" IN {
type master;
file "pri/127.0.0";
allow-update { none; };
diff --git a/net-dns/bind/files/named.conf-r1 b/net-dns/bind/files/named.conf-r1
new file mode 100644
index 000000000000..9b7b2a91fdc6
--- /dev/null
+++ b/net-dns/bind/files/named.conf-r1
@@ -0,0 +1,42 @@
+options {
+ directory "/var/bind";
+
+ // uncomment the following lines to turn on DNS forwarding,
+ // and change the forwarind ip address(es) :
+ //forward first;
+ //forwarders {
+ // 123.123.123.123
+ // 123,123.123.123;
+ //};
+
+ listen-on-v6 { none; };
+ listen-on { 127.0.0.1; };
+
+ // to allow only specific hosts to use the DNS server:
+ //allow-query {
+ // 127.0.0.1;
+ //};
+
+ // if you have problems and are behind a firewall:
+ //query-source address * port 53;
+ pid-file "/var/run/named/named.pid";
+};
+
+zone "." IN {
+ type hint;
+ file "named.ca";
+};
+
+zone "localhost" IN {
+ type master;
+ file "pri/localhost";
+ allow-update { none; };
+ notify no;
+};
+
+zone "127.in-addr.arpa" IN {
+ type master;
+ file "pri/127";
+ allow-update { none; };
+ notify no;
+};