summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-08-21 08:21:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-08-21 08:21:19 +0000
commit0935252a8051410c7de95435207a9ba911fade81 (patch)
tree7f45cf97cdab15f68979e12cd636002601caff5d /net-dns
parentOrder dependencies alphabetically and tighten up formatting (diff)
downloadgentoo-2-0935252a8051410c7de95435207a9ba911fade81.tar.gz
gentoo-2-0935252a8051410c7de95435207a9ba911fade81.tar.bz2
gentoo-2-0935252a8051410c7de95435207a9ba911fade81.zip
Version bump to 1.3.0. Thanks to Ondra Caletka.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/ChangeLog9
-rw-r--r--net-dns/knot/files/knot-move-pidfile-to-var.patch22
-rw-r--r--net-dns/knot/knot-1.2.0.ebuild62
-rw-r--r--net-dns/knot/knot-1.3.0.ebuild (renamed from net-dns/knot/knot-1.1.3.ebuild)25
-rw-r--r--net-dns/knot/metadata.xml3
5 files changed, 22 insertions, 99 deletions
diff --git a/net-dns/knot/ChangeLog b/net-dns/knot/ChangeLog
index 1cfcb9dbb8ff..40a33242226d 100644
--- a/net-dns/knot/ChangeLog
+++ b/net-dns/knot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/knot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/ChangeLog,v 1.18 2013/04/03 17:34:47 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/ChangeLog,v 1.19 2013/08/21 08:21:19 scarabeus Exp $
+
+*knot-1.3.0 (21 Aug 2013)
+
+ 21 Aug 2013; Tomáš Chvátal <scarabeus@gentoo.org> +knot-1.3.0.ebuild,
+ -files/knot-move-pidfile-to-var.patch, -knot-1.1.3.ebuild, -knot-1.2.0.ebuild,
+ metadata.xml:
+ Version bump to 1.3.0. Thanks to Ondra Caletka.
*knot-1.2.0 (03 Apr 2013)
diff --git a/net-dns/knot/files/knot-move-pidfile-to-var.patch b/net-dns/knot/files/knot-move-pidfile-to-var.patch
deleted file mode 100644
index 0e5e11424bb0..000000000000
--- a/net-dns/knot/files/knot-move-pidfile-to-var.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/src/knot/common.h
-+++ b/src/knot/common.h
-@@ -42,7 +42,7 @@ typedef unsigned int uint; /*!< \brief U
-
- #define PROJECT_EXEC SBINDIR "/" "knotd" /*!< \brief Project executable. */
- #define ZONEPARSER_EXEC LIBEXECDIR "/" "knot-zcompile" /*!< \brief Zoneparser executable. */
--#define PID_FILE "knot.pid" /*!< \brief Server PID file name. */
-+#define PID_FILE "/var/run/knotd.pid" /*!< \brief Server PID file name. */
-
- /*
- * Server.
---- a/src/knot/conf/conf.c
-+++ b/src/knot/conf/conf.c
-@@ -198,7 +198,7 @@ static int conf_process(conf_t *conf)
-
- // Create PID file
- if (conf->pidfile == NULL) {
-- conf->pidfile = strcdup(conf->storage, "/" PID_FILE);
-+ conf->pidfile = strdup(PID_FILE);
- if (conf->pidfile == NULL) {
- return KNOTD_ENOMEM;
- }
diff --git a/net-dns/knot/knot-1.2.0.ebuild b/net-dns/knot/knot-1.2.0.ebuild
deleted file mode 100644
index ec131f71a87a..000000000000
--- a/net-dns/knot/knot-1.2.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/knot-1.2.0.ebuild,v 1.1 2013/04/03 17:34:46 scarabeus Exp $
-
-EAPI=5
-
-inherit eutils autotools
-
-DESCRIPTION="High-performance authoritative-only DNS server"
-HOMEPAGE="http://www.knot-dns.cz/"
-SRC_URI="http://public.nic.cz/files/knot-dns/${P/_/-}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RDEPEND="
- dev-libs/openssl
- dev-libs/userspace-rcu
-"
-# sys-libs/glibc
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/flex
- virtual/yacc
-"
-
-S="${WORKDIR}/${P/_/-}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-move-pidfile-to-var.patch
- sed -i \
- -e 's:-Werror::g' \
- configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- --sysconfdir="${EPREFIX}/etc/${PN}" \
- --libexecdir="${EPREFIX}/usr/libexec/${PN}" \
- --disable-lto \
- --enable-recvmmsg \
- $(use_enable debug debug server,zones,xfr,packet,dname,rr,ns,hash,compiler) \
- $(use_enable debug debuglevel details)
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}/knot.init" knot-dns
-}
-
-pkg_postinst() {
- if [[ -n ${REPLACING_VERSIONS} ]] ; then
- elog "Remember to recompile all zones after update. Run:"
- elog " # knotc stop"
- elog " # knotc compile"
- elog " # knotc start"
- fi
-}
diff --git a/net-dns/knot/knot-1.1.3.ebuild b/net-dns/knot/knot-1.3.0.ebuild
index e13b37a06346..0ded794ee49f 100644
--- a/net-dns/knot/knot-1.1.3.ebuild
+++ b/net-dns/knot/knot-1.3.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/knot-1.1.3.ebuild,v 1.2 2013/01/04 13:27:28 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/knot-1.3.0.ebuild,v 1.1 2013/08/21 08:21:18 scarabeus Exp $
EAPI=5
-inherit eutils autotools
+inherit eutils autotools user
DESCRIPTION="High-performance authoritative-only DNS server"
HOMEPAGE="http://www.knot-dns.cz/"
@@ -13,23 +13,24 @@ SRC_URI="http://public.nic.cz/files/knot-dns/${P/_/-}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug"
+IUSE="debug caps +fastparser"
RDEPEND="
dev-libs/openssl
dev-libs/userspace-rcu
+ caps? ( sys-libs/libcap-ng )
"
# sys-libs/glibc
DEPEND="${RDEPEND}
virtual/pkgconfig
sys-devel/flex
virtual/yacc
+ fastparser? ( dev-util/ragel )
"
S="${WORKDIR}/${P/_/-}"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-move-pidfile-to-var.patch
sed -i \
-e 's:-Werror::g' \
configure.ac || die
@@ -38,25 +39,21 @@ src_prepare() {
src_configure() {
econf \
- --sysconfdir="${EPREFIX}/etc/${PN}" \
- --libexecdir="${EPREFIX}/usr/libexec/${PN}" \
+ --with-storage="${EPREFIX}/var/lib/${PN}" \
+ --with-rundir="${EPREFIX}/var/run/${PN}" \
--disable-lto \
--enable-recvmmsg \
+ $(use_enable fastparser) \
$(use_enable debug debug server,zones,xfr,packet,dname,rr,ns,hash,compiler) \
$(use_enable debug debuglevel details)
}
src_install() {
default
-
- newinitd "${FILESDIR}/knot.init" knot-dns
+ newinitd "${FILESDIR}/knot.init" knot
}
pkg_postinst() {
- if [[ -n ${REPLACING_VERSIONS} ]] ; then
- elog "Remember to recompile all zones after update. Run:"
- elog " # knotc stop"
- elog " # knotc compile"
- elog " # knotc start"
- fi
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
}
diff --git a/net-dns/knot/metadata.xml b/net-dns/knot/metadata.xml
index befadac9db4c..6f82d6ca0fc2 100644
--- a/net-dns/knot/metadata.xml
+++ b/net-dns/knot/metadata.xml
@@ -4,4 +4,7 @@
<maintainer>
<email>scarabeus@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name="fastparser">Enables fast DNS zone parser.</flag>
+ </use>
</pkgmetadata>