summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-01-07 19:19:28 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-01-07 19:19:28 +0000
commit28e7f153765a89b1f252ce2e005898ba3e779296 (patch)
treea999c50e725958965d3a1151bc7c50ef5fde3bdd /net-dns
parentVersion bump, #254134 (diff)
downloadgentoo-2-28e7f153765a89b1f252ce2e005898ba3e779296.tar.gz
gentoo-2-28e7f153765a89b1f252ce2e005898ba3e779296.tar.bz2
gentoo-2-28e7f153765a89b1f252ce2e005898ba3e779296.zip
Version bump, #254134
(Portage version: 2.2_rc20/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind-tools/ChangeLog10
-rw-r--r--net-dns/bind-tools/bind-tools-9.4.3_p1.ebuild83
2 files changed, 91 insertions, 2 deletions
diff --git a/net-dns/bind-tools/ChangeLog b/net-dns/bind-tools/ChangeLog
index 7514c9951671..8d552e8eeed7 100644
--- a/net-dns/bind-tools/ChangeLog
+++ b/net-dns/bind-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/bind-tools
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.115 2008/12/26 22:34:47 dertobi123 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.116 2009/01/07 19:19:28 dertobi123 Exp $
+
+*bind-tools-9.4.3_p1 (07 Jan 2009)
+
+ 07 Jan 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +bind-tools-9.4.3_p1.ebuild:
+ Version bump, #254134
*bind-tools-9.6.0 (26 Dec 2008)
diff --git a/net-dns/bind-tools/bind-tools-9.4.3_p1.ebuild b/net-dns/bind-tools/bind-tools-9.4.3_p1.ebuild
new file mode 100644
index 000000000000..0be5d325ceaf
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.4.3_p1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.4.3_p1.ebuild,v 1.1 2009/01/07 19:19:28 dertobi123 Exp $
+
+inherit flag-o-matic
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p1/-P1}
+MY_P="${MY_PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="idn ipv6"
+
+DEPEND="idn? ( || ( sys-libs/glibc dev-libs/libiconv )
+ net-dns/idnkit )"
+
+src_unpack() {
+ unpack ${A} || die
+ cd "${S}" || die
+
+ use idn && {
+ # BIND 9.4.0 doesn't have this patch
+ # epatch ${S}/contrib/idn/idnkit-1.0-src/patch/bind9/bind-${PV}-patch
+
+ cd "${S}"/contrib/idn/idnkit-1.0-src
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ cd -
+ }
+
+ # bug #151839
+ sed -e \
+ 's:struct isc_socket {:#undef SO_BSDCOMPAT\n\nstruct isc_socket {:' \
+ -i lib/isc/unix/socket.c
+}
+
+src_compile() {
+ local myconf=
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
+ use idn && myconf="${myconf} --with-idn"
+
+ has_version sys-libs/glibc || myconf="${myconf} --with-iconv"
+
+ econf ${myconf} || die "Configure failed"
+
+ cd "${S}"/lib
+ emake -j1 || die "make failed in /lib"
+
+ cd "${S}"/bin/dig
+ emake -j1 || die "make failed in /bin/dig"
+
+ cd "${S}"/lib/lwres/
+ emake -j1 || die "make failed in /lib/lwres"
+
+ cd "${S}"/bin/nsupdate/
+ emake -j1 || die "make failed in /bin/nsupdate"
+
+ cd "${S}"/bin/dnssec/
+ emake -j1 || die "make failed in /bin/dnssec"
+}
+
+src_install() {
+ dodoc README CHANGES FAQ
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup || die
+ doman dig.1 host.1 nslookup.1 || die
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate || die
+ doman nsupdate.1 || die
+ dohtml nsupdate.html || die
+
+ cd "${S}"/bin/dnssec
+ dobin dnssec-keygen || die
+ doman dnssec-keygen.8 || die
+ dohtml dnssec-keygen.html || die
+}