summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2008-02-18 19:54:54 +0000
committerPeter Weller <welp@gentoo.org>2008-02-18 19:54:54 +0000
commitd5d746f566779789db123b2a65f3dc6039c3f3cf (patch)
tree6aa5f1de77305bbb1645ff7ca245b5cb214cfe16 /net-dns
parentAdd nuv use flag, with lzo dep, bug 210352 (diff)
downloadgentoo-2-d5d746f566779789db123b2a65f3dc6039c3f3cf.tar.gz
gentoo-2-d5d746f566779789db123b2a65f3dc6039c3f3cf.tar.bz2
gentoo-2-d5d746f566779789db123b2a65f3dc6039c3f3cf.zip
Bump to 1.3, Fix deps. Bug 209423
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/openresolv/ChangeLog9
-rw-r--r--net-dns/openresolv/openresolv-1.3.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/net-dns/openresolv/ChangeLog b/net-dns/openresolv/ChangeLog
index 97465ff83f97..25a7dce970bb 100644
--- a/net-dns/openresolv/ChangeLog
+++ b/net-dns/openresolv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/openresolv
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/ChangeLog,v 1.1 2007/12/31 13:31:56 welp Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/ChangeLog,v 1.2 2008/02/18 19:54:54 welp Exp $
+
+*openresolv-1.3 (18 Feb 2008)
+
+ 18 Feb 2008; <welp@gentoo.org> +openresolv-1.3.ebuild:
+ Bump to 1.3, Fix deps. Bug 209423
*openresolv-1.1 (31 Dec 2007)
diff --git a/net-dns/openresolv/openresolv-1.3.ebuild b/net-dns/openresolv/openresolv-1.3.ebuild
new file mode 100644
index 000000000000..953fbd5f8b04
--- /dev/null
+++ b/net-dns/openresolv/openresolv-1.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/openresolv-1.3.ebuild,v 1.1 2008/02/18 19:54:54 welp Exp $
+
+inherit eutils
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="http://roy.marples.name/node/343"
+SRC_URI="http://roy.marples.name/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="!net-dns/resolvconf-gentoo
+ !<net-dns/dnsmasq-2.40-r1"
+RDEPEND=""
+
+src_install() {
+ make DESTDIR="${D}" install || die "Failed to install"
+}
+
+pkg_postinst() {
+ if [ ! -"L ${ROOT}/etc/resolv.conf" ] \
+ || [ "$(readlink "${ROOT}/etc/resolv.conf")" != \
+ "resolvconf/run/resolv.conf" ] ; then
+ ewarn "resolvconf requires ${ROOT}etc/resolv.conf to be a symbolic"
+ ewarn "to resolvconf/run/resolv.conf"
+ ewarn "To set this up automatically type"
+ ewarn " emerge --config =${PF}"
+ fi
+}
+
+pkg_config() {
+ cd "${ROOT}/etc"
+ if [ -L resolv.conf -a "$(readlink resolv.conf)" = \
+ "resolvconf/run/resolv.conf" ] ; then
+ einfo "${ROOT}etc/resolv.conf is already configured for ${PN}"
+ else
+ if [ -e resolv.conf ] ; then
+ einfo "Your existing resolv.conf is will be mapped to an"
+ einfo "interface called \"dummy\" in resolvconf. This will"
+ einfo "disappear when you reboot."
+ cp resolv.conf resolvconf/run/resolv.conf
+ [ ! -d resolvconf/run/interfaces ] \
+ && mkdir resolvconf/run/interfaces
+ cp resolv.conf resolvconf/run/interfaces/dummy
+ echo "dummy" > resolvconf/run/add_order
+ fi
+ rm -f resolv.conf
+ ln -snf resolvconf/run/resolv.conf .
+ einfo "${ROOT}etc/resolv.conf is now correctly configured for ${PN}"
+ fi
+}
+
+pkg_postrm() {
+ # If we are totally removed but still configured, then replace
+ # /etc/resolv.conf with a real file
+ cd "${ROOT}"/etc
+ [ -L resolv.conf ] || return 0
+ if [ -e resolv.conf ]; then
+ [ "$(readlink resolv.conf)" = "resolvconf/run/resolv.conf" ] || return 0
+ rm resolv.conf
+ cp resolvconf/run/resolv.conf .
+ elif [ -e /var/run/resolvconf/resolv.conf ]; then
+ rm resolv.conf
+ cp /var/run/resolvconf/resolv.conf .
+ fi
+}