summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-21 16:19:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-21 16:19:18 +0000
commit3a4d3fe14a616f29627b684e3c0ba53e3d1cfd19 (patch)
treec6e382018c10cdcd46e4f65565a7e5fe56cf8215 /net-firewall/fwbuilder
parenttouchup (diff)
downloadgentoo-2-3a4d3fe14a616f29627b684e3c0ba53e3d1cfd19.tar.gz
gentoo-2-3a4d3fe14a616f29627b684e3c0ba53e3d1cfd19.tar.bz2
gentoo-2-3a4d3fe14a616f29627b684e3c0ba53e3d1cfd19.zip
touchups
Diffstat (limited to 'net-firewall/fwbuilder')
-rw-r--r--net-firewall/fwbuilder/fwbuilder-1.1.1-r1.ebuild6
-rw-r--r--net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild28
2 files changed, 12 insertions, 22 deletions
diff --git a/net-firewall/fwbuilder/fwbuilder-1.1.1-r1.ebuild b/net-firewall/fwbuilder/fwbuilder-1.1.1-r1.ebuild
index 7abd12174362..e32f79e22287 100644
--- a/net-firewall/fwbuilder/fwbuilder-1.1.1-r1.ebuild
+++ b/net-firewall/fwbuilder/fwbuilder-1.1.1-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/fwbuilder-1.1.1-r1.ebuild,v 1.2 2004/02/25 21:51:02 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/fwbuilder-1.1.1-r1.ebuild,v 1.3 2004/04/21 16:19:18 vapier Exp $
DESCRIPTION="A firewall GUI"
SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
HOMEPAGE="http://www.fwbuilder.org/"
-RESTRICT="nomirror"
-S=${WORKDIR}/${P}
KEYWORDS="~x86 sparc ~amd64"
LICENSE="GPL-2"
@@ -21,7 +19,7 @@ DEPEND="sys-devel/autoconf
nls? ( >=sys-devel/gettext-0.11 )
~net-libs/libfwbuilder-1.0.2"
-RDEPEND="sys-apps/iproute"
+RDEPEND="sys-apps/iproute2"
# Added by Jason Wever <weeve@gentoo.org>
# Fix for bug #30256.
diff --git a/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild b/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild
index 15c0201fe6bc..5514adc909ad 100644
--- a/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild
+++ b/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild,v 1.7 2004/04/14 07:32:49 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild,v 1.8 2004/04/21 16:19:18 vapier Exp $
inherit flag-o-matic
DESCRIPTION="A firewall GUI"
-SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
HOMEPAGE="http://www.fwbuilder.org/"
-RESTRICT="nomirror"
+SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
-KEYWORDS="x86 sparc amd64 ~ppc"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 sparc amd64 ~ppc"
IUSE="static nls"
DEPEND="sys-devel/autoconf
@@ -21,28 +20,22 @@ DEPEND="sys-devel/autoconf
=dev-libs/libsigc++-1.0*
nls? ( >=sys-devel/gettext-0.11 )
~net-libs/libfwbuilder-1.0.2"
-RDEPEND="$DEPEND"
-
-# Added by Jason Wever <weeve@gentoo.org>
-# Fix for bug #30256.
-if [ "${ARCH}" = "sparc" ]; then
- replace-flags "-O3" "-O2"
-fi
src_compile() {
+ use sparc && replace-flags -O3 -O2
local myconf
- myconf="--with-gnu-ld"
- use static && myconf="${myconf} --enable-shared=no --enable-static=yes"
- use nls || myconf="${myconf} --disable-nls"
+ use static && myconf="${myconf} --enable-shared=no --enable-static=yes"
+ use nls || myconf="${myconf} --disable-nls"
./autogen.sh \
--prefix=/usr \
- --host=${CHOST} || die "./configure failed"
+ --host=${CHOST} \
+ ${myconf} \
+ || die "./configure failed"
sed -i -e "s:#define HAVE_XMLSAVEFORMATFILE 1://:" config.h
- if [ "`use static`" ]
- then
+ if use static ; then
emake LDFLAGS="-static" || die "emake LDFLAGS failed"
else
emake || die "emake failed"
@@ -57,4 +50,3 @@ pkg_postinst() {
einfo "You need to emerge iproute2 on the machine that"
einfo "will run the firewall script."
}
-