summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-12-05 06:20:30 +0000
committerAlin Năstac <mrness@gentoo.org>2006-12-05 06:20:30 +0000
commitcd3366f6b17a92c18e417b7cad94edfe9fb2fdcf (patch)
treed4dea83ff55d52b6a13a0a49e8ec51d800c06ff9 /net-firewall/ipp2p
parentcleanup (diff)
downloadgentoo-2-cd3366f6b17a92c18e417b7cad94edfe9fb2fdcf.tar.gz
gentoo-2-cd3366f6b17a92c18e417b7cad94edfe9fb2fdcf.tar.bz2
gentoo-2-cd3366f6b17a92c18e417b7cad94edfe9fb2fdcf.zip
Version bumped as stable on x86 (#141700). Add myself as secondary maintainer. Add longdescription to metadata.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'net-firewall/ipp2p')
-rw-r--r--net-firewall/ipp2p/ChangeLog8
-rw-r--r--net-firewall/ipp2p/files/digest-ipp2p-0.8.02
-rw-r--r--net-firewall/ipp2p/files/digest-ipp2p-0.8.23
-rw-r--r--net-firewall/ipp2p/ipp2p-0.8.2.ebuild59
-rw-r--r--net-firewall/ipp2p/metadata.xml10
5 files changed, 81 insertions, 1 deletions
diff --git a/net-firewall/ipp2p/ChangeLog b/net-firewall/ipp2p/ChangeLog
index 9a19f2887f5a..a7d75f79e5e5 100644
--- a/net-firewall/ipp2p/ChangeLog
+++ b/net-firewall/ipp2p/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipp2p
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.16 2006/05/23 20:02:03 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.17 2006/12/05 06:20:30 mrness Exp $
+
+*ipp2p-0.8.2 (05 Dec 2006)
+
+ 05 Dec 2006; Alin Năstac <mrness@gentoo.org> metadata.xml,
+ +ipp2p-0.8.2.ebuild:
+ Version bumped as stable on x86 (#141700).
23 May 2006; Markus Rothe <corsair@gentoo.org> ipp2p-0.8.0.ebuild:
Stable on ppc64
diff --git a/net-firewall/ipp2p/files/digest-ipp2p-0.8.0 b/net-firewall/ipp2p/files/digest-ipp2p-0.8.0
index a7177a501593..b0aafaf0a44e 100644
--- a/net-firewall/ipp2p/files/digest-ipp2p-0.8.0
+++ b/net-firewall/ipp2p/files/digest-ipp2p-0.8.0
@@ -1 +1,3 @@
MD5 8738d6ad5600ac5577bd599e6d279bef ipp2p-0.8.0.tar.gz 18910
+RMD160 5e5825a28e626fcd96ce2e3bcf588d226426a1d3 ipp2p-0.8.0.tar.gz 18910
+SHA256 18375c1a5ef5e65da78c18b089be1d26846ad0372ac476fd0385de1dbe0d295e ipp2p-0.8.0.tar.gz 18910
diff --git a/net-firewall/ipp2p/files/digest-ipp2p-0.8.2 b/net-firewall/ipp2p/files/digest-ipp2p-0.8.2
new file mode 100644
index 000000000000..14106f32db3b
--- /dev/null
+++ b/net-firewall/ipp2p/files/digest-ipp2p-0.8.2
@@ -0,0 +1,3 @@
+MD5 9dd745830f302d70d0b728013c1d6a0c ipp2p-0.8.2.tar.gz 18976
+RMD160 097cd4175af3f97f3687f343087b8fe0af20ba38 ipp2p-0.8.2.tar.gz 18976
+SHA256 b265f5a1ce62de5a6cc60b9af22134a8d19b23e14b47a897057bca91188e0ee7 ipp2p-0.8.2.tar.gz 18976
diff --git a/net-firewall/ipp2p/ipp2p-0.8.2.ebuild b/net-firewall/ipp2p/ipp2p-0.8.2.ebuild
new file mode 100644
index 000000000000..c7631fa6b4df
--- /dev/null
+++ b/net-firewall/ipp2p/ipp2p-0.8.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.8.2.ebuild,v 1.1 2006/12/05 06:20:30 mrness Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="Netfilter module for dealing with P2P Applications."
+HOMEPAGE="http://www.ipp2p.org/index_en.html"
+SRC_URI="http://www.ipp2p.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="virtual/modutils
+ >=net-firewall/iptables-1.2.11"
+
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+
+pkg_setup() {
+ CONFIG_CHECK="NETFILTER"
+ NETFILTER_ERROR="Your kernel is not configured to support Netfilter."
+ MODULE_NAMES="ipt_ipp2p(${PN}:${S}:${S})"
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ convert_to_m Makefile
+
+ sed -i -e "s/^IPTABLES_VERSION/#IPTABLES_VERSION/" Makefile
+}
+
+src_compile() {
+ local IPTABLES_VERSION="$("${ROOT}"/sbin/iptables --version | cut -f2 -dv)"
+ emake CFLAGS="${CFLAGS}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" libipt_ipp2p.so || die "Failed to build iptables module"
+
+ local xarch="${ARCH}"
+ unset ARCH
+ emake KERNEL_SRC="${KV_DIR}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" || die "Failed to build kernel modle."
+ ARCH="${xarch}"
+}
+
+src_install() {
+ exeinto /$(get_libdir)/iptables
+ doexe libipt_ipp2p.so
+
+ dodoc README
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+}
diff --git a/net-firewall/ipp2p/metadata.xml b/net-firewall/ipp2p/metadata.xml
index 15a401e91b43..08ab94997acf 100644
--- a/net-firewall/ipp2p/metadata.xml
+++ b/net-firewall/ipp2p/metadata.xml
@@ -5,4 +5,14 @@
<maintainer>
<email>eradicator@gentoo.org</email>
</maintainer>
+<maintainer>
+ <email>mrness@gentoo.org</email>
+ <name>Alin Năstac</name>
+ <description>Secondary maintainer</description>
+</maintainer>
+<longdescription>IPP2P uses suitable search patterns to identify P2P traffic thus allowing
+the reliable identification of traffic belonging to many P2P networks. Once identified one
+may handle P2P traffic in different ways - dropping such traffic, putting into low priority
+classes or shaping to a given bandwidth limit is possible. Reducing costs, freeing network
+resources and therefore improving network performance is often the result of using IPP2P.</longdescription>
</pkgmetadata>