summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-01-04 13:18:52 +0000
committerAlin Năstac <mrness@gentoo.org>2007-01-04 13:18:52 +0000
commitcf7f50558c3af560ca9c056970aadecbde799067 (patch)
tree9c7b8b84d330cd68aa278dba96346d91fe41e6ca /net-firewall/ipp2p
parentFix autotools handling, closes bug #152497. Also don't use gnuconfig_update. (diff)
downloadgentoo-2-cf7f50558c3af560ca9c056970aadecbde799067.tar.gz
gentoo-2-cf7f50558c3af560ca9c056970aadecbde799067.tar.bz2
gentoo-2-cf7f50558c3af560ca9c056970aadecbde799067.zip
Link libipt_ipp2p.o dynamically when iptables 1.3.6 or better is installed (#157238).
(Portage version: 2.1.1-r1)
Diffstat (limited to 'net-firewall/ipp2p')
-rw-r--r--net-firewall/ipp2p/ChangeLog10
-rw-r--r--net-firewall/ipp2p/files/digest-ipp2p-0.8.2-r13
-rw-r--r--net-firewall/ipp2p/ipp2p-0.8.2-r1.ebuild66
3 files changed, 77 insertions, 2 deletions
diff --git a/net-firewall/ipp2p/ChangeLog b/net-firewall/ipp2p/ChangeLog
index 581ebc7604f5..ae0eaa01b354 100644
--- a/net-firewall/ipp2p/ChangeLog
+++ b/net-firewall/ipp2p/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipp2p
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.19 2006/12/06 08:12:33 corsair Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.20 2007/01/04 13:18:52 mrness Exp $
+
+*ipp2p-0.8.2-r1 (04 Jan 2007)
+
+ 04 Jan 2007; Alin Nastac <mrness@gentoo.org> +ipp2p-0.8.2-r1.ebuild:
+ Link libipt_ipp2p.o dynamically when iptables 1.3.6 or better is installed
+ (#157238).
06 Dec 2006; Markus Rothe <corsair@gentoo.org> ipp2p-0.8.2.ebuild:
Stable on ppc64; bug #157175
diff --git a/net-firewall/ipp2p/files/digest-ipp2p-0.8.2-r1 b/net-firewall/ipp2p/files/digest-ipp2p-0.8.2-r1
new file mode 100644
index 000000000000..14106f32db3b
--- /dev/null
+++ b/net-firewall/ipp2p/files/digest-ipp2p-0.8.2-r1
@@ -0,0 +1,3 @@
+MD5 9dd745830f302d70d0b728013c1d6a0c ipp2p-0.8.2.tar.gz 18976
+RMD160 097cd4175af3f97f3687f343087b8fe0af20ba38 ipp2p-0.8.2.tar.gz 18976
+SHA256 b265f5a1ce62de5a6cc60b9af22134a8d19b23e14b47a897057bca91188e0ee7 ipp2p-0.8.2.tar.gz 18976
diff --git a/net-firewall/ipp2p/ipp2p-0.8.2-r1.ebuild b/net-firewall/ipp2p/ipp2p-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..fc61d31d1629
--- /dev/null
+++ b/net-firewall/ipp2p/ipp2p-0.8.2-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.8.2-r1.ebuild,v 1.1 2007/01/04 13:18:52 mrness Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="Netfilter module for dealing with P2P Applications."
+HOMEPAGE="http://www.ipp2p.org/index_en.html"
+SRC_URI="http://www.ipp2p.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/modutils
+ >=net-firewall/iptables-1.2.11"
+
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+
+pkg_setup() {
+ CONFIG_CHECK="NETFILTER"
+ NETFILTER_ERROR="Your kernel is not configured to support Netfilter."
+ MODULE_NAMES="ipt_ipp2p(${PN}:${S}:${S})"
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ convert_to_m Makefile
+
+ sed -i -e "s/^IPTABLES_VERSION/#IPTABLES_VERSION/" Makefile
+ if has_version '>=net-firewall/iptables-1.3.6' ; then
+ sed -i -e "s/ld -shared/\$\(CC\) -shared/" Makefile
+ fi
+}
+
+src_compile() {
+ local IPTABLES_VERSION="$("${ROOT}"/sbin/iptables --version | cut -f2 -dv)"
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
+ IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" libipt_ipp2p.so \
+ || die "Failed to build iptables module"
+
+ local myARCH="${ARCH}"
+ ARCH="$(tc-arch-kernel)"
+ emake KERNEL_SRC="${KV_DIR}" \
+ IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" \
+ || die "Failed to build kernel module."
+ ARCH="${myARCH}"
+}
+
+src_install() {
+ exeinto /$(get_libdir)/iptables
+ doexe libipt_ipp2p.so
+
+ dodoc README
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+}