summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-10-30 14:05:09 +0000
committerPeter Volkov <pva@gentoo.org>2010-10-30 14:05:09 +0000
commitb1495bece1072ea062be08a4c4aa1d99cbcb99d5 (patch)
treeb3aa4391c3a343c1d6615af58f50cf610c338ed0 /net-firewall/iptables/iptables-1.4.10.ebuild
parentVersion bumped. Changed udev-postmount script to better check for ro filesyst... (diff)
downloadgentoo-2-b1495bece1072ea062be08a4c4aa1d99cbcb99d5.tar.gz
gentoo-2-b1495bece1072ea062be08a4c4aa1d99cbcb99d5.tar.bz2
gentoo-2-b1495bece1072ea062be08a4c4aa1d99cbcb99d5.zip
Version bump. Dropped --as-needed hack from ebuild as better solution is upstream now. Remove .la files.
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/iptables/iptables-1.4.10.ebuild')
-rw-r--r--net-firewall/iptables/iptables-1.4.10.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-firewall/iptables/iptables-1.4.10.ebuild b/net-firewall/iptables/iptables-1.4.10.ebuild
new file mode 100644
index 000000000000..b3d1e3380c48
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.10.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.10.ebuild,v 1.1 2010/10/30 14:05:09 pva Exp $
+
+EAPI="2"
+
+# Force users doing their own patches to install their own tools
+AUTOTOOLS_AUTO_DEPEND=no
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/os-headers"
+RDEPEND=""
+
+src_prepare() {
+ # Only run autotools if user patched something
+ epatch_user && eautoreconf || elibtoolize
+}
+
+src_configure() {
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_enable ipv6)
+}
+
+src_compile() {
+ emake V=1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dosbin iptables-apply || die
+ doman iptables-apply.8 || die
+ dodoc INCOMPATIBILITIES iptables.xslt || die
+
+ insinto /usr/include
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
+ insinto /usr/include/iptables
+ doins include/iptables/internal.h || die
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+ fi
+
+ # Move important libs to /lib
+ gen_usr_ldscript -a ip{4,6}tc ipq iptc xtables
+ find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}