summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-05-21 07:24:14 +0000
committerPeter Volkov <pva@gentoo.org>2010-05-21 07:24:14 +0000
commit719038429f296510cdd924881702dcd6889af622 (patch)
tree407523c5b0bf950a1b73de8a5db214790dfe8f9b /net-firewall/iptables
parentMask www-client/chromium dev channel release. (diff)
downloadgentoo-2-719038429f296510cdd924881702dcd6889af622.tar.gz
gentoo-2-719038429f296510cdd924881702dcd6889af622.tar.bz2
gentoo-2-719038429f296510cdd924881702dcd6889af622.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog8
-rw-r--r--net-firewall/iptables/iptables-1.4.8.ebuild58
-rw-r--r--net-firewall/iptables/metadata.xml2
3 files changed, 66 insertions, 2 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 9d1a14cb5f90..e1ea15f1c7e4 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.212 2010/05/20 10:38:07 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.213 2010/05/21 07:24:14 pva Exp $
+
+*iptables-1.4.8 (21 May 2010)
+
+ 21 May 2010; Peter Volkov <pva@gentoo.org> +iptables-1.4.8.ebuild,
+ metadata.xml:
+ Version bump.
20 May 2010; Peter Volkov <pva@gentoo.org> iptables-1.4.6.ebuild:
amd64 stable, bug 318531.
diff --git a/net-firewall/iptables/iptables-1.4.8.ebuild b/net-firewall/iptables/iptables-1.4.8.ebuild
new file mode 100644
index 000000000000..c7fce11a02ed
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.8.ebuild,v 1.1 2010/05/21 07:24:14 pva Exp $
+
+EAPI="2"
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/os-headers"
+RDEPEND=""
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_enable ipv6)
+}
+
+src_compile() {
+ emake V=1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dosbin iptables-apply || die
+ doman iptables-apply.8 || die
+ dodoc INCOMPATIBILITIES iptables.xslt || die
+
+ insinto /usr/include
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
+ insinto /usr/include/iptables
+ doins include/iptables/internal.h || die
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+ fi
+}
diff --git a/net-firewall/iptables/metadata.xml b/net-firewall/iptables/metadata.xml
index 810f7dc9668d..6d895815e0c5 100644
--- a/net-firewall/iptables/metadata.xml
+++ b/net-firewall/iptables/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>base-system</herd>
-<maintainer restrict="imq and l7filter extensions">
+<maintainer>
<email>pva@gentoo.org</email>
</maintainer>
<longdescription>