summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-08-12 13:22:33 +0000
committerPeter Volkov <pva@gentoo.org>2010-08-12 13:22:33 +0000
commitaddb99728fbc40fb4c73b8dc9b4050611c06870e (patch)
treec9ac7b76ddea60ec305fede5359de816ccb58f10 /net-firewall/iptables
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-addb99728fbc40fb4c73b8dc9b4050611c06870e.tar.gz
gentoo-2-addb99728fbc40fb4c73b8dc9b4050611c06870e.tar.bz2
gentoo-2-addb99728fbc40fb4c73b8dc9b4050611c06870e.zip
Fix pkg-config's .pc file location (should be in /usr/...).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog8
-rw-r--r--net-firewall/iptables/iptables-1.4.9.1-r2.ebuild (renamed from net-firewall/iptables/iptables-1.4.9.1-r1.ebuild)3
2 files changed, 9 insertions, 2 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index ef21b19ad255..d1a3cbe9c4fe 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.221 2010/08/11 07:58:32 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.222 2010/08/12 13:22:33 pva Exp $
+
+*iptables-1.4.9.1-r2 (12 Aug 2010)
+
+ 12 Aug 2010; Peter Volkov <pva@gentoo.org> -iptables-1.4.9.1-r1.ebuild,
+ +iptables-1.4.9.1-r2.ebuild:
+ Fix pkg-config's .pc file location (should be in /usr/...).
*iptables-1.4.9.1-r1 (11 Aug 2010)
diff --git a/net-firewall/iptables/iptables-1.4.9.1-r1.ebuild b/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild
index 1a17beb1974c..0519c5278c39 100644
--- a/net-firewall/iptables/iptables-1.4.9.1-r1.ebuild
+++ b/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.9.1-r1.ebuild,v 1.1 2010/08/11 07:58:32 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild,v 1.1 2010/08/12 13:22:33 pva Exp $
EAPI="2"
inherit eutils toolchain-funcs autotools
@@ -62,5 +62,6 @@ src_install() {
find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
dodir /usr/$(get_libdir)/
mv "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/ || die "failed to mv static libs"
+ mv "${D}"{/,/usr/}"$(get_libdir)"/pkgconfig || die "failed to mv pkg-config files"
gen_usr_ldscript libip4tc.so libip6tc.so libipq.so libiptc.so libxtables.so
}