summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-10-07 06:22:34 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-10-07 06:22:34 +0000
commit25c66e3705814da34698ddfc5ac86045b0a4dee4 (patch)
treef07dff9865d7b710862cdd43c35c52bab6484b9f /net-firewall/psad
parentinstall location fix0rs (diff)
downloadgentoo-2-25c66e3705814da34698ddfc5ac86045b0a4dee4.tar.gz
gentoo-2-25c66e3705814da34698ddfc5ac86045b0a4dee4.tar.bz2
gentoo-2-25c66e3705814da34698ddfc5ac86045b0a4dee4.zip
install location fix0rs
Diffstat (limited to 'net-firewall/psad')
-rw-r--r--net-firewall/psad/ChangeLog8
-rw-r--r--net-firewall/psad/Manifest4
-rw-r--r--net-firewall/psad/files/digest-psad-1.2.3-r11
-rw-r--r--net-firewall/psad/psad-1.2.3-r1.ebuild101
4 files changed, 111 insertions, 3 deletions
diff --git a/net-firewall/psad/ChangeLog b/net-firewall/psad/ChangeLog
index 60487067c1e1..ce42cc7b90a7 100644
--- a/net-firewall/psad/ChangeLog
+++ b/net-firewall/psad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/psad
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/ChangeLog,v 1.3 2003/09/19 07:44:06 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/ChangeLog,v 1.4 2003/10/07 06:22:33 seemant Exp $
+
+*psad-1.2.3-r1 (06 Oct 2003)
+
+ 06 Oct 2003; Seemant Kulleen <seemant@gentoo.org> psad-1.2.3-r1.ebuild:
+ Moved bundled PERL module locations to /usr/lib/psad to avoid conflicts with
+ the system PERL tree -- thanks again to Battoussai
19 Sep 2003; Seemant Kulleen <seemant@gentoo.org> :
version bump, thanks again to Battoussai (Bryan Stine <admin@kentonet.net>)
diff --git a/net-firewall/psad/Manifest b/net-firewall/psad/Manifest
index 1eef6d2b7070..9eeeca0218cd 100644
--- a/net-firewall/psad/Manifest
+++ b/net-firewall/psad/Manifest
@@ -1,7 +1,7 @@
-MD5 0074c55c528d75a79dbc5ce6f30022f1 psad-1.2.3-r1.ebuild 2368
+MD5 d53d8f350b98cb2c133a02ed1bb7b17f psad-1.2.3-r1.ebuild 2318
MD5 3f67eca9c08b0f4c00febb141781d3bc psad-1.2.1.ebuild 2177
MD5 1b47f1cbc333cef8864f9c143321eb4c psad-1.2.3.ebuild 2324
-MD5 95053cfa9af4c06060b526e44c9cbe0e ChangeLog 644
+MD5 2107911272a5933dcb2cb62861e7f9af ChangeLog 881
MD5 624441f5e21afa19251eedc583e0c4e7 metadata.xml 433
MD5 13ac645fa87957507ebc86576fb4e76b files/digest-psad-1.2.1 62
MD5 2958d8637b53c70d3e7c1fc812265c96 files/digest-psad-1.2.3 62
diff --git a/net-firewall/psad/files/digest-psad-1.2.3-r1 b/net-firewall/psad/files/digest-psad-1.2.3-r1
new file mode 100644
index 000000000000..16b7474b4eed
--- /dev/null
+++ b/net-firewall/psad/files/digest-psad-1.2.3-r1
@@ -0,0 +1 @@
+MD5 e9aa74b03528ee6143af45f6f3b1fb0c psad-1.2.3.tar.gz 432797
diff --git a/net-firewall/psad/psad-1.2.3-r1.ebuild b/net-firewall/psad/psad-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..08351970c4a8
--- /dev/null
+++ b/net-firewall/psad/psad-1.2.3-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/psad-1.2.3-r1.ebuild,v 1.1 2003/10/07 06:22:33 seemant Exp $
+
+inherit eutils
+inherit perl-module
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Port Scannning Attack Detection daemon"
+SRC_URI="http://www.cipherdyne.org/psad/download/psad-${PV}.tar.gz"
+HOMEPAGE="http://www.cipherdyne.org/psad"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~alpha ~sparc ~hppa ~mips ~arm"
+
+DEPEND="${DEPEND}
+ dev-lang/perl"
+
+RDEPEND="virtual/logger
+ dev-perl/Unix-Syslog
+ dev-perl/Date-Calc
+ net-mail/mailx
+ net-firewall/iptables"
+
+src_compile() {
+ cd ${S}/Psad
+ SRC_PREP="no" perl-module_src_compile
+ emake test
+
+ cd ${S}/Net-IPv4Addr
+ SRC_PREP="no" perl-module_src_compile
+ emake test
+
+ cd ${S}/IPTables/Parse
+ SRC_PREP="no" perl-module_src_compile
+ emake test
+
+ cd ${S}/whois
+ emake || die
+
+ cd ${S}
+ # We'll use the C binaries until we see them break
+ emake || die
+}
+
+src_install() {
+ keepdir /var/lib/psad /var/log/psad /var/run/psad /var/lock/subsys/${PN}
+ dodir /etc/psad
+ cd ${S}/Psad
+ insinto /usr/lib/psad
+ doins Psad.pm
+
+ cd ${S}/Net-IPv4Addr
+ insinto /usr/lib/psad
+ doins IPv4Addr.pm
+
+ cd ${S}/IPTables/Parse
+ insinto /usr/lib/psad
+ doins Parse.pm
+
+ cd ${S}/whois
+ # Makefile seems borken, do install by hand...
+ insinto /usr
+ newbin whois whois_psad
+ newman whois.1 whois_psad.1
+
+ cd ${S}
+ insinto /usr
+ dosbin diskmond kmsgsd psad psadwatchd
+ dobin pscan
+
+ cd ${S}
+ insinto /etc/psad
+ doins *.conf
+
+ cd ${S}/snort_rules
+ dodir /etc/psad/snort_rules
+ insinto /etc/psad/snort_rules
+ doins *.rules
+
+ dodoc BENCHMARK CREDITS Change* FW_EXAMPLE_RULES README LICENSE SCAN_LOG
+}
+
+pkg_postinst() {
+ if [ ! -p ${ROOT}/var/lib/psad/psadfifo ]
+ then
+ ebegin "Creating syslog FIFO for PSAD"
+ mknod -m 600 ${ROOT}/var/lib/psad/psadfifo p
+ eend $?
+ fi
+ echo
+ einfo "Several programs in the PSAD package are in the process of being converted to"
+ einfo "compiled C from PERL. If you have any problems, please notify the PSAD"
+ einfo "maintainers. Please do not take PSAD issues to the Bastille-Linux team."
+ echo
+ ewarn "Please be sure to edit /etc/psad/psad.conf to reflect your system's configuration"
+ ewarn "or it may not work correctly or start up."
+}