summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-01-27 19:19:50 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-01-27 19:19:50 +0000
commit893fe26324182c539757efe6d7c32688ae00404b (patch)
treeb5c92a1f9d694515846f3db9e54060069a989518 /net-firewall/shorewall-common
parentDelete old version. (diff)
downloadgentoo-2-893fe26324182c539757efe6d7c32688ae00404b.tar.gz
gentoo-2-893fe26324182c539757efe6d7c32688ae00404b.tar.bz2
gentoo-2-893fe26324182c539757efe6d7c32688ae00404b.zip
Version bump, thanks to Vieri for the notification in bug #196695
(Portage version: 2.1.4)
Diffstat (limited to 'net-firewall/shorewall-common')
-rw-r--r--net-firewall/shorewall-common/ChangeLog10
-rw-r--r--net-firewall/shorewall-common/files/digest-shorewall-common-4.0.86
-rw-r--r--net-firewall/shorewall-common/shorewall-common-4.0.8.ebuild101
3 files changed, 115 insertions, 2 deletions
diff --git a/net-firewall/shorewall-common/ChangeLog b/net-firewall/shorewall-common/ChangeLog
index dbcdb0888535..3eb6b332a936 100644
--- a/net-firewall/shorewall-common/ChangeLog
+++ b/net-firewall/shorewall-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-common
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.8 2007/09/14 11:44:51 fmccor Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.9 2008/01/27 19:19:50 jokey Exp $
+
+*shorewall-common-4.0.8 (27 Jan 2008)
+
+ 27 Jan 2008; Markus Ullmann <jokey@gentoo.org>
+ +shorewall-common-4.0.8.ebuild:
+ Version bump, thanks to Vieri for the notification in bug #196695
14 Sep 2007; Ferris McCormick <fmccor@gentoo.org>
shorewall-common-4.0.3.ebuild:
diff --git a/net-firewall/shorewall-common/files/digest-shorewall-common-4.0.8 b/net-firewall/shorewall-common/files/digest-shorewall-common-4.0.8
new file mode 100644
index 000000000000..190a27383231
--- /dev/null
+++ b/net-firewall/shorewall-common/files/digest-shorewall-common-4.0.8
@@ -0,0 +1,6 @@
+MD5 45b0ef719627a514f29570d2106245b1 shorewall-common-4.0.8.tar.bz2 137483
+RMD160 b02f03092468581b590bbb9bff8c01404bd17390 shorewall-common-4.0.8.tar.bz2 137483
+SHA256 8d6029743c0108a765ffe0e477efeb6a712767ee4bf15187230671df145239eb shorewall-common-4.0.8.tar.bz2 137483
+MD5 9c5b8bfd709a778d910dae97b3e6795a shorewall-docs-html-4.0.8.tar.bz2 2370029
+RMD160 fdba3de87bcb756dba17bc10299217dc5535805c shorewall-docs-html-4.0.8.tar.bz2 2370029
+SHA256 de4c75582c7605e4ef26158eeeb70e65d93a66e6a30659a95a647aa087153c66 shorewall-docs-html-4.0.8.tar.bz2 2370029
diff --git a/net-firewall/shorewall-common/shorewall-common-4.0.8.ebuild b/net-firewall/shorewall-common/shorewall-common-4.0.8.ebuild
new file mode 100644
index 000000000000..be7269103595
--- /dev/null
+++ b/net-firewall/shorewall-common/shorewall-common-4.0.8.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.0.8.ebuild,v 1.1 2008/01/27 19:19:50 jokey Exp $
+
+inherit eutils
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-RC1" # only beta and RC
+MY_P_BETA="" # stable or experimental
+
+MY_P="${P/-common/}${MY_P_BETA}"
+MY_PN="${PN/-common/}"
+
+MY_P_DOCS="${MY_P/${MY_PN}/${MY_PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_P_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${MY_PN}/${MY_P_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2
+ ~net-firewall/shorewall-shell-${PV}
+ !<net-firewall/shorewall-4.0"
+
+pkg_setup() {
+ if built_with_use sys-apps/iproute2 minimal; then
+ die "Shorewall requires sys-apps/iproute2 to be built without the \"minimal\" USE flag."
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall || die "doinitd failed"
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ # install documentation
+ dohtml -r *
+ ## dosym Documentation_Index.html "/usr/share/doc/${PF}/html/index.htm"
+ # install samples
+ cp -pR "${S}${MY_P_BETA}/Samples" "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ elog
+ if use doc ; then
+ elog "Documentation is available at /usr/share/doc/${PF}/html."
+ elog "Please read the Release Notes in /usr/share/doc/${PF}."
+ elog "Samples are available at /usr/share/doc/${PF}/Samples."
+ else
+ elog "Documentation is available at http://www.shorewall.net"
+ fi
+ elog "There are man pages for shorewall(8) and for each configuration file."
+ elog
+ elog "Bridging configuration has changed with kernel 2.6.20+."
+ elog "Check the documentation."
+ elog
+ elog "Do not blindly start shorewall, edit the files in /etc/shorewall first"
+ elog "At the very least, you must change 'STARTUP_ENABLED' in shorewall.conf"
+ elog
+ elog "Be aware that version ${MY_P_TREE} differs substantially from previous releases."
+ elog "Information on upgrading is available at:"
+ elog "http://www.shorewall.net/upgrade_issues.htm"
+ elog
+ elog "There is a 'shorewall compile' command to generate scripts to run"
+ elog "on systems with Shorewall Lite installed."
+ elog "Please refer to http://www.shorewall.net/CompiledPrograms.html"
+ elog "It is advised to copy the /usr/share/shorewall/configfiles dir to your"
+ elog "own 'export directories'. However, whenever you upgrade Shorewall you"
+ elog "should check for changes in configfiles and manually update your exports."
+ elog "Alternatively, if you only have one Shorewall-Lite system in your network"
+ elog "then you can use the configfiles dir but set CONFIG_PROTECT appropriately"
+ elog "in /etc/make.conf (man make.conf)."
+ elog
+ elog "Known problems:"
+ elog "http://shorewall.net/pub/${MY_PN}/${MY_P_TREE}/${MY_P}/known_problems.txt"
+ elog
+ elog "Whether upgrading or installing you should run shorewall check,"
+ elog "correct any errors found and run shorewall restart|start."
+ elog
+ elog "${PN} requires a compiler."
+ elog "You can choose to emerge shorewall-shell and/or shorewall-perl."
+ elog "As of ${PV} shorewall-shell is mandatory."
+}