summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-02-24 18:49:27 +0000
committerPeter Volkov <pva@gentoo.org>2008-02-24 18:49:27 +0000
commitb22700081ebb2a8c67d463749090c90e79c88bb8 (patch)
treee074663fc7a309be25b7400a041fbac932a85f25 /net-firewall/shorewall-perl
parentVersion bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work! (diff)
downloadgentoo-2-b22700081ebb2a8c67d463749090c90e79c88bb8.tar.gz
gentoo-2-b22700081ebb2a8c67d463749090c90e79c88bb8.tar.bz2
gentoo-2-b22700081ebb2a8c67d463749090c90e79c88bb8.zip
Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-firewall/shorewall-perl')
-rw-r--r--net-firewall/shorewall-perl/ChangeLog7
-rw-r--r--net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-firewall/shorewall-perl/ChangeLog b/net-firewall/shorewall-perl/ChangeLog
index afc89845ada2..002f79141be0 100644
--- a/net-firewall/shorewall-perl/ChangeLog
+++ b/net-firewall/shorewall-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-perl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.10 2008/01/27 19:21:00 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.11 2008/02/24 18:49:27 pva Exp $
+
+*shorewall-perl-4.0.9 (24 Feb 2008)
+
+ 24 Feb 2008; <pva@gentoo.org> +shorewall-perl-4.0.9.ebuild:
+ Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
*shorewall-perl-4.0.8 (27 Jan 2008)
diff --git a/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild b/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild
new file mode 100644
index 000000000000..614aeb7d223d
--- /dev/null
+++ b/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild,v 1.1 2008/02/24 18:49:27 pva Exp $
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-Beta7" # only beta
+MY_P_BETA="" # stable or experimental
+
+MY_P="shorewall-${PV}"
+
+DESCRIPTION="Shoreline Firewall Perl-based compiler that allows faster compilation and execution."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ dev-lang/perl
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="~net-firewall/shorewall-common-${PV}"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ einfo "In order to use the Perl compiler you need to add"
+ einfo "SHOREWALL_COMPILER=perl"
+ einfo "to shorewall.conf"
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/known_problems.txt"
+ einfo
+}