summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-03-04 16:26:48 +0000
committerPeter Volkov <pva@gentoo.org>2008-03-04 16:26:48 +0000
commitb097a8603d55c736454631ff5b0f8f5a40a2e546 (patch)
treeac335042d46bc940a17fcecc2d462c9a8e929506 /net-firewall/shorewall-shell
parentVersion bump. (diff)
downloadgentoo-2-b097a8603d55c736454631ff5b0f8f5a40a2e546.tar.gz
gentoo-2-b097a8603d55c736454631ff5b0f8f5a40a2e546.tar.bz2
gentoo-2-b097a8603d55c736454631ff5b0f8f5a40a2e546.zip
Version bump, bug #212277, thank Vieri!
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-firewall/shorewall-shell')
-rw-r--r--net-firewall/shorewall-shell/ChangeLog7
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.0.9.1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-firewall/shorewall-shell/ChangeLog b/net-firewall/shorewall-shell/ChangeLog
index 7ecedb7f7d24..c389b1d65f8f 100644
--- a/net-firewall/shorewall-shell/ChangeLog
+++ b/net-firewall/shorewall-shell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-shell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.10 2008/02/25 18:11:55 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.11 2008/03/04 16:26:48 pva Exp $
+
+*shorewall-shell-4.0.9.1 (04 Mar 2008)
+
+ 04 Mar 2008; <pva@gentoo.org> +shorewall-shell-4.0.9.1.ebuild:
+ Version bump, bug #212277, thank Vieri!
25 Feb 2008; <pva@gentoo.org> shorewall-shell-4.0.9.ebuild:
Don't depend on shorewall-shell by default, bug #211321, thank you Stefan
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.0.9.1.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.0.9.1.ebuild
new file mode 100644
index 000000000000..a127215be5dc
--- /dev/null
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.0.9.1.ebuild,v 1.1 2008/03/04 16:26:48 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # shorewall-common version to use (ignoring upstream "compatibility matrix" for now as it is not always updated at the same time as the software is released)
+
+MY_P="shorewall-${MY_PV_BASE}"
+
+DESCRIPTION="Shoreline Firewall shell-based compiler."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_PV_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="~net-firewall/shorewall-common-${MY_PV_BASE}"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ elog "In order to use the shell compiler you need to add"
+ elog "SHOREWALL_COMPILER=shell"
+ elog "to shorewall.conf unless you do not have the Perl compiler."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/shorewall/${MY_PV_TREE}/${MY_P}${MY_P_BETA}/known_problems.txt"
+ einfo
+}