summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2011-03-13 11:46:35 +0000
committerConstanze Hausner <constanze@gentoo.org>2011-03-13 11:46:35 +0000
commit2476bb5cbf91d957d62a013093a9a6d8f884f290 (patch)
tree8bc9ac4962982846961f6c60b80b952805d5ba68 /net-firewall/shorewall
parentMarked ~x86-macos (diff)
downloadgentoo-2-2476bb5cbf91d957d62a013093a9a6d8f884f290.tar.gz
gentoo-2-2476bb5cbf91d957d62a013093a9a6d8f884f290.tar.bz2
gentoo-2-2476bb5cbf91d957d62a013093a9a6d8f884f290.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/shorewall')
-rw-r--r--net-firewall/shorewall/ChangeLog8
-rw-r--r--net-firewall/shorewall/shorewall-4.4.18.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index c600de955cbb..51fe510b8c6a 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.179 2011/02/27 14:48:00 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.180 2011/03/13 11:46:35 constanze Exp $
+
+*shorewall-4.4.18 (13 Mar 2011)
+
+ 13 Mar 2011; Constanze Hausner <constanze@gentoo.org>
+ +shorewall-4.4.18.ebuild:
+ Version bump.
27 Feb 2011; Tobias Klausmann <klausman@gentoo.org>
shorewall-4.4.15.1.ebuild:
diff --git a/net-firewall/shorewall/shorewall-4.4.18.ebuild b/net-firewall/shorewall/shorewall-4.4.18.ebuild
new file mode 100644
index 000000000000..06c4cad0e00a
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-4.4.18.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-4.4.18.ebuild,v 1.1 2011/03/13 11:46:35 constanze Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="${PN}-${MY_PV_BASE}${MY_P_BETA}"
+MY_P_DOCS="${P/${PN}/${PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl
+ !net-firewall/shorewall-common
+ !net-firewall/shorewall-shell
+ !net-firewall/shorewall-perl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall || die "doinitd failed"
+
+ dodoc changelog.txt releasenotes.txt || die
+
+ if use doc; then
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ # install documentation
+ dohtml -r *
+ ## dosym Documentation_Index.html "/usr/share/doc/${PF}/html/index.htm"
+ # install samples
+ cp -pR "${S}${MY_P_BETA}/Samples" "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ elog "It is advised to copy the /usr/share/shorewall/configfiles dir to your"
+ elog "own 'export directories'. However, whenever you upgrade Shorewall you"
+ elog "should check for changes in configfiles and manually update your exports."
+ elog "Alternatively, if you only have one Shorewall-Lite system in your network"
+ elog "then you can use the configfiles dir but set CONFIG_PROTECT appropriately"
+ elog "in /etc/make.conf (man make.conf)."
+ elog
+ elog "${PN} now uses Perl only. The shell compiler is obsolete."
+ elog "shorewall-common, shorewall-shell and shorewall-perl have been removed."
+}