summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-06-16 14:44:05 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-06-16 14:44:05 +0000
commitaba10a51407a2462c5040824a8373d7474470001 (patch)
treeb7c100a2e273c04adccfa9be8500918073b39e44 /net-firewall/shorewall
parentamd64 stable, bug 322973. (diff)
downloadgentoo-2-aba10a51407a2462c5040824a8373d7474470001.tar.gz
gentoo-2-aba10a51407a2462c5040824a8373d7474470001.tar.bz2
gentoo-2-aba10a51407a2462c5040824a8373d7474470001.zip
Version bump, for bug #298301 by Magnus Kessler.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/shorewall')
-rw-r--r--net-firewall/shorewall/ChangeLog10
-rw-r--r--net-firewall/shorewall/files/4.4.10-underscore-not-dash.patch12
-rw-r--r--net-firewall/shorewall/shorewall-4.4.10.ebuild100
3 files changed, 120 insertions, 2 deletions
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index 536cbee2c9fc..a3a149ba4e40 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.170 2009/10/09 12:22:43 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.171 2010/06/16 14:44:05 chainsaw Exp $
+
+*shorewall-4.4.10 (16 Jun 2010)
+
+ 16 Jun 2010; <chainsaw@gentoo.org>
+ +files/4.4.10-underscore-not-dash.patch, +shorewall-4.4.10.ebuild:
+ Version bump, for bug #298301 by Magnus Kessler.
*shorewall-4.4.2.1 (09 Oct 2009)
diff --git a/net-firewall/shorewall/files/4.4.10-underscore-not-dash.patch b/net-firewall/shorewall/files/4.4.10-underscore-not-dash.patch
new file mode 100644
index 000000000000..15e3671aa59a
--- /dev/null
+++ b/net-firewall/shorewall/files/4.4.10-underscore-not-dash.patch
@@ -0,0 +1,12 @@
+diff -uNr shorewall-4.4.10.ORIG//install.sh shorewall-4.4.10/install.sh
+--- shorewall-4.4.10.ORIG//install.sh 2010-06-16 15:32:46.000000000 +0100
++++ shorewall-4.4.10/install.sh 2010-06-16 15:33:29.000000000 +0100
+@@ -745,7 +745,7 @@
+ #
+ # Install the Makefiles
+ #
+-install-file Makefile-lite ${DESTDIR}/usr/share/shorewall/configfiles/Makefile 0644
++install_file Makefile-lite ${DESTDIR}/usr/share/shorewall/configfiles/Makefile 0644
+
+ if [ -z "$SPARSE" ]; then
+ run_install $OWNERSHIP -m 0600 Makefile ${DESTDIR}/etc/shorewall
diff --git a/net-firewall/shorewall/shorewall-4.4.10.ebuild b/net-firewall/shorewall/shorewall-4.4.10.ebuild
new file mode 100644
index 000000000000..dd2e7a7b1e85
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-4.4.10.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-4.4.10.ebuild,v 1.1 2010/06/16 14:44:05 chainsaw Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="${PN}-${MY_PV_BASE}${MY_P_BETA}"
+MY_P_DOCS="${MY_P/${PN}/${PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl
+ !net-firewall/shorewall-common
+ !net-firewall/shorewall-shell
+ !net-firewall/shorewall-perl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-underscore-not-dash.patch"
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall || die "doinitd failed"
+
+ dodoc changelog.txt releasenotes.txt || die
+
+ if use doc; then
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ # install documentation
+ dohtml -r *
+ ## dosym Documentation_Index.html "/usr/share/doc/${PF}/html/index.htm"
+ # install samples
+ cp -pR "${S}${MY_P_BETA}/Samples" "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ elog
+ if use doc ; then
+ elog "Documentation is available at /usr/share/doc/${PF}/html."
+ elog "Please read the Release Notes in /usr/share/doc/${PF}."
+ elog "Samples are available at /usr/share/doc/${PF}/Samples."
+ else
+ elog "Documentation is available at http://www.shorewall.net"
+ fi
+ elog "There are man pages for shorewall(8) and for each configuration file."
+ elog
+ elog "Bridging configuration has changed with kernel 2.6.20+."
+ elog "Check the documentation."
+ elog
+ elog "Do not blindly start shorewall, edit the files in /etc/shorewall first."
+ elog
+ elog "Be aware that version ${MY_PV_TREE} differs substantially from previous releases."
+ elog "Information on upgrading is available at:"
+ elog "http://www.shorewall.net/upgrade_issues.htm"
+ elog
+ elog "There is a 'shorewall compile' command to generate scripts to run"
+ elog "on systems with Shorewall Lite installed."
+ elog "Please refer to http://www.shorewall.net/CompiledPrograms.html"
+ elog "It is advised to copy the /usr/share/shorewall/configfiles dir to your"
+ elog "own 'export directories'. However, whenever you upgrade Shorewall you"
+ elog "should check for changes in configfiles and manually update your exports."
+ elog "Alternatively, if you only have one Shorewall-Lite system in your network"
+ elog "then you can use the configfiles dir but set CONFIG_PROTECT appropriately"
+ elog "in /etc/make.conf (man make.conf)."
+ elog
+ elog "Known problems:"
+ elog "http://shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ elog
+ elog "Whether upgrading or installing you should run shorewall check,"
+ elog "correct any errors found and run shorewall restart|start."
+ elog
+ elog "${PN} now uses Perl only. The shell compiler is obsolete."
+ elog "shorewall-common, shorewall-shell and shorewall-perl have been removed."
+}