summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-07-08 10:35:54 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-07-08 10:35:54 +0000
commit2f4c255ca282c2500de152af6d121a12062d5e41 (patch)
tree09c8b17e77e4fac66ab3489fe3c590800eaa50aa /net-firewall
parentversion bump needed for www-apps/nikola-7.6.0 (diff)
downloadgentoo-2-2f4c255ca282c2500de152af6d121a12062d5e41.tar.gz
gentoo-2-2f4c255ca282c2500de152af6d121a12062d5e41.tar.bz2
gentoo-2-2f4c255ca282c2500de152af6d121a12062d5e41.zip
Fix building with kernel 3.19, wrt bug #552476. Thanks to Tomasz Chilinski <tomasz.chilinski AT chilan.com> for discovering this issue
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x60C0742D1F357D42)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipt_netflow/ChangeLog7
-rw-r--r--net-firewall/ipt_netflow/files/ipt_netflow-2.1-linux-3.19.patch45
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.1.ebuild5
3 files changed, 55 insertions, 2 deletions
diff --git a/net-firewall/ipt_netflow/ChangeLog b/net-firewall/ipt_netflow/ChangeLog
index c3fe6dd32f27..85ebaa12197b 100644
--- a/net-firewall/ipt_netflow/ChangeLog
+++ b/net-firewall/ipt_netflow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/ipt_netflow
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.25 2015/05/18 15:39:22 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.26 2015/07/08 10:35:54 pinkbyte Exp $
+
+ 08 Jul 2015; Sergey Popov <pinkbyte@gentoo.org> ipt_netflow-2.1.ebuild,
+ +files/ipt_netflow-2.1-linux-3.19.patch:
+ Fix building with kernel 3.19, wrt bug #552476. Thanks to Tomasz Chilinski
+ <tomasz.chilinski AT chilan.com> for discovering this issue
18 May 2015; Sergey Popov <pinkbyte@gentoo.org> -ipt_netflow-2.0.1.ebuild,
-ipt_netflow-2.0.1_p20150109.ebuild, -files/ipt_netflow-2.0-pax-const.patch:
diff --git a/net-firewall/ipt_netflow/files/ipt_netflow-2.1-linux-3.19.patch b/net-firewall/ipt_netflow/files/ipt_netflow-2.1-linux-3.19.patch
new file mode 100644
index 000000000000..47fec4f73da8
--- /dev/null
+++ b/net-firewall/ipt_netflow/files/ipt_netflow-2.1-linux-3.19.patch
@@ -0,0 +1,45 @@
+commit 582fd497a5f0f5ae5dce24cba042d856d63bfbe1
+Author: ABC <abc@telekom.ru>
+Date: Mon Feb 16 21:53:54 2015 +0400
+
+ Compatibility of __get_cpu_var with linux 3.19.
+
+ Fixes #28, thanks boyarsh@github.
+
+diff --git a/ipt_NETFLOW.h b/ipt_NETFLOW.h
+index bc2734f..5548e57 100644
+--- a/ipt_NETFLOW.h
++++ b/ipt_NETFLOW.h
+@@ -396,6 +396,9 @@ struct netflow_aggr_p {
+ __u16 aggr_port;
+ };
+
++#ifndef __get_cpu_var
++#define __get_cpu_var(var) (*this_cpu_ptr(&(var)))
++#endif
+ #define NETFLOW_STAT_INC(count) (__get_cpu_var(ipt_netflow_stat).count++)
+ #define NETFLOW_STAT_ADD(count, val) (__get_cpu_var(ipt_netflow_stat).count += (unsigned long long)val)
+ #define NETFLOW_STAT_SET(count, val) (__get_cpu_var(ipt_netflow_stat).count = (unsigned long long)val)
+diff --git a/testing.sh b/testing.sh
+index b465c8d..caa4f03 100755
+--- a/testing.sh
++++ b/testing.sh
+@@ -6,7 +6,7 @@ if [ "$1" = "" ]; then
+ echo Maintainer only tool.
+ exit 1
+ elif [ "$1" = all ]; then
+- exec bash $0 linux-2.6.18 centos5 linux-3.11.2 centos6 linux-3.4.66 linux-3.9.11 centos7 linux-3.14 linux-3.17
++ exec bash $0 linux-2.6.18 centos5 linux-3.11.2 centos6 linux-3.4.66 linux-3.9.11 centos7 linux-3.14 linux-3.17 linux-3.19
+ exit 1
+ fi
+
+@@ -33,6 +33,9 @@ readarray -t opts <<EOF
+ --enable-sampler=hash
+ --enable-promisc
+ EOF
++if [ "$SHORT" ]; then
++ opts=("")
++fi
+
+ colorecho() {
+ echo -e "\033[1;32m$@\033[m"
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.1.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.1.ebuild
index 742789d6fde0..8e93c16dfa5d 100644
--- a/net-firewall/ipt_netflow/ipt_netflow-2.1.ebuild
+++ b/net-firewall/ipt_netflow/ipt_netflow-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-2.1.ebuild,v 1.3 2015/05/13 09:35:56 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-2.1.ebuild,v 1.4 2015/07/08 10:35:54 pinkbyte Exp $
EAPI=5
MY_PN="${PN/_/-}"
@@ -53,6 +53,9 @@ src_prepare() {
# bug #455984
epatch "${FILESDIR}/${PN}-2.0-configure.patch"
+ # bug #552476
+ epatch "${FILESDIR}/${PN}-2.1-linux-3.19.patch"
+
epatch_user
}