summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-08-13 13:28:45 +0000
committerPeter Volkov <pva@gentoo.org>2011-08-13 13:28:45 +0000
commitc530279082698fbba4d860bb77b13de8e7c7fd7b (patch)
treea8ebf49b05efdc275c2e1f2ee7e5c280b253fe6c /net-firewall
parentDrop old. (diff)
downloadgentoo-2-c530279082698fbba4d860bb77b13de8e7c7fd7b.tar.gz
gentoo-2-c530279082698fbba4d860bb77b13de8e7c7fd7b.tar.bz2
gentoo-2-c530279082698fbba4d860bb77b13de8e7c7fd7b.zip
Version bump.
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ebtables/ChangeLog7
-rw-r--r--net-firewall/ebtables/ebtables-2.0.10.2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/net-firewall/ebtables/ChangeLog b/net-firewall/ebtables/ChangeLog
index 4073bd76b1df..5deef2b9da80 100644
--- a/net-firewall/ebtables/ChangeLog
+++ b/net-firewall/ebtables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/ebtables
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ebtables/ChangeLog,v 1.43 2011/07/15 20:31:54 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ebtables/ChangeLog,v 1.44 2011/08/13 13:28:45 pva Exp $
+
+*ebtables-2.0.10.2 (13 Aug 2011)
+
+ 13 Aug 2011; Peter Volkov <pva@gentoo.org> +ebtables-2.0.10.2.ebuild:
+ Version bump.
15 Jul 2011; Markus Meier <maekke@gentoo.org> ebtables-2.0.9.2-r2.ebuild:
x86 stable, bug #373291
diff --git a/net-firewall/ebtables/ebtables-2.0.10.2.ebuild b/net-firewall/ebtables/ebtables-2.0.10.2.ebuild
new file mode 100644
index 000000000000..195f5b2bb7a3
--- /dev/null
+++ b/net-firewall/ebtables/ebtables-2.0.10.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ebtables/ebtables-2.0.10.2.ebuild,v 1.1 2011/08/13 13:28:45 pva Exp $
+
+EAPI="4"
+
+inherit versionator eutils toolchain-funcs multilib flag-o-matic
+
+MY_PV=$(replace_version_separator 3 '-' )
+MY_P=${PN}-v${MY_PV}
+
+DESCRIPTION="Utility that enables basic Ethernet frame filtering on a Linux bridge, MAC NAT and brouting."
+HOMEPAGE="http://ebtables.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+LICENSE="GPL-2"
+SLOT="0"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use static; then
+ ewarn "You've chosen static build which is useful for embedded devices."
+ ewarn "It has no init script. Make sure that's really what you want."
+ fi
+}
+
+src_prepare() {
+ # Enhance ebtables-save to take table names as parameters bug #189315
+ epatch "${FILESDIR}/${PN}-2.0.8.1-ebt-save.diff"
+
+ sed -i -e "s,^MANDIR:=.*,MANDIR:=/usr/share/man," \
+ -e "s,^BINDIR:=.*,BINDIR:=/sbin," \
+ -e "s,^INITDIR:=.*,INITDIR:=/usr/share/doc/${PF}," \
+ -e "s,^SYSCONFIGDIR:=.*,SYSCONFIGDIR:=/usr/share/doc/${PF}," \
+ -e "s,^LIBDIR:=.*,LIBDIR:=/$(get_libdir)/\$(PROGNAME)," Makefile
+}
+
+src_compile() {
+ # This package uses _init functions to initialise extensions. With
+ # --as-needed this will not work.
+ append-ldflags $(no-as-needed)
+ # This package correctly aliases pointers, but gcc is unable to know that:
+ # unsigned char ip[4];
+ # if (*((uint32_t*)ip) == 0) {
+ append-cflags -Wno-strict-aliasing
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ $(use static && echo static)
+}
+
+src_install() {
+ if ! use static; then
+ make DESTDIR="${D}" install
+ keepdir /var/lib/ebtables/
+ newinitd "${FILESDIR}"/ebtables.initd-r1 ebtables
+ newconfd "${FILESDIR}"/ebtables.confd-r1 ebtables
+ else
+ into /
+ newsbin static ebtables
+ insinto /etc
+ doins ethertypes
+ fi
+ dodoc ChangeLog THANKS || die
+}