summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-06-26 22:54:52 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-06-26 22:54:52 +0000
commitcee3c33529445ee58b25f4e28d5d67a702b20b95 (patch)
treef1c7fc4b0905f5f8467c9994644b0d2acd46dfd0 /net-firewall
parentkeyword ~amd64-linux ~x86-linux (diff)
downloadgentoo-2-cee3c33529445ee58b25f4e28d5d67a702b20b95.tar.gz
gentoo-2-cee3c33529445ee58b25f4e28d5d67a702b20b95.tar.bz2
gentoo-2-cee3c33529445ee58b25f4e28d5d67a702b20b95.zip
version bump
(Portage version: 2.2.0_alpha113/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/pglinux/ChangeLog7
-rw-r--r--net-firewall/pglinux/pglinux-2.2.1.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/net-firewall/pglinux/ChangeLog b/net-firewall/pglinux/ChangeLog
index 825b3ae53585..fbe27c03b345 100644
--- a/net-firewall/pglinux/ChangeLog
+++ b/net-firewall/pglinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/pglinux
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/pglinux/ChangeLog,v 1.5 2012/06/12 22:22:24 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/pglinux/ChangeLog,v 1.6 2012/06/26 22:54:52 hasufell Exp $
+
+*pglinux-2.2.1 (26 Jun 2012)
+
+ 26 Jun 2012; Julian Ospald <hasufell@gentoo.org> +pglinux-2.2.1.ebuild:
+ version bump
*pglinux-2.2.0 (12 Jun 2012)
diff --git a/net-firewall/pglinux/pglinux-2.2.1.ebuild b/net-firewall/pglinux/pglinux-2.2.1.ebuild
new file mode 100644
index 000000000000..2f329703e980
--- /dev/null
+++ b/net-firewall/pglinux/pglinux-2.2.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/pglinux/pglinux-2.2.1.ebuild,v 1.1 2012/06/26 22:54:52 hasufell Exp $
+
+EAPI=4
+
+inherit gnome2-utils linux-info
+
+MY_P="pgl-${PV}"
+
+DESCRIPTION="Privacy oriented firewall application"
+HOMEPAGE="https://sourceforge.net/projects/peerguardian/"
+SRC_URI="mirror://sourceforge/peerguardian/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="cron dbus logrotate networkmanager qt4 zlib"
+
+COMMON_DEPEND="
+ net-libs/libnetfilter_queue
+ net-libs/libnfnetlink
+ dbus? ( sys-apps/dbus )
+ zlib? ( sys-libs/zlib )
+ qt4? ( sys-auth/polkit-qt
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ || ( kde-base/kdesu x11-libs/gksu x11-misc/ktsuss )
+ )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool:2"
+RDEPEND="${COMMON_DEPEND}
+ net-firewall/iptables
+ sys-apps/sysvinit
+ cron? ( virtual/cron )
+ logrotate? ( app-admin/logrotate )
+ networkmanager? ( net-misc/networkmanager )"
+
+REQUIRED_USE="qt4? ( dbus )"
+
+CONFIG_CHECK="~NETFILTER_NETLINK
+ ~NETFILTER_NETLINK_QUEUE
+ ~NETFILTER_XTABLES
+ ~NETFILTER_XT_TARGET_NFQUEUE
+ ~NETFILTER_XT_MATCH_IPRANGE
+ ~NETFILTER_XT_MARK
+ ~NETFILTER_XT_MATCH_MULTIPORT
+ ~NETFILTER_XT_MATCH_STATE
+ ~NF_CONNTRACK
+ ~NF_CONNTRACK_IPV4
+ ~NF_DEFRAG_IPV4
+ ~IP_NF_FILTER
+ ~IP_NF_IPTABLES
+ ~IP_NF_TARGET_REJECT"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable logrotate) \
+ $(use_enable cron) \
+ $(use_enable networkmanager) \
+ $(use_enable zlib) \
+ $(use_enable dbus) \
+ --disable-lowmem \
+ --with-iconsdir=/usr/share/icons/hicolor/128x128/apps \
+ $(use_with qt4)
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "optional dependencies:"
+ elog " app-arch/p7zip (needed for blocklists packed as .7z)"
+ elog " app-arch/unzip (needed for blocklists packed as .zip)"
+ elog " virtual/mta (needed to send informational (blocklist updates) and"
+ elog " warning mails (if pglcmd.wd detects a problem.))"
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}