summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-11-07 15:26:00 +0000
committerPeter Volkov <pva@gentoo.org>2007-11-07 15:26:00 +0000
commitdcd3397b64aeb3113a780c54ae7330b3a5053423 (patch)
tree06187e13ccaf543fada421a0407e14954ffab1dd /net-firewall
parent Remove Quicktime support for now, bug #150288. (diff)
downloadgentoo-2-dcd3397b64aeb3113a780c54ae7330b3a5053423.tar.gz
gentoo-2-dcd3397b64aeb3113a780c54ae7330b3a5053423.tar.bz2
gentoo-2-dcd3397b64aeb3113a780c54ae7330b3a5053423.zip
Cleaned ebuild, courtesy of Donnie Berkholz <dberkholz AT gentoo.org>
(Portage version: 2.1.3.18)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipset/ChangeLog8
-rw-r--r--net-firewall/ipset/files/digest-ipset-2.3.0.20070828-r1 (renamed from net-firewall/ipset/files/digest-ipset-2.3.0.20070828)0
-rw-r--r--net-firewall/ipset/ipset-2.3.0.20070828-r1.ebuild (renamed from net-firewall/ipset/ipset-2.3.0.20070828.ebuild)43
3 files changed, 22 insertions, 29 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index 871dc702f4f4..9af26f016fee 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.11 2007/11/05 14:23:31 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.12 2007/11/07 15:25:59 pva Exp $
+
+*ipset-2.3.0.20070828-r1 (07 Nov 2007)
+
+ 07 Nov 2007; <pva@gentoo.org> -ipset-2.3.0.20070828.ebuild,
+ +ipset-2.3.0.20070828-r1.ebuild:
+ Cleaned ebuild, courtesy of Donnie Berkholz <dberkholz AT gentoo.org>
*ipset-2.3.0.20070828 (05 Nov 2007)
diff --git a/net-firewall/ipset/files/digest-ipset-2.3.0.20070828 b/net-firewall/ipset/files/digest-ipset-2.3.0.20070828-r1
index 8aefb0736d49..8aefb0736d49 100644
--- a/net-firewall/ipset/files/digest-ipset-2.3.0.20070828
+++ b/net-firewall/ipset/files/digest-ipset-2.3.0.20070828-r1
diff --git a/net-firewall/ipset/ipset-2.3.0.20070828.ebuild b/net-firewall/ipset/ipset-2.3.0.20070828-r1.ebuild
index fb7465f0f1a5..407f4295be8e 100644
--- a/net-firewall/ipset/ipset-2.3.0.20070828.ebuild
+++ b/net-firewall/ipset/ipset-2.3.0.20070828-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.3.0.20070828.ebuild,v 1.2 2007/11/05 20:03:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.3.0.20070828-r1.ebuild,v 1.1 2007/11/07 15:25:59 pva Exp $
inherit eutils versionator toolchain-funcs
@@ -19,63 +19,50 @@ RDEPEND=">=net-firewall/iptables-1.3"
DEPEND="${RDEPEND}"
S=${WORKDIR}/ipset-${MY_PV%-*}
-src_defs() {
- # these are used in both of src_compile and src_install
+pkg_setup() {
myconf="${myconf} PREFIX="
- myconf="${myconf} LIBDIR=/lib"
+ myconf="${myconf} LIBDIR=$(get_libdir)"
myconf="${myconf} BINDIR=/sbin"
myconf="${myconf} MANDIR=/usr/share/man"
myconf="${myconf} INCDIR=/usr/include"
myconf="${myconf} KERNEL_DIR=${WORKDIR}/patch-o-matic-ng/patchlets/set/linux-2.6"
- export myconf
}
src_compile() {
- src_defs
emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} || die "failed to build"
}
src_install() {
- src_defs
emake DESTDIR="${D}" ${myconf} install || die "failed to package"
}
pkg_postinst() {
elog "To use ${PN} you must have the ip_set kernel module compiled!"
- elog "To patch your kernel run:"
+ elog "To patch you kernel run:"
elog
elog " # emerge --config ipset"
elog
- elog "And follow on-screen instructions."
+ elog "And follow on-screen instructions"
}
pkg_config() {
cd "${ROOT}${PORTAGE_TMPDIR}"
- mkdir patch-o-matic-ng
- cd patch-o-matic-ng
+ [ -d patch-o-matic-ng ] && {
+ einfo "${ROOT}${PORTAGE_TMPDIR}/patch-o-matic-ng directory exist. Cleaning it..." ;
+ rm -rf patch-o-matic-ng;
+ }
+ mkdir patch-o-matic-ng && cd patch-o-matic-ng
IPTVERINS=`echo $(best_version net-firewall/iptables) | \
sed -n 's:^[^/]*/[[:alpha:]]*-\([0-9]\+\([.][0-9]\+\)*[a-z]\?\(_\(pre\|p\|beta\|alpha\|rc\)[0-9]*\)*\)\(-r[0-9]\+\)\?$:\1:p'`
- einfo "Unpacking patch-o-matic-ng-${POM_PV}"
- tar -jxf "${DISTDIR}"/patch-o-matic-ng-${POM_PV}.tar.bz2 || \
- die "Unable to unpack patch-o-matic-ng-${POM_PV}"
- einfo "Unpacking iptables-${IPTVERINS}"
- tar -jxf "${DISTDIR}"/iptables-${IPTVERINS}.tar.bz2 || \
- die "Unable to unpack iptables-${IPTVERINS}.tar.bz2"
+ einfo "Unpacking patch-o-matic-ng-${POM_PV} and iptables-${IPTVERINS} sources"
+ unpack {patch-o-matic-ng-${POM_PV},iptables-${IPTVERINS}}.tar.bz2
+ einfo "I'm going to patch sources in ${ROOT}usr/src/linux"
cd patch-o-matic-ng
- einfo "Enter path to your kernel sources, relative to ${ROOT}"
- echo -n "[/usr/src/linux]: "
- read K_DIR
- [ "${ROOT}${K_DIR}" == "/" ] && K_DIR=${ROOT}/usr/src/linux
- if [ -d "${K_DIR}" ] ; then
- pwd
- einfo "Running KERNEL_DIR=${K_DIR} IPTABLES_DIR=../iptables-${IPTVERINS} ./runme set"
- KERNEL_DIR=${K_DIR} IPTABLES_DIR=../iptables-${IPTVERINS} ./runme set
- else
- eerror "${K_DIR} is not a directory"
- fi
+ KERNEL_DIR="${ROOT}"usr/src/linux IPTABLES_DIR=../iptables-${IPTVERINS} ./runme set
+ einfo "Cleaning ${ROOT}${PORTAGE_TMPDIR}/patch-o-matic-ng directory"
rm -rf "${ROOT}${PORTAGE_TMPDIR}"/patch-o-matic-ng
}