summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-07 15:29:37 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-07 15:29:37 +0000
commite74088629da168efce3dc11a907535ccab6c600f (patch)
treeca1d4a6501393464e3a43ab3d47b0a406714829f /net-firewall
parentBump to eapi5, set subslot to PV as its a lib, use slot deps. (diff)
downloadgentoo-2-e74088629da168efce3dc11a907535ccab6c600f.tar.gz
gentoo-2-e74088629da168efce3dc11a907535ccab6c600f.tar.bz2
gentoo-2-e74088629da168efce3dc11a907535ccab6c600f.zip
Revision bump: EAPI 5, fix for pkgconfig 0.28 support via patch for configure script. Thanks to Jeroen Roovers for patch
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipt_netflow/ChangeLog11
-rw-r--r--net-firewall/ipt_netflow/files/ipt_netflow-1.8-configure.patch26
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild63
3 files changed, 98 insertions, 2 deletions
diff --git a/net-firewall/ipt_netflow/ChangeLog b/net-firewall/ipt_netflow/ChangeLog
index a71e4b54a97d..324e5dfda61d 100644
--- a/net-firewall/ipt_netflow/ChangeLog
+++ b/net-firewall/ipt_netflow/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/ipt_netflow
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.1 2012/10/14 11:26:44 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.2 2013/02/07 15:29:37 pinkbyte Exp $
+
+*ipt_netflow-1.8-r1 (07 Feb 2013)
+
+ 07 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> +ipt_netflow-1.8-r1.ebuild,
+ +files/ipt_netflow-1.8-configure.patch:
+ Revision bump: EAPI 5, fix for pkgconfig 0.28 support via patch for configure
+ script. Thanks to Jeroen Roovers for patch
*ipt_netflow-1.8 (14 Oct 2012)
diff --git a/net-firewall/ipt_netflow/files/ipt_netflow-1.8-configure.patch b/net-firewall/ipt_netflow/files/ipt_netflow-1.8-configure.patch
new file mode 100644
index 000000000000..bb3820a17e94
--- /dev/null
+++ b/net-firewall/ipt_netflow/files/ipt_netflow-1.8-configure.patch
@@ -0,0 +1,26 @@
+Patch by Jeroen Roovers from https://bugs.gentoo.org/show_bug.cgi?id=455984
+
+Fixes failure on configure stage with pkgconfig 0.28
+--- a/configure
++++ b/configure
+@@ -11,10 +11,7 @@
+ test "$IPTSRC" || return 1
+
+ echo -n "Checking iptables sources version: "
+- SRC="$IPTSRC/Makefile"
+- test -s "$SRC" || error "Please build iptables first."
+- VER=`sed -n 's/^\(IPTABLES_\)\?VERSION[ :]= \?//p' "$SRC"`
+- test "$VER" || error "Unknown version of iptables."
++ VER=`pkg-config --modversion xtables`
+ if [ "$VER" = "$IPTVER" ]; then
+ echo "$VER (ok)"
+ else
+@@ -155,7 +152,7 @@
+ iptables_pkg_config() {
+ if [ ! "$PKGVER" ]; then
+ echo -n "pkg-config for version $IPTVER exists: "
+- PKGVER=`pkg-config --exact-version=$IPTVER --modversion xtables 2>/dev/null`
++ PKGVER=`pkg-config --modversion xtables 2>/dev/null`
+ if [ $? = 0 ]; then
+ echo "Yes"
+ else
diff --git a/net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild b/net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild
new file mode 100644
index 000000000000..a4cd7db8b14b
--- /dev/null
+++ b/net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild,v 1.1 2013/02/07 15:29:37 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils linux-info linux-mod multilib toolchain-funcs
+
+MY_PN="ipt-netflow"
+
+DESCRIPTION="Netflow iptables module"
+HOMEPAGE="http://sourceforge.net/projects/ipt-netflow"
+SRC_URI="mirror://sourceforge/${MY_PN}/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="net-firewall/iptables"
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ virtual/pkgconfig"
+
+BUILD_TARGETS="all"
+CONFIG_CHECK="IP_NF_IPTABLES"
+MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
+
+IPT_LIB=/usr/$(get_libdir)/xtables
+
+src_prepare() {
+ sed -i -e 's:-I$(KDIR)/include::' \
+ -e 's:gcc -O2:$(CC) $(CFLAGS) $(LDFLAGS):' \
+ -e 's:gcc:$(CC) $(CFLAGS) $(LDFLAGS):' Makefile.in || die 'sed on Makefile.in failed'
+ sed -i -e '/IPT_NETFLOW_VERSION/s/1.7.2/1.8/' ipt_NETFLOW.c || die 'sed on ipt_NETFLOW.c failed'
+ epatch "${FILESDIR}"/${PN}-1.8-configure.patch
+}
+
+src_configure() {
+ local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
+ # econf can not be used, cause configure script fails when see unknown parameter
+ # ipt-src need to be defined, see bug #455984
+ ./configure \
+ --ipt-lib="${IPT_LIB}" \
+ --ipt-src="/usr/" \
+ --ipt-ver="${IPT_VERSION}" \
+ --kdir="${KV_DIR}" \
+ --kver="${KV_FULL}" \
+ || die 'configure failed'
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ emake CC="$(tc-getCC)" all
+}
+
+src_install() {
+ linux-mod_src_install
+ exeinto "${IPT_LIB}"
+ doexe libipt_NETFLOW.so
+ insinto /usr/include
+ doins ipt_NETFLOW.h
+ dodoc README*
+}