summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-04-23 18:28:30 +0000
committerPacho Ramos <pacho@gentoo.org>2012-04-23 18:28:30 +0000
commit05e0afbbbb16d1c7719975be165822e541bc7d7d (patch)
tree83f4cf0590c4faf3b435fb0ece06e20b2fd10897 /net-fs/coda/files
parentPackage removal. (diff)
downloadgentoo-2-05e0afbbbb16d1c7719975be165822e541bc7d7d.tar.gz
gentoo-2-05e0afbbbb16d1c7719975be165822e541bc7d7d.tar.bz2
gentoo-2-05e0afbbbb16d1c7719975be165822e541bc7d7d.zip
Package removal.
Diffstat (limited to 'net-fs/coda/files')
-rw-r--r--net-fs/coda/files/6.0.15/auth253
-rw-r--r--net-fs/coda/files/6.0.15/coda-update60
-rw-r--r--net-fs/coda/files/6.0.15/codasrv44
-rw-r--r--net-fs/coda/files/6.0.15/venus31
-rw-r--r--net-fs/coda/files/coda-6.0.15-mit-krb5-struct.patch29
-rw-r--r--net-fs/coda/files/fixdeps.patch17
-rw-r--r--net-fs/coda/files/gentoo-init.patch27
-rw-r--r--net-fs/coda/files/vice-setup.in.patch64
8 files changed, 0 insertions, 325 deletions
diff --git a/net-fs/coda/files/6.0.15/auth2 b/net-fs/coda/files/6.0.15/auth2
deleted file mode 100644
index 9e1f3386e85d..000000000000
--- a/net-fs/coda/files/6.0.15/auth2
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/6.0.15/auth2,v 1.1 2008/07/12 22:31:41 chtekk Exp $
-
-depend() {
- need net
-}
-
-checkconfig() {
- if [ ! -e $vicedir/hostname ] ; then
- eerror "Please run vice-setup before starting the service..."
- return 1
- fi
-}
-
-we_are_scm() {
- if [ "`cat $vicedir/hostname`" = "`cat $vicedir/db/scm`" ] ; then
- return 0
- else
- return 1
- fi
-}
-
-getvicedir() {
- vicedir=`/usr/sbin/codaconfedit server.conf vicedir`
-}
-
-start() {
- getvicedir
-
- checkconfig || return 1
-
- ebegin "Starting auth2"
-
- # Check to see if we are the SCM. If not, we must add -chk to auth2
-
- if (! we_are_scm) ; then
- start-stop-daemon --start --quiet --exec /usr/sbin/auth2 \
- --background -- -chk
- else
- start-stop-daemon --start --quiet --exec /usr/sbin/auth2 \
- --background
- fi
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping auth2"
- start-stop-daemon --stop --quiet --exec /usr/sbin/auth2
- eend $?
-}
diff --git a/net-fs/coda/files/6.0.15/coda-update b/net-fs/coda/files/6.0.15/coda-update
deleted file mode 100644
index 7d9cd34f8bf1..000000000000
--- a/net-fs/coda/files/6.0.15/coda-update
+++ /dev/null
@@ -1,60 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/6.0.15/coda-update,v 1.1 2008/07/12 22:31:41 chtekk Exp $
-
-depend() {
- need net auth2
-}
-
-checkconfig() {
- if [ ! -e $vicedir/hostname ] ; then
- eerror "Please run vice-setup before starting the service..."
- return 1
- fi
-}
-
-we_are_scm() {
- if [ "`cat $vicedir/hostname`" = "`cat $vicedir/db/scm`" ] ; then
- return 0
- else
- return 1
- fi
-}
-
-getvicedir() {
- vicedir=`/usr/sbin/codaconfedit server.conf vicedir`
-}
-
-start() {
- getvicedir
-
- checkconfig || return 1
-
- ebegin "Starting coda-update"
-
- # Check to see if we are the SCM.
- if we_are_scm ; then
- start-stop-daemon --start --quiet --exec /usr/sbin/rpc2portmap
- start-stop-daemon --start --quiet --exec /usr/sbin/updatesrv
- fi
-
- start-stop-daemon --start --quiet --exec /usr/sbin/updateclnt
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping coda-update"
-
- getvicedir
-
- if we_are_scm ; then
- start-stop-daemon --stop --quiet --exec /usr/sbin/rpc2portmap
- start-stop-daemon --stop --quiet --exec /usr/sbin/updatesrv
- fi
-
- start-stop-daemon --stop --quiet --exec /usr/sbin/updateclnt
-
- eend $?
-}
diff --git a/net-fs/coda/files/6.0.15/codasrv b/net-fs/coda/files/6.0.15/codasrv
deleted file mode 100644
index 7bf9fd4655a9..000000000000
--- a/net-fs/coda/files/6.0.15/codasrv
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/6.0.15/codasrv,v 1.1 2008/07/12 22:31:41 chtekk Exp $
-
-depend() {
- need net coda-update auth2
-}
-
-checkconfig() {
- if [ ! -e $vicedir/hostname ] ; then
- eerror "Please run vice-setup before starting the service..."
- return 1
- fi
-}
-
-we_are_scm() {
- if [ "`cat $vicedir/hostname`" = "`cat $vicedir/db/scm`" ] ; then
- return 0
- else
- return 1
- fi
-}
-
-getvicedir() {
- vicedir=`/usr/sbin/codaconfedit server.conf vicedir`
-}
-
-start() {
- getvicedir
-
- checkconfig || return 1
-
- ebegin "Starting codasrv"
- start-stop-daemon --start --background --exec /usr/sbin/codasrv
- eend $?
-}
-
-stop() {
- ebegin "Stopping codasrv"
- msg=`/usr/sbin/volutil shutdown 2>&1` || echo "$msg"
- start-stop-daemon --stop --quiet --retry 30/TERM --oknodo --exec /usr/sbin/codasrv
- eend $?
-}
diff --git a/net-fs/coda/files/6.0.15/venus b/net-fs/coda/files/6.0.15/venus
deleted file mode 100644
index f4666630cdff..000000000000
--- a/net-fs/coda/files/6.0.15/venus
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/6.0.15/venus,v 1.1 2006/06/08 12:47:31 griffon26 Exp $
-
-depend() {
- need net
- after codasrv
-}
-
-checkconfig() {
- if ! /usr/sbin/codaconfedit venus.conf &>/dev/null; then
- eerror "Please run venus-setup before starting the service..."
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting venus"
- start-stop-daemon --start --quiet --exec /usr/sbin/venus > /dev/null
- eend $?
-}
-
-stop() {
- ebegin "Stopping venus"
- start-stop-daemon --stop --quiet --exec /usr/sbin/venus
- umount -l coda &>/dev/null
- eend $?
-}
diff --git a/net-fs/coda/files/coda-6.0.15-mit-krb5-struct.patch b/net-fs/coda/files/coda-6.0.15-mit-krb5-struct.patch
deleted file mode 100644
index d74a159b699b..000000000000
--- a/net-fs/coda/files/coda-6.0.15-mit-krb5-struct.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -ruN coda-6.0.15/coda-src/auth2/krb5.c coda-6.0.15-fixed/coda-src/auth2/krb5.c
---- coda-6.0.15/coda-src/auth2/krb5.c 2005-04-13 16:27:00.000000000 +0200
-+++ coda-6.0.15-fixed/coda-src/auth2/krb5.c 2006-06-08 14:11:17.287528250 +0200
-@@ -54,14 +54,14 @@
- #define tkt_realm(t) ((t)->client->realm)
- #define tkt_realmlen(t) (strlen((t)->client->realm))
- #define tkt_client(t) ((t)->client)
--#define tkt_key(t) ((t)->ticket.key)
-+#define tkt_key(t) (&(t)->ticket.key)
- #define key_data(k) ((k)->keyvalue.data)
- #define key_length(k) ((k)->keyvalue.length)
- #else
- #define tkt_realm(t) ((t)->enc_part2->client->realm.data)
- #define tkt_realmlen(t) ((t)->enc_part2->client->realm.length)
- #define tkt_client(t) ((t)->enc_part2->client)
--#define tkt_key(t) ((t)->session)
-+#define tkt_key(t) ((t)->enc_part2->session)
- #define key_data(k) ((k)->contents)
- #define key_length(k) ((k)->length)
- #endif
-@@ -334,7 +334,7 @@
- /* now prepare the keys */
-
- /* hKey is the md5 hash of the kerberos session secret */
-- HashSecret(key_data(&tkt_key(ticket)), key_length(&tkt_key(ticket)), hKey);
-+ HashSecret(key_data(tkt_key(ticket)), key_length(tkt_key(ticket)), hKey);
-
- /* sKey is a random sequence of bytes */
- GenerateSecret(sKey);
diff --git a/net-fs/coda/files/fixdeps.patch b/net-fs/coda/files/fixdeps.patch
deleted file mode 100644
index 7c64a5c59e47..000000000000
--- a/net-fs/coda/files/fixdeps.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -Nuar coda-6.9.3.old/coda-src/auth2/Makefile.am coda-6.9.3/coda-src/auth2/Makefile.am
---- coda-6.9.3.old/coda-src/auth2/Makefile.am 2007-12-17 09:20:25.000000000 -0800
-+++ coda-6.9.3/coda-src/auth2/Makefile.am 2008-07-06 14:10:10.000000000 -0700
-@@ -20,11 +20,11 @@
- if WANT_KERBEROS
- if WANT_KRB4
- KRBSRC += krb4.c
--LIBKRB += $(LIBKRB4)
-+LIBKRB += $(LIBKRB4) ../util/libutil.la
- endif
- if WANT_KRB5
- KRBSRC += krb5.c
--LIBKRB += $(LIBKRB5)
-+LIBKRB += $(LIBKRB5) ../util/libutil.la
- endif
- KRBSRC += krbcommon.c krbcommon.h
- endif
diff --git a/net-fs/coda/files/gentoo-init.patch b/net-fs/coda/files/gentoo-init.patch
deleted file mode 100644
index 05b52081b6f3..000000000000
--- a/net-fs/coda/files/gentoo-init.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -ruaN coda-6.9.3.old/coda-src/scripts/Makefile.am coda-6.9.3/coda-src/scripts/Makefile.am
---- coda-6.9.3.old/coda-src/scripts/Makefile.am 2007-12-11 12:06:17.000000000 -0800
-+++ coda-6.9.3/coda-src/scripts/Makefile.am 2008-07-06 22:44:57.000000000 -0700
-@@ -9,9 +9,7 @@
- sbin_SCRIPTS += venus-setup
- dist_sbin_SCRIPTS += volmunge
- dist_man_MANS += venus-setup.8 volmunge.8
--if SYSVINIT
--init_SCRIPTS += venus.init
--endif
-+init_SCRIPTS += venus
- endif
- if BUILD_SERVER
- sbin_SCRIPTS += bldvldb.sh createvol_rep purgevol_rep startserver vice-setup \
-@@ -21,11 +19,7 @@
- vice-setup-srvdir vice-setup-user
- dist_man_MANS += bldvldb.sh.8 createvol_rep.8 maxgroupid.5 purgevol_rep.8 \
- startserver.8 vice-setup.8 volumelist.5
--if SYSVINIT
--dist_init_SCRIPTS += auth2.init codasrv.init update.init
--else
--init_SCRIPTS += rc.vice
--endif
-+init_SCRIPTS += codasrv
- endif
- EXTRA_DIST = findparents.sh volinfo.pl volsizes.pl
- CLEANFILES = $(sbin_SCRIPTS) $(init_SCRIPTS)
diff --git a/net-fs/coda/files/vice-setup.in.patch b/net-fs/coda/files/vice-setup.in.patch
deleted file mode 100644
index 9e5cf6ec5a88..000000000000
--- a/net-fs/coda/files/vice-setup.in.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff -ru coda-6.9.5.orig/coda-src/scripts/vice-setup.in coda-6.9.5/coda-src/scripts/vice-setup.in
---- coda-6.9.5.orig/coda-src/scripts/vice-setup.in 2008-08-08 21:09:37.000000000 +0200
-+++ coda-6.9.5/coda-src/scripts/vice-setup.in 2010-05-10 17:12:22.013409206 +0200
-@@ -345,57 +345,9 @@
- DP=`cat ${vicedir}/db/vicetab | awk '{print $2}' | head -n 1`
- echo "Congratulations: your configuration is ready..."
- echo
--
-- start=""
-- yesno=""
-- until [ "x$yesno" != x ]; do
-- echon 'Shall I try to get things started? (y/n) '
-- read yesno
-- done
-- if [ "x$yesno" = xy -o "x$yesno" = xyes -o "x$yesno" = xY ]; then
-- start=Y
-- else
-- echo "Here is what you would have to do to get things up and running"
-- fi
--
-- set -e
-- echo " - Coda authentication server (auth2 &)"
-- [ "$start" ] && @sbindir@/auth2 &
-- echo " - Coda update server (updatesrv)"
-- [ "$start" ] && @sbindir@/updatesrv
-- echo " - Coda update client (updateclnt -h $hn)"
-- [ "$start" ] && @sbindir@/updateclnt -h $hn
--
-- if [ $numservers = 1 ]; then
-- echo " - Coda file server (startserver)"
-- [ "$start" ] && @sbindir@/startserver
-- else
-- echo " - Coda file servers:"
-- n=1
-- while [ $n -le $numservers ]; do
-- echo " startserver -n $n"
-- [ "$start" ] && @sbindir@/startserver -n $n
-- n=`expr $n + 1`
-- done
-- fi
-- echo
--
-- if [ "$start" ] ; then
-- echo
-- echo "Nice, it looks like everything went ok"
-- echo "Now I'll try to create an initial root volume"
-- fi
--
-- echo " - createvol_rep / ${hn}${DP}"
-- [ "$start" ] && @sbindir@/createvol_rep / ${hn}${DP}
--
-- if [ "$start" ] ; then
-- echo
-- echo "That seems to have worked..."
-- echo "If you have a working Coda client you should now be able to"
-- echo "access the new Coda realm"
-- echo " - cfs lv /coda/${hn}/"
-- fi
-+ echo "To test configuration run /etc/init.d/codasrv start"
-+ echo "To start coda server at boot, run rc-update add codasrv default"
-+ echo "To create root volume run: createvol_rep / ${hn}${DP}"
- echo
- echo "enjoy Coda."
- echo " for more information see http://www.coda.cs.cmu.edu."