summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@gentoo.org>2001-12-02 14:17:10 +0000
committerRyan Tolboom <ryan@gentoo.org>2001-12-02 14:17:10 +0000
commit35c8e2b7988723ddbd035bc7d05c2455297ed866 (patch)
treec6ed60e8fb3b1c9bf2a037d523ba16b1d1f8910d /net-fs/ftpfs
parentnew version (diff)
downloadgentoo-2-35c8e2b7988723ddbd035bc7d05c2455297ed866.tar.gz
gentoo-2-35c8e2b7988723ddbd035bc7d05c2455297ed866.tar.bz2
gentoo-2-35c8e2b7988723ddbd035bc7d05c2455297ed866.zip
ftpfs allows mounting of ftp servers as FTP volumes
Diffstat (limited to 'net-fs/ftpfs')
-rw-r--r--net-fs/ftpfs/files/digest-ftpfs-0.6.21
-rw-r--r--net-fs/ftpfs/ftpfs-0.6.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-fs/ftpfs/files/digest-ftpfs-0.6.2 b/net-fs/ftpfs/files/digest-ftpfs-0.6.2
new file mode 100644
index 000000000000..e5ded0841a2c
--- /dev/null
+++ b/net-fs/ftpfs/files/digest-ftpfs-0.6.2
@@ -0,0 +1 @@
+MD5 5e160de7f7237cdb27e5bc6f234e8c14 ftpfs-0.6.2-k2.4.tar.gz 49152
diff --git a/net-fs/ftpfs/ftpfs-0.6.2.ebuild b/net-fs/ftpfs/ftpfs-0.6.2.ebuild
new file mode 100644
index 000000000000..e73e48f523bb
--- /dev/null
+++ b/net-fs/ftpfs/ftpfs-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ryan Tolboom <ryan@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ftpfs/ftpfs-0.6.2.ebuild,v 1.1 2001/12/02 14:17:10 ryan Exp $
+
+A=${P}-k2.4.tar.gz
+S=${WORKDIR}/${P}-k2.4
+DESCRIPTION="A filesystem for mounting FTP volumes"
+SRC_URI="http://ftp1.sourceforge.net/ftpfs/${A}"
+HOMEPAGE="http://ftpfs.sourceforge.net"
+
+DEPEND="virtual/glibc
+ virtual/kernel"
+
+src_compile() {
+ cd ftpfs
+ try make
+ cd ../ftpmount
+ try make CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ try make MODULESDIR=${D}/lib/modules/`uname -r` FTPMOUNT=${D}/usr/bin/ftpmount install
+ dodoc CHANGELOG
+ docinto html
+ dodoc docs/*.html
+ docinto html/img
+ dodoc docs/img/*
+ try depmod -aq
+}