summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-01-21 09:21:33 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-01-21 09:21:33 +0000
commit7938a5c0016efc070a662eff71037d28c59a387a (patch)
treec899339b73a82784ac4784637a355eb1e5642282 /net-fs/mount-cifs
parentfix depend because it crashes with old curl, bug 203230 (diff)
downloadgentoo-2-7938a5c0016efc070a662eff71037d28c59a387a.tar.gz
gentoo-2-7938a5c0016efc070a662eff71037d28c59a387a.tar.bz2
gentoo-2-7938a5c0016efc070a662eff71037d28c59a387a.zip
Version bump including security fix (bug #206502, thanks to Jakub Moc for providing).
(Portage version: 2.1.4)
Diffstat (limited to 'net-fs/mount-cifs')
-rw-r--r--net-fs/mount-cifs/ChangeLog9
-rw-r--r--net-fs/mount-cifs/files/digest-mount-cifs-3.0.283
-rw-r--r--net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff23
-rw-r--r--net-fs/mount-cifs/mount-cifs-3.0.28.ebuild38
4 files changed, 72 insertions, 1 deletions
diff --git a/net-fs/mount-cifs/ChangeLog b/net-fs/mount-cifs/ChangeLog
index 9d43a7a7553d..a9ca42bbd5e0 100644
--- a/net-fs/mount-cifs/ChangeLog
+++ b/net-fs/mount-cifs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/mount-cifs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/mount-cifs/ChangeLog,v 1.7 2008/01/10 20:13:24 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/mount-cifs/ChangeLog,v 1.8 2008/01/21 09:21:33 dev-zero Exp $
+
+*mount-cifs-3.0.28 (21 Jan 2008)
+
+ 21 Jan 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +files/user-unmount-ioctl-fix-bug4784.diff, +mount-cifs-3.0.28.ebuild:
+ Version bump including security fix (bug #206502, thanks to Jakub Moc for
+ providing).
10 Jan 2008; Brent Baude <ranger@gentoo.org> mount-cifs-3.0.25c.ebuild:
Marking mount-cifs-3.0.25c ~ppc for bug 200837
diff --git a/net-fs/mount-cifs/files/digest-mount-cifs-3.0.28 b/net-fs/mount-cifs/files/digest-mount-cifs-3.0.28
new file mode 100644
index 000000000000..dc70d8d6f177
--- /dev/null
+++ b/net-fs/mount-cifs/files/digest-mount-cifs-3.0.28
@@ -0,0 +1,3 @@
+MD5 d57464f51b88b94e5e1eaa2e64d25ab8 mount-cifs-3.0.28.tar.bz2 21764
+RMD160 03607cf63aaeef074e03d2e3758f7a1dd19d47e3 mount-cifs-3.0.28.tar.bz2 21764
+SHA256 fd0164979182010a034b93e4ad7974a03bf4c431470a1c93ac99fd4b5bd8b2af mount-cifs-3.0.28.tar.bz2 21764
diff --git a/net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff b/net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff
new file mode 100644
index 000000000000..7be08ff04588
--- /dev/null
+++ b/net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff
@@ -0,0 +1,23 @@
+From: Jeremy Allison <jra@samba.org>
+Date: Thu, 13 Dec 2007 02:45:20 +0000 (-0800)
+Subject: Fix bug #4784. Patch from Steve Langasek <vorlon@debian.org>.
+X-Git-Url: http://gitweb.samba.org/?p=samba.git;a=commitdiff_plain;h=244230eb619c6699e962bb24f8f6e4dd2a1235c7
+
+Fix bug #4784. Patch from Steve Langasek <vorlon@debian.org>.
+Jeremy.
+---
+
+diff --git a/source/client/umount.cifs.c b/source/client/umount.cifs.c
+index 47ddd1e..70829eb 100644
+--- a/source/client/umount.cifs.c
++++ b/source/client/umount.cifs.c
+@@ -131,7 +131,7 @@ static int umount_check_perm(char * dir)
+ printf("user unmounting via %s is an optional feature of",thisprogram);
+ printf(" the cifs filesystem driver (cifs.ko)");
+ printf("\n\tand requires cifs.ko version 1.32 or later\n");
+- } else if (rc > 0)
++ } else if (rc != 0)
+ printf("user unmount of %s failed with %d %s\n",dir,errno,strerror(errno));
+ close(fileid);
+
+
diff --git a/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild b/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild
new file mode 100644
index 000000000000..0c0f0b861348
--- /dev/null
+++ b/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild,v 1.1 2008/01/21 09:21:33 dev-zero Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="cifs filesystem mount helper split from Samba"
+HOMEPAGE="http://linux-cifs.samba.org/cifs/cifs_download.html"
+SRC_URI="http://dev.gentooexperimental.org/~jakub/distfiles/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="!<net-fs/samba-3.0.25"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/user-unmount-ioctl-fix-bug4784.diff
+}
+
+src_compile() {
+ cd "${S}/source/client"
+ $(tc-getCC) ${CFLAGS} mount.cifs.c -o mount.cifs || die "make mount.cifs failed"
+ $(tc-getCC) ${CFLAGS} umount.cifs.c -o umount.cifs || die "make umount.cifs failed"
+}
+
+src_install() {
+ dobin source/client/{mount,umount}.cifs
+ dosym /usr/bin/mount.cifs /sbin/mount.cifs
+
+ docinto html
+ dohtml docs/htmldocs/*
+ doman docs/manpages/{mount,umount}.cifs.8
+}