summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-04-20 09:34:27 +0000
committerMike Frysinger <vapier@gentoo.org>2010-04-20 09:34:27 +0000
commitf1cd4d118cfe60504575da6a136a417568831c68 (patch)
tree3b059370d75de61fb011560e2776064b03d23093 /net-fs/ncpfs
parentMake libcap support optional via USE=caps #314777. (diff)
downloadgentoo-2-f1cd4d118cfe60504575da6a136a417568831c68.tar.gz
gentoo-2-f1cd4d118cfe60504575da6a136a417568831c68.tar.bz2
gentoo-2-f1cd4d118cfe60504575da6a136a417568831c68.zip
Clean up ebuild, respect env LDFLAGS, fix multilib pam issues #273486 by Rion, and fix sandbox violations w/ldconfig #273484 by Rion.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/ncpfs')
-rw-r--r--net-fs/ncpfs/ChangeLog10
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.6-r1.ebuild43
2 files changed, 51 insertions, 2 deletions
diff --git a/net-fs/ncpfs/ChangeLog b/net-fs/ncpfs/ChangeLog
index bd1c89b0efbb..a42ee4486201 100644
--- a/net-fs/ncpfs/ChangeLog
+++ b/net-fs/ncpfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/ncpfs
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.24 2008/05/14 22:16:53 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.25 2010/04/20 09:34:27 vapier Exp $
+
+*ncpfs-2.2.6-r1 (20 Apr 2010)
+
+ 20 Apr 2010; Mike Frysinger <vapier@gentoo.org> +ncpfs-2.2.6-r1.ebuild:
+ Clean up ebuild, respect env LDFLAGS, fix multilib pam issues #273486 by
+ Rion, and fix sandbox violations w/ldconfig #273484 by Rion.
14 May 2008; Diego Pettenò <flameeyes@gentoo.org> ncpfs-2.2.6.ebuild:
Depend on virtual/pam as the code builds fine with OpenPAM.
diff --git a/net-fs/ncpfs/ncpfs-2.2.6-r1.ebuild b/net-fs/ncpfs/ncpfs-2.2.6-r1.ebuild
new file mode 100644
index 000000000000..f9f4cd292888
--- /dev/null
+++ b/net-fs/ncpfs/ncpfs-2.2.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.6-r1.ebuild,v 1.1 2010/04/20 09:34:27 vapier Exp $
+
+EAPI="2"
+
+inherit eutils pam
+
+DESCRIPTION="Provides Access to Netware services using the NCP protocol"
+HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/ncpfs/"
+SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls pam php"
+
+DEPEND="nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )
+ php? ( || ( virtual/php virtual/httpd-php ) )"
+
+src_prepare() {
+ # add patch for PHP extension sandbox violation
+ epatch "${FILESDIR}"/${PN}-2.2.5-php.patch
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ epatch "${FILESDIR}"/${P}-missing-includes.patch
+ sed -i '/ldconfig/d' lib/Makefile.in #273484
+ # hack inject LDFLAGS into the build
+ sed -i '/^LIBS/s:=:= @LDFLAGS@:' `find -name Makefile.in` || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable pam pam "$(getpam_mod_dir)") \
+ $(use_enable php)
+}
+
+src_install() {
+ dodir $(getpam_mod_dir) /usr/sbin /sbin
+ emake DESTDIR="${D}" install || die
+ dodoc FAQ README
+}