summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-07-15 12:34:43 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-07-15 12:34:43 +0000
commit9dd4c6d9b13a741c023e622101d935c6f06aaba8 (patch)
treed1c8892529ee080e17c613022342b7e255557a37 /net-fs/samba
parentdrop app-emulation/emul-linux-x86-xlibs dependency from 3.2.x ebuilds, not ne... (diff)
downloadgentoo-2-9dd4c6d9b13a741c023e622101d935c6f06aaba8.tar.gz
gentoo-2-9dd4c6d9b13a741c023e622101d935c6f06aaba8.tar.bz2
gentoo-2-9dd4c6d9b13a741c023e622101d935c6f06aaba8.zip
Do variable adjustments based on useflag in pkg_setup.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/samba')
-rw-r--r--net-fs/samba/ChangeLog6
-rw-r--r--net-fs/samba/samba-4.0.0_alpha11.ebuild41
2 files changed, 25 insertions, 22 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index f9b87b12d89c..db1694fed4ae 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.426 2010/07/14 16:20:24 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.427 2010/07/15 12:34:43 scarabeus Exp $
+
+ 15 Jul 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ samba-4.0.0_alpha11.ebuild:
+ Do variable adjustments based on useflag in pkg_setup.
14 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
samba-4.0.0_alpha11.ebuild:
diff --git a/net-fs/samba/samba-4.0.0_alpha11.ebuild b/net-fs/samba/samba-4.0.0_alpha11.ebuild
index a5592e8091a5..8bf93cf68ecd 100644
--- a/net-fs/samba/samba-4.0.0_alpha11.ebuild
+++ b/net-fs/samba/samba-4.0.0_alpha11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.0_alpha11.ebuild,v 1.4 2010/07/14 16:20:24 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.0_alpha11.ebuild,v 1.5 2010/07/15 12:34:43 scarabeus Exp $
EAPI="2"
@@ -37,27 +37,26 @@ RESTRICT="mirror"
S="${WORKDIR}/${MY_P}/source4"
-SBINPROGS=""
-if use server ; then
- SBINPROGS="${SBINPROGS} bin/samba"
-fi
-if use client ; then
- SBINPROGS="${SBINPROGS} bin/mount.cifs bin/umount.cifs"
-fi
-
-BINPROGS=""
-if use client ; then
- BINPROGS="${BINPROGS} bin/smbclient bin/net bin/nmblookup bin/ntlm_auth"
-fi
-if use server ; then
- BINPROGS="${BINPROGS} bin/testparm bin/smbtorture"
-fi
-if use tools ; then
- # Should be in sys-libs/ldb, but there's no ldb release yet
- BINPROGS="${BINPROGS} bin/ldbedit bin/ldbsearch bin/ldbadd bin/ldbdel bin/ldbmodify bin/ldbrename"
-fi
-
pkg_setup() {
+ SBINPROGS=""
+ if use server ; then
+ SBINPROGS="${SBINPROGS} bin/samba"
+ fi
+ if use client ; then
+ SBINPROGS="${SBINPROGS} bin/mount.cifs bin/umount.cifs"
+ fi
+
+ BINPROGS=""
+ if use client ; then
+ BINPROGS="${BINPROGS} bin/smbclient bin/net bin/nmblookup bin/ntlm_auth"
+ fi
+ if use server ; then
+ BINPROGS="${BINPROGS} bin/testparm bin/smbtorture"
+ fi
+ if use tools ; then
+ # Should be in sys-libs/ldb, but there's no ldb release yet
+ BINPROGS="${BINPROGS} bin/ldbedit bin/ldbsearch bin/ldbadd bin/ldbdel bin/ldbmodify bin/ldbrename"
+ fi
confutils_use_depend_all server python
}