summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-03-20 04:07:52 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-03-20 04:07:52 +0000
commit484af108b0b70ad64f5c40f12705117c1f8cc174 (patch)
treee3fe53c01c78159baea971a1b96492b38f860ef2 /net-fs/shfs
parentRemoving compnerd as a maintainer since he was retired. (diff)
downloadgentoo-2-484af108b0b70ad64f5c40f12705117c1f8cc174.tar.gz
gentoo-2-484af108b0b70ad64f5c40f12705117c1f8cc174.tar.bz2
gentoo-2-484af108b0b70ad64f5c40f12705117c1f8cc174.zip
Removing compnerd as a maintainer since he was retired. Fixed some QA warnings.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/shfs')
-rw-r--r--net-fs/shfs/ChangeLog9
-rw-r--r--net-fs/shfs/metadata.xml6
-rw-r--r--net-fs/shfs/shfs-0.35-r3.ebuild26
-rw-r--r--net-fs/shfs/shfs-0.35-r4.ebuild26
4 files changed, 34 insertions, 33 deletions
diff --git a/net-fs/shfs/ChangeLog b/net-fs/shfs/ChangeLog
index 5582596038bd..f1bfb7fd20f0 100644
--- a/net-fs/shfs/ChangeLog
+++ b/net-fs/shfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/shfs
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.43 2008/08/16 03:53:58 cardoe Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.44 2009/03/20 04:07:52 jmbsvicetto Exp $
+
+ 20 Mar 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ metadata.xml, shfs-0.35-r3.ebuild, shfs-0.35-r4.ebuild:
+ Removing compnerd as a maintainer since he was retired. Fixed some QA
+ warnings.
16 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/net-fs/shfs/metadata.xml b/net-fs/shfs/metadata.xml
index 51b03a2d4429..5bf5d9b2389e 100644
--- a/net-fs/shfs/metadata.xml
+++ b/net-fs/shfs/metadata.xml
@@ -3,11 +3,7 @@
<pkgmetadata>
<herd>net-fs</herd>
<longdescription>Secure Shell File System</longdescription>
-<maintainer>
- <email>compnerd@gentoo.org</email>
- <name>Saleem Abdulrasool</name>
-</maintainer>
<use>
- <flag name='amd'>Enable automounter support</flag>
+ <flag name="amd">Enable automounter support</flag>
</use>
</pkgmetadata>
diff --git a/net-fs/shfs/shfs-0.35-r3.ebuild b/net-fs/shfs/shfs-0.35-r3.ebuild
index 5fb767c754d3..184f7aaa4442 100644
--- a/net-fs/shfs/shfs-0.35-r3.ebuild
+++ b/net-fs/shfs/shfs-0.35-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/shfs-0.35-r3.ebuild,v 1.10 2007/05/08 22:30:25 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/shfs-0.35-r3.ebuild,v 1.11 2009/03/20 04:07:52 jmbsvicetto Exp $
inherit linux-mod eutils
@@ -44,26 +44,26 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/0.35/*.patch
+ epatch "${FILESDIR}/0.35/*.patch"
# Take care of 2.6 Kernels <= 2.6.6
if [[ "${KV_MAJOR}.${KV_MINOR}" == "2.6" ]] ; then
- convert_to_m ${S}/shfs/Linux-2.6/Makefile
+ convert_to_m "${S}/shfs/Linux-2.6/Makefile"
fi
# 2.6.16 has a modified dentry struct. Patch by Miroslav Spousta
# <qiq@ucw.cz>. Submitted by Torsten Krah (bug #127092).
if kernel_is ge 2 6 16 ; then
- epatch ${FILESDIR}/${PN}-0.35-2.6.16-dentry.patch
+ epatch "${FILESDIR}/${PN}-0.35-2.6.16-dentry.patch"
fi
}
src_compile() {
linux-mod_src_compile
- cd ${S}/shfsmount
+ cd "${S}/shfsmount"
emake || die "failed to build userland utilities"
}
@@ -72,17 +72,17 @@ src_install() {
linux-mod_src_install
# Install userland utilities
- cd ${S}/shfsmount
+ cd "${S}/shfsmount"
dobin shfsmount
dobin shfsumount
if use amd ; then
insinto /etc/amd
- doins ${FILESDIR}/amd.conf
- doins ${FILESDIR}/amd.shfs
+ doins "${FILESDIR}/amd.conf"
+ doins "${FILESDIR}/amd.shfs"
exeinto /etc/amd
- doexe ${FILESDIR}/shfs.mount
+ doexe "${FILESDIR}/shfs.mount"
dosym /etc/amd/shfs.mount /etc/amd/shfs.unmount
fi
@@ -97,8 +97,8 @@ src_install() {
dosym /usr/bin/shfsmount /sbin/mount.shfs
# Install docs
- doman ${S}/docs/manpages/shfsmount.8 ${S}/docs/manpages/shfsumount.8
- use doc && dohtml -r ${S}/docs/html
+ doman "${S}/docs/manpages/shfsmount.8" "${S}/docs/manpages/shfsumount.8"
+ use doc && dohtml -r "${S}/docs/html"
}
pkg_postinst() {
diff --git a/net-fs/shfs/shfs-0.35-r4.ebuild b/net-fs/shfs/shfs-0.35-r4.ebuild
index 011476cac2db..ac33200ad269 100644
--- a/net-fs/shfs/shfs-0.35-r4.ebuild
+++ b/net-fs/shfs/shfs-0.35-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/shfs-0.35-r4.ebuild,v 1.3 2007/05/08 22:30:25 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/shfs-0.35-r4.ebuild,v 1.4 2009/03/20 04:07:52 jmbsvicetto Exp $
inherit linux-mod eutils
@@ -38,26 +38,26 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/0.35/*.patch
+ epatch "${FILESDIR}/0.35/*.patch"
# Take care of 2.6 Kernels <= 2.6.6
if [[ "${KV_MAJOR}.${KV_MINOR}" == "2.6" ]] ; then
- convert_to_m ${S}/shfs/Linux-2.6/Makefile
+ convert_to_m "${S}/shfs/Linux-2.6/Makefile"
fi
# 2.6.16 has a modified dentry struct. Patch by Miroslav Spousta
# <qiq@ucw.cz>. Submitted by Torsten Krah (bug #127092).
if kernel_is ge 2 6 16 ; then
- epatch ${FILESDIR}/${PN}-0.35-2.6.16-dentry.patch
+ epatch "${FILESDIR}/${PN}-0.35-2.6.16-dentry.patch"
fi
}
src_compile() {
linux-mod_src_compile
- cd ${S}/shfsmount
+ cd "${S}/shfsmount"
emake || die "failed to build userland utilities"
}
@@ -66,17 +66,17 @@ src_install() {
linux-mod_src_install
# Install userland utilities
- cd ${S}/shfsmount
+ cd "${S}/shfsmount"
dobin shfsmount
dobin shfsumount
if use amd ; then
insinto /etc/amd
- doins ${FILESDIR}/amd.conf
- doins ${FILESDIR}/amd.shfs
+ doins "${FILESDIR}/amd.conf"
+ doins "${FILESDIR}/amd.shfs"
exeinto /etc/amd
- doexe ${FILESDIR}/shfs.mount
+ doexe "${FILESDIR}/shfs.mount"
dosym /etc/amd/shfs.mount /etc/amd/shfs.unmount
fi
@@ -91,8 +91,8 @@ src_install() {
dosym /usr/bin/shfsmount /sbin/mount.shfs
# Install docs
- doman ${S}/docs/manpages/shfsmount.8 ${S}/docs/manpages/shfsumount.8
- use doc && dohtml -r ${S}/docs/html
+ doman "${S}/docs/manpages/shfsmount.8" "${S}/docs/manpages/shfsumount.8"
+ use doc && dohtml -r "${S}/docs/html"
}
pkg_postinst() {