summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2011-09-02 17:11:23 +0000
committerSteve Dibb <beandog@gentoo.org>2011-09-02 17:11:23 +0000
commit01574aa2050b821240014b3505bbdf119ca68181 (patch)
treed0bab8c148bb34197de81a7f5901971761d8774a /net-fs
parentStable for HPPA (bug #380475). (diff)
downloadgentoo-2-01574aa2050b821240014b3505bbdf119ca68181.tar.gz
gentoo-2-01574aa2050b821240014b3505bbdf119ca68181.tar.bz2
gentoo-2-01574aa2050b821240014b3505bbdf119ca68181.zip
Version bump, bug 353177; Rename init script from atalk to netatalk; Restrict test; Add avahi use flag; Add GPL-2 as license
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/netatalk/ChangeLog9
-rw-r--r--net-fs/netatalk/files/netatalk-2.2.0-path_afp_ipc.patch15
-rw-r--r--net-fs/netatalk/netatalk-2.2.0.ebuild94
3 files changed, 117 insertions, 1 deletions
diff --git a/net-fs/netatalk/ChangeLog b/net-fs/netatalk/ChangeLog
index cb40ceb4843a..ca269394cbfa 100644
--- a/net-fs/netatalk/ChangeLog
+++ b/net-fs/netatalk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/netatalk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.67 2011/01/04 20:26:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.68 2011/09/02 17:11:23 beandog Exp $
+
+*netatalk-2.2.0 (02 Sep 2011)
+
+ 02 Sep 2011; Steve Dibb <beandog@gentoo.org> +netatalk-2.2.0.ebuild,
+ +files/netatalk-2.2.0-path_afp_ipc.patch:
+ Version bump, bug 353177; Rename init script from atalk to netatalk; Restrict
+ test; Add avahi use flag; Add GPL-2 as license
*netatalk-2.1.5 (04 Jan 2011)
diff --git a/net-fs/netatalk/files/netatalk-2.2.0-path_afp_ipc.patch b/net-fs/netatalk/files/netatalk-2.2.0-path_afp_ipc.patch
new file mode 100644
index 000000000000..9b1a340edd52
--- /dev/null
+++ b/net-fs/netatalk/files/netatalk-2.2.0-path_afp_ipc.patch
@@ -0,0 +1,15 @@
+--- include/atalk/paths.h 2011-07-27 07:55:39.000000000 -0400
++++ include/atalk/paths.h 2011-08-13 20:19:13.000000000 -0400
+@@ -71,11 +71,11 @@
+ * afpd paths
+ */
+ #define _PATH_AFPTKT "/tmp/AFPtktXXXXXX"
++#define _PATH_AFP_IPC ATALKPATHCAT(_PATH_LOCKDIR,"afpd_ipc")
+ #if defined (FHS_COMPATIBILITY) || defined (__NetBSD__)
+ # define _PATH_AFPDLOCK ATALKPATHCAT(_PATH_LOCKDIR,"afpd.pid")
+ #else
+ # define _PATH_AFPDLOCK ATALKPATHCAT(_PATH_LOCKDIR,"afpd")
+-#define _PATH_AFP_IPC ATALKPATHCAT(_PATH_LOCKDIR,"afpd_ipc")
+ #endif
+
+ /* \ No newline at end of file
diff --git a/net-fs/netatalk/netatalk-2.2.0.ebuild b/net-fs/netatalk/netatalk-2.2.0.ebuild
new file mode 100644
index 000000000000..6d88e086fb11
--- /dev/null
+++ b/net-fs/netatalk/netatalk-2.2.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.2.0.ebuild,v 1.1 2011/09/02 17:11:23 beandog Exp $
+
+EAPI="2"
+
+inherit pam
+
+RESTRICT="test"
+DESCRIPTION="Kernel level implementation of the AppleTalk Protocol Suite"
+HOMEPAGE="http://netatalk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+avahi cracklib cups debug kerberos pam slp ssl tcpd xfs"
+
+RDEPEND=">=sys-libs/db-4.2.52
+ avahi? ( net-dns/avahi[dbus] )
+ cracklib? ( sys-libs/cracklib )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ slp? ( net-libs/openslp )
+ cups? ( net-print/cups )
+ kerberos? ( virtual/krb5 )
+ >=sys-apps/coreutils-7.1
+ !app-text/yudit
+ dev-libs/libgcrypt"
+DEPEND="${RDEPEND}
+ xfs? ( sys-fs/xfsprogs )"
+
+src_prepare() {
+ # until someone that understands their config script build
+ # system gets a patch pushed upstream to make
+ # --enable-srvloc passed to configure also add slpd to the
+ # use line on the initscript, we'll need to do it this way
+ if use slp ; then
+ sed -i -e '/^[[:space:]]*use\>/s:$: slpd:' \
+ distrib/initscripts/rc.atalk.gentoo.tmpl || die
+ fi
+ epatch "${FILESDIR}/${P}-path_afp_ipc.patch" || die "epatch failed"
+}
+
+src_configure() {
+ use xfs || eval $(printf 'export ac_cv_header_%s=no\n' {linux,xfs}_{dqblk_xfs,libxfs,xqm,xfs_fs}_h)
+
+ # Ignore --enable-gentoo, we install the init.d by hand and we avoid having
+ # to sed the Makefiles to not do rc-update.
+ # --enable-shadow: let build system detect shadow.h in toolchain
+ econf \
+ $(use_with pam) \
+ $(use_enable avahi zeroconf) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable tcpd tcp-wrappers) \
+ $(use_enable kerberos krbV-uam) \
+ --disable-krb4-uam \
+ $(use_enable slp srvloc) \
+ $(use_with ssl ssl-dir) \
+ $(use_with cracklib) \
+ --disable-afs \
+ --enable-fhs \
+ --with-bdb=/usr
+}
+
+src_compile() {
+ emake || die
+
+ # Create the init script manually (it's more messy to --enable-gentoo)
+ emake -C distrib/initscripts rc.atalk.gentoo || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CONTRIBUTORS NEWS VERSION AUTHORS doc/README.AppleTalk
+
+ newinitd distrib/initscripts/rc.atalk.gentoo netatalk || die
+
+ # The pamd file isn't what we need, use pamd_mimic_system
+ rm -rf "${D}/etc/pam.d"
+ pamd_mimic_system netatalk auth account password session
+
+ # Move /usr/include/netatalk to /usr/include/netatalk2 to avoid collisions
+ # with /usr/include/netatalk/at.h provided by glibc (strange, uh?)
+ # Packages that wants to link to netatalk should then probably change the
+ # includepath then, but right now, nothing uses netatalk.
+ # On a side note, it also solves collisions with freebsd-lib and other libcs
+ mv "${D}"/usr/include/netatalk{,2} || die
+ sed -i \
+ -e 's/include <netatalk/include <netatalk2/g' \
+ "${D}"usr/include/{netatalk2,atalk}/* || die
+}