summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-03 19:14:13 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-03 19:14:13 +0000
commit41295f1d4156b30afc64ccef18185f7624bb08cc (patch)
treee7650c5a854180b7a58cb6a6b8f0f79e2204efa1 /net-fs
parentremoving the non-existant python 2.5 support (diff)
downloadgentoo-2-41295f1d4156b30afc64ccef18185f7624bb08cc.tar.gz
gentoo-2-41295f1d4156b30afc64ccef18185f7624bb08cc.tar.bz2
gentoo-2-41295f1d4156b30afc64ccef18185f7624bb08cc.zip
net-fs/autofs: add latest upstream patches, needed for correct connection with LDAP based automounts, #463770
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog9
-rw-r--r--net-fs/autofs/autofs-5.0.7-r1.ebuild121
-rw-r--r--net-fs/autofs/metadata.xml24
3 files changed, 141 insertions, 13 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 92f07f8572c1..da6468fcd4f9 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.147 2013/03/25 19:27:27 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.148 2013/05/03 19:14:13 jlec Exp $
+
+*autofs-5.0.7-r1 (03 May 2013)
+
+ 03 May 2013; Justin Lecher <jlec@gentoo.org> +autofs-5.0.7-r1.ebuild,
+ metadata.xml:
+ add latest upstream patches, needed for correct connection with LDAP based
+ automounts, #463770
*autofs-5.0.7 (25 Mar 2013)
diff --git a/net-fs/autofs/autofs-5.0.7-r1.ebuild b/net-fs/autofs/autofs-5.0.7-r1.ebuild
new file mode 100644
index 000000000000..1762d244e227
--- /dev/null
+++ b/net-fs/autofs/autofs-5.0.7-r1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.7-r1.ebuild,v 1.1 2013/05/03 19:14:13 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils linux-info multilib
+
+PATCH_VER=2
+[[ -n ${PATCH_VER} ]] && \
+ PATCHSET_URI="http://dev.gentoo.org/~jlec/distfiles/${P}-patches-${PATCH_VER}.tar.lzma"
+
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+SRC_URI="
+ mirror://kernel/linux/daemons/${PN}/v5/${P}.tar.bz2
+ ${PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="hesiod ldap mount-locking sasl"
+
+# USE="sasl" adds SASL support to the LDAP module which will not be build. If
+# SASL support should be available, please add "ldap" to the USE flags.
+REQUIRED_USE="sasl? ( ldap )"
+
+# currently, sasl code assumes the presence of kerberosV
+RDEPEND="
+ hesiod? ( net-dns/hesiod )
+ ldap? ( >=net-nds/openldap-2.0
+ sasl? (
+ dev-libs/cyrus-sasl
+ dev-libs/libxml2
+ virtual/krb5 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+PATCHES=(
+ # Fix for bug #210762
+ # Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/4203
+ "${FILESDIR}"/${PN}-5.0.3-heimdal.patch
+
+ # Accumulated fixes for bugs
+ # #154797: Respect CC and CFLAGS
+ # #253412: Respect LDFLAGS
+ # #247969: Link order for --as-needed
+ "${FILESDIR}"/${PN}-5.0.6-respect-user-flags-and-fix-asneeded-r2.patch
+
+ # Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/5371
+ "${FILESDIR}"/${PN}-5.0.5-fix-install-deadlink.patch
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=361899
+ "${FILESDIR}"/${PN}-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=381315
+ "${FILESDIR}"/${PN}-5.0.6-revert-ldap.patch
+ )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # Upstream's patchset
+ if [[ -n ${PATCH_VER} ]]; then
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/patches
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # work around bug #355975 (mount modifies timestamp of /etc/mtab)
+ # with >=sys-apps/util-linux-2.19,
+ addpredict "/etc/mtab"
+
+ # --with-confdir is for bug #361481
+ # --with-mapdir is for bug #385113
+ # for systemd support (not enabled yet):
+ # --with-systemd
+ # --disable-move-mount: requires kernel >=2.6.39
+ local myeconfargs=(
+ --with-confdir=/etc/conf.d
+ --with-mapdir=/etc/autofs
+ $(use_with ldap openldap)
+ $(use_with sasl)
+ $(use_with hesiod)
+ $(use_enable mount-locking)
+ --enable-ignore-busy
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # kernel patches
+ docinto patches
+ dodoc patches/${PN}4-2.6.??{,.?{,?}}-v5-update-????????.patch
+
+ newinitd "${FILESDIR}"/autofs5.initd autofs
+ insinto etc/autofs
+ newins "${FILESDIR}"/autofs5-auto.master auto.master
+}
+
+pkg_postinst() {
+ if kernel_is -lt 2 6 30; then
+ elog "This version of ${PN} requires a kernel with autofs4 supporting"
+ elog "protocol version 5.00. Patches for kernels older than 2.6.30 have"
+ elog "been installed into"
+ elog "${EROOT}usr/share/doc/${P}/patches."
+ elog "For further instructions how to patch the kernel, please refer to"
+ elog "${EROOT}usr/share/doc/${P}/INSTALL."
+ elog
+ fi
+ elog "If you plan on using autofs for automounting remote NFS mounts,"
+ elog "please check that both portmap (or rpcbind) and rpc.statd/lockd"
+ elog "are running."
+}
diff --git a/net-fs/autofs/metadata.xml b/net-fs/autofs/metadata.xml
index d1c0634ada12..6724134b20d8 100644
--- a/net-fs/autofs/metadata.xml
+++ b/net-fs/autofs/metadata.xml
@@ -1,21 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-fs</herd>
-<herd>proxy-maintainers</herd>
-<maintainer>
- <email>gentoobugsie.20.dsurawicz@spamgourmet.com</email>
- <name>Dustin Polke</name>
-</maintainer>
-<use>
- <flag name="hesiod">Install hesiod module</flag>
- <flag name="ldap">Install LDAP module</flag>
- <flag name="mount-locking">
+ <herd>net-fs</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>gentoobugsie.20.dsurawicz@spamgourmet.com</email>
+ <name>Dustin Polke</name>
+ </maintainer>
+ <use>
+ <flag name="hesiod">Install hesiod module</flag>
+ <flag name="ldap">Install LDAP module</flag>
+ <flag name="mount-locking">
Enable locking to prevent corruption of /etc/mtab in the presence of
concurrent auto-mounting. If enabled, recursive auto-mounting (eg. using
autofs to bind or loop mount a filesystem which is itself auto-mounted)
is not possible.
</flag>
- <flag name="sasl">Enable SASL support in the LDAP module</flag>
-</use>
+ <flag name="sasl">Enable SASL support in the LDAP module</flag>
+ </use>
</pkgmetadata>