summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-01-28 15:15:05 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-01-28 15:15:05 +0000
commit81cd0d9a04aa513f1b25cdda3cd0875f4ec7949a (patch)
tree190e0f85c20064e89900f5fed13d7a1ccaf9ba00 /net-fs
parentdev-java/jdbc-mysql (diff)
downloadgentoo-2-81cd0d9a04aa513f1b25cdda3cd0875f4ec7949a.tar.gz
gentoo-2-81cd0d9a04aa513f1b25cdda3cd0875f4ec7949a.tar.bz2
gentoo-2-81cd0d9a04aa513f1b25cdda3cd0875f4ec7949a.zip
Initial import, ebuild based on work from Ewoud Kohl van Wijngaarden <gentoo@kohlvanwijngaarden.nl> and Sebastiaan <s.breedveld@erasmusmc.nl> bug 308655
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/cifs-utils/ChangeLog12
-rw-r--r--net-fs/cifs-utils/cifs-utils-4.8.1.ebuild83
-rw-r--r--net-fs/cifs-utils/metadata.xml17
3 files changed, 112 insertions, 0 deletions
diff --git a/net-fs/cifs-utils/ChangeLog b/net-fs/cifs-utils/ChangeLog
new file mode 100644
index 000000000000..536e697812ba
--- /dev/null
+++ b/net-fs/cifs-utils/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-fs/cifs-utils
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.1 2011/01/28 15:15:05 vostorga Exp $
+
+*cifs-utils-4.8.1 (28 Jan 2011)
+
+ 28 Jan 2011; Víctor Ostorga <vostorga@gentoo.org>
+ +cifs-utils-4.8.1.ebuild, +metadata.xml:
+ Initial import, ebuild based on work from Ewoud Kohl van Wijngaarden
+ <gentoo@kohlvanwijngaarden.nl> and Sebastiaan <s.breedveld@erasmusmc.nl>
+ bug 308655
+
diff --git a/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild b/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild
new file mode 100644
index 000000000000..71ab8388b66f
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild,v 1.1 2011/01/28 15:15:05 vostorga Exp $
+
+EAPI=2
+
+inherit eutils confutils linux-mod
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="http://www.samba.org/linux-cifs/cifs-utils/"
+SRC_URI="ftp://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ads +caps caps-ng creds setuid"
+
+DEPEND="!net-fs/mount-cifs
+ !<net-fs/samba-3.6
+ ads? ( sys-libs/talloc virtual/krb5 sys-apps/keyutils )
+ caps? ( sys-libs/libcap )
+ caps-ng? ( sys-libs/libcap-ng )"
+RDEPEND="${DEPEND}"
+
+cifs_check() {
+ ebegin "Checking for CIFS support"
+ linux_chkconfig_present CIFS
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ eerror "Please enable CIFS support in your kernel config, found at:"
+ eerror
+ eerror " File systems"
+ eerror " Network File Systems"
+ eerror " CIFS support"
+ eerror
+ eerror "and recompile your kernel ..."
+ die "CIFS support not detected!"
+ fi
+}
+
+pkg_setup() {
+ confutils_use_conflict caps caps-ng
+
+ if use kernel_linux; then
+ linux-mod_pkg_setup
+ cifs_check
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable ads cifsupcall) \
+ $(use_with caps libcap) \
+ $(use_enable creds cifscreds)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ # Set set-user-ID bit of mount.cifs
+ if use setuid ; then
+ chmod u+s "${D}"/sbin/mount.cifs
+ fi
+ dodoc doc/linux-cifs-client-guide.odt
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ if use setuid ; then
+ ewarn "Setting SETUID bit for mount.cifs."
+ ewarn "However, there may be severe security implications. Also see:"
+ ewarn "http://samba.org/samba/security/CVE-2009-2948.html"
+ fi
+
+ # Inform about upcall usage
+ if use ads ; then
+ ewarn "Using mount.cifs in combination with keyutils"
+ ewarn "in order to mount DFS shares, you need to add"
+ ewarn "the following line to /etc/request-key.conf:"
+ ewarn " create dns_resolver * * /usr/sbin/cifs.upcall %k"
+ ewarn "Otherwise, your DFS shares will not work properly."
+ fi
+}
diff --git a/net-fs/cifs-utils/metadata.xml b/net-fs/cifs-utils/metadata.xml
new file mode 100644
index 000000000000..f5b753cac313
--- /dev/null
+++ b/net-fs/cifs-utils/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>samba</herd>
+ <maintainer>
+ <email>samba@gentoo.org</email>
+ <name>Samba Team</name>
+ </maintainer>
+ <longdescription>The in-kernel CIFS filesystem relies on a set of user-space tools. That package of tools is called cifs-utils. Although not really part of Samba proper, these tools were originally part of the Samba package. For several reasons, shipping these tools as part of Samba was problematic and it was deemed better to split them off into their own package</longdescription>
+ <use>
+ <flag name="ads">Enable Active Directory support</flag>
+ <flag name="caps">libcap support</flag>
+ <flag name="caps-ng">libcap-ng support</flag>
+ <flag name="creds">cifs credentials support</flag>
+ <flag name="setuid">Seting SETUID bit for mount.cifs</flag>
+ </use>
+</pkgmetadata>