summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-05 16:22:49 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-05 16:22:49 +0000
commitaf0b8069c7d0bb7d4d8b6b5df0d4d329ec0897d4 (patch)
tree627f0279db94bc73a45792565f3e6a6a7dcc7f84 /net-fs
parentAdd readline dep. (diff)
downloadgentoo-2-af0b8069c7d0bb7d4d8b6b5df0d4d329ec0897d4.tar.gz
gentoo-2-af0b8069c7d0bb7d4d8b6b5df0d4d329ec0897d4.tar.bz2
gentoo-2-af0b8069c7d0bb7d4d8b6b5df0d4d329ec0897d4.zip
net-fs/netatalk: Version Bump, handle configure options correctly
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/netatalk/ChangeLog9
-rw-r--r--net-fs/netatalk/metadata.xml3
-rw-r--r--net-fs/netatalk/netatalk-3.0.2-r3.ebuild149
-rw-r--r--net-fs/netatalk/netatalk-3.0.3.ebuild167
4 files changed, 327 insertions, 1 deletions
diff --git a/net-fs/netatalk/ChangeLog b/net-fs/netatalk/ChangeLog
index 7608da47887d..9cf463743907 100644
--- a/net-fs/netatalk/ChangeLog
+++ b/net-fs/netatalk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/netatalk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.93 2013/02/05 07:45:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.94 2013/04/05 16:22:49 jlec Exp $
+
+*netatalk-3.0.3 (05 Apr 2013)
+*netatalk-3.0.2-r3 (05 Apr 2013)
+
+ 05 Apr 2013; Justin Lecher <jlec@gentoo.org> +netatalk-3.0.2-r3.ebuild,
+ +netatalk-3.0.3.ebuild, metadata.xml:
+ Version Bump, handle configure options correctly
*netatalk-3.0.2-r2 (05 Feb 2013)
diff --git a/net-fs/netatalk/metadata.xml b/net-fs/netatalk/metadata.xml
index 3d3fd3cc9ba9..ac8debc4ec50 100644
--- a/net-fs/netatalk/metadata.xml
+++ b/net-fs/netatalk/metadata.xml
@@ -27,6 +27,9 @@
<flag name="shadow">
Add shadow support
</flag>
+ <flag name="utils">
+ Install afpstats script
+ </flag>
<flag name="ssl">
Use <pkg>dev-libs/openssl</pkg> to provide DHX User Access
Modules. These are not used with most recent versions of OS X
diff --git a/net-fs/netatalk/netatalk-3.0.2-r3.ebuild b/net-fs/netatalk/netatalk-3.0.2-r3.ebuild
new file mode 100644
index 000000000000..da9e7281dc81
--- /dev/null
+++ b/net-fs/netatalk/netatalk-3.0.2-r3.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-3.0.2-r3.ebuild,v 1.1 2013/04/05 16:22:49 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils flag-o-matic multilib pam systemd
+
+DESCRIPTION="Open Source AFP server"
+HOMEPAGE="http://netatalk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="acl avahi cracklib debug pgp kerberos ldap pam quota samba +shadow ssl static-libs tcpd"
+
+RDEPEND="
+ !app-editors/yudit
+ dev-libs/libevent
+ dev-libs/libgcrypt
+ sys-apps/coreutils
+ >=sys-libs/db-4.2.52
+ acl? (
+ sys-apps/attr
+ sys-apps/acl
+ )
+ avahi? ( net-dns/avahi[dbus] )
+ cracklib? ( sys-libs/cracklib )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ "
+DEPEND="${RDEPEND}"
+PDEPEND="sys-apps/openrc"
+
+RESTRICT="test"
+
+REQUIRED_USE="ldap? ( acl )"
+
+DOCS=( CONTRIBUTORS NEWS VERSION AUTHORS doc/DEVELOPER )
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.1-gentoo.patch )
+
+src_configure() {
+ local myeconfargs=()
+
+ append-flags -fno-strict-aliasing
+
+ if use acl; then
+ myeconfargs+=( --with-acls $(use_with ldap) )
+ else
+ myeconfargs+=( --without-acls --without-ldap )
+ fi
+
+ # Ignore --with-init-style=gentoo, we install the init.d by hand and we avoid having
+ # to sed the Makefiles to not do rc-update.
+ # TODO:
+ # systemd : --with-init-style=systemd
+ myeconfargs+=(
+ --disable-silent-rules
+ $(use_enable avahi zeroconf)
+ $(use_enable debug)
+ $(use_enable debug debugging)
+ $(use_enable pgp pgp-uam)
+ $(use_enable kerberos)
+ $(use_enable kerberos krbV-uam)
+ $(use_enable quota)
+ $(use_enable tcpd tcp-wrappers)
+ $(use_with cracklib)
+ $(use_with pam)
+ $(use_with samba smbsharemodes)
+ $(use_with shadow)
+ $(use_with ssl ssl-dir)
+ --enable-overwrite
+ --disable-krb4-uam
+ --disable-afs
+ --with-libevent-header=/usr/include
+ --with-libevent-lib=/usr/$(get_libdir)
+ --with-bdb=/usr
+ --with-uams-path=/usr/$(get_libdir)/${PN}
+ --disable-silent-rules
+ --with-init-style=gentoo
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use avahi; then
+ sed -i -e '/avahi-daemon/s:use:need:g' "${D}"/etc/init.d/${PN} || die
+ else
+ sed -i -e '/avahi-daemon/d' "${D}"/etc/init.d/${PN} || die
+ fi
+
+ # The pamd file isn't what we need, use pamd_mimic_system
+ rm -rf "${D}/etc/pam.d"
+ pamd_mimic_system netatalk auth account password session
+
+ sed \
+ -e "s|:SBINDIR:|${EPREFIX}/usr/sbin|g" \
+ distrib/initscripts/service.systemd.tmpl \
+ > "${T}"/service.systemd || die
+ systemd_newunit "${T}"/service.systemd ${PN}.service
+}
+
+pkg_postinst() {
+ local fle
+ if [[ ${REPLACING_VERSIONS} < 3 ]]; then
+ for fle in afp_signature.conf afp_voluuid.conf; do
+ if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
+ if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
+ mv \
+ "${ROOT}"etc/netatalk/${fle} \
+ "${ROOT}"var/lib/netatalk/
+ fi
+ fi
+ done
+
+ echo ""
+ elog "Starting from version 3.0 only uses a single init script again"
+ elog "Please update your runlevels accordingly"
+ echo ""
+ elog "Dependencies should be resolved automatically depending on settings"
+ elog "but please report issues with this on https://bugs.gentoo.org/ if"
+ elog "you find any."
+ echo ""
+ elog "Following config files are obsolete now:"
+ elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
+ elog "in favour of"
+ elog "/etc/afp.conf"
+ echo ""
+ elog "Please convert your existing configs before you restart your daemon"
+ echo ""
+ elog "The new AppleDouble default backend is appledouble = ea"
+ elog "Existing entries will be updated on access, but can do an offline"
+ elog "conversion with"
+ elog "dbd -ruve /path/to/Volume"
+ echo ""
+ elog "For general notes on the upgrade, please visit"
+ elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
+ echo ""
+ fi
+}
diff --git a/net-fs/netatalk/netatalk-3.0.3.ebuild b/net-fs/netatalk/netatalk-3.0.3.ebuild
new file mode 100644
index 000000000000..37113bff9cba
--- /dev/null
+++ b/net-fs/netatalk/netatalk-3.0.3.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-3.0.3.ebuild,v 1.1 2013/04/05 16:22:49 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils flag-o-matic multilib pam python-r1 systemd
+
+DESCRIPTION="Open Source AFP server"
+HOMEPAGE="http://netatalk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="acl avahi cracklib debug pgp kerberos ldap pam quota samba +shadow ssl static-libs tcpd +utils"
+
+DEPEND="
+ !app-editors/yudit
+ dev-libs/libevent
+ dev-libs/libgcrypt
+ sys-apps/coreutils
+ >=sys-libs/db-4.2.52
+ acl? (
+ sys-apps/attr
+ sys-apps/acl
+ )
+ avahi? ( net-dns/avahi[dbus] )
+ cracklib? ( sys-libs/cracklib )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ "
+RDEPEND="${DEPEND}
+ utils? (
+ dev-lang/perl
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )"
+PDEPEND="sys-apps/openrc"
+
+RESTRICT="test"
+
+REQUIRED_USE="ldap? ( acl )"
+
+DOCS=( CONTRIBUTORS NEWS VERSION AUTHORS doc/DEVELOPER )
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.1-gentoo.patch )
+
+src_prepare() {
+ if ! use utils; then
+ sed \
+ -e "s:shell_utils::g" \
+ -i contrib/Makefile.am || die
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=()
+
+ append-flags -fno-strict-aliasing
+
+ if use acl; then
+ myeconfargs+=( --with-acls $(use_with ldap) )
+ else
+ myeconfargs+=( --without-acls --without-ldap )
+ fi
+
+ # Ignore --with-init-style=gentoo, we install the init.d by hand and we avoid having
+ # to sed the Makefiles to not do rc-update.
+ # TODO:
+ # systemd : --with-init-style=systemd
+ myeconfargs+=(
+ --disable-silent-rules
+ $(use_enable avahi zeroconf)
+ $(use_enable debug)
+ $(use_enable debug debugging)
+ $(use_enable pgp pgp-uam)
+ $(use_enable kerberos)
+ $(use_enable kerberos krbV-uam)
+ $(use_enable quota)
+ $(use_enable tcpd tcp-wrappers)
+ $(use_with cracklib)
+ $(use_with pam)
+ $(use_with samba smbsharemodes)
+ $(use_with shadow)
+ $(use_with ssl ssl-dir)
+ --enable-overwrite
+ --disable-krb4-uam
+ --disable-afs
+ --with-libevent-header=/usr/include
+ --with-libevent-lib=/usr/$(get_libdir)
+ --with-bdb=/usr
+ --with-uams-path=/usr/$(get_libdir)/${PN}
+ --disable-silent-rules
+ --with-init-style=gentoo
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use avahi; then
+ sed -i -e '/avahi-daemon/s:use:need:g' "${D}"/etc/init.d/${PN} || die
+ else
+ sed -i -e '/avahi-daemon/d' "${D}"/etc/init.d/${PN} || die
+ fi
+
+ # The pamd file isn't what we need, use pamd_mimic_system
+ rm -rf "${D}/etc/pam.d"
+ pamd_mimic_system netatalk auth account password session
+
+ sed \
+ -e "s|:SBINDIR:|${EPREFIX}/usr/sbin|g" \
+ distrib/initscripts/service.systemd.tmpl \
+ > "${T}"/service.systemd || die
+ systemd_newunit "${T}"/service.systemd ${PN}.service
+
+ use utils && python_foreach_impl python_doscript contrib/shell_utils/afpstats
+}
+
+pkg_postinst() {
+ local fle
+ if [[ ${REPLACING_VERSIONS} < 3 ]]; then
+ for fle in afp_signature.conf afp_voluuid.conf; do
+ if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
+ if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
+ mv \
+ "${ROOT}"etc/netatalk/${fle} \
+ "${ROOT}"var/lib/netatalk/
+ fi
+ fi
+ done
+
+ echo ""
+ elog "Starting from version 3.0 only uses a single init script again"
+ elog "Please update your runlevels accordingly"
+ echo ""
+ elog "Dependencies should be resolved automatically depending on settings"
+ elog "but please report issues with this on https://bugs.gentoo.org/ if"
+ elog "you find any."
+ echo ""
+ elog "Following config files are obsolete now:"
+ elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
+ elog "in favour of"
+ elog "/etc/afp.conf"
+ echo ""
+ elog "Please convert your existing configs before you restart your daemon"
+ echo ""
+ elog "The new AppleDouble default backend is appledouble = ea"
+ elog "Existing entries will be updated on access, but can do an offline"
+ elog "conversion with"
+ elog "dbd -ruve /path/to/Volume"
+ echo ""
+ elog "For general notes on the upgrade, please visit"
+ elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
+ echo ""
+ fi
+}