summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-06-09 08:27:00 +0000
committerPeter Volkov <pva@gentoo.org>2010-06-09 08:27:00 +0000
commitc47c0970a52ec67eb444ad53f07305407b54234d (patch)
treec8d7d6c0d1addbc51faf9cb285d707de94bd3f63 /net-fs
parentMoved from sci overlay to tree (diff)
downloadgentoo-2-c47c0970a52ec67eb444ad53f07305407b54234d.tar.gz
gentoo-2-c47c0970a52ec67eb444ad53f07305407b54234d.tar.bz2
gentoo-2-c47c0970a52ec67eb444ad53f07305407b54234d.zip
Version bump, bug #296357, thank Dustin Polke for this work.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog10
-rw-r--r--net-fs/autofs/autofs-5.0.5.ebuild98
-rw-r--r--net-fs/autofs/files/autofs-5.0.5-fix-building-without-sasl.patch16
-rw-r--r--net-fs/autofs/files/autofs-5.0.5-respect-user-flags-and-fix-asneeded.patch144
-rw-r--r--net-fs/autofs/metadata.xml5
5 files changed, 272 insertions, 1 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 3526193e5077..401202810efb 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.92 2010/06/01 09:19:58 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.93 2010/06/09 08:27:00 pva Exp $
+
+*autofs-5.0.5 (09 Jun 2010)
+
+ 09 Jun 2010; Peter Volkov <pva@gentoo.org> +autofs-5.0.5.ebuild,
+ +files/autofs-5.0.5-fix-building-without-sasl.patch,
+ +files/autofs-5.0.5-respect-user-flags-and-fix-asneeded.patch,
+ metadata.xml:
+ Version bump, bug #296357, thank Dustin Polke for this work.
01 Jun 2010; Peter Volkov <pva@gentoo.org> autofs-5.0.4-r5.ebuild:
Wrong patch was applied and that cause build issue, bug #292147#c15, thank
diff --git a/net-fs/autofs/autofs-5.0.5.ebuild b/net-fs/autofs/autofs-5.0.5.ebuild
new file mode 100644
index 000000000000..c1a4e4beb4a9
--- /dev/null
+++ b/net-fs/autofs/autofs-5.0.5.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.5.ebuild,v 1.1 2010/06/09 08:27:00 pva Exp $
+
+EAPI="2"
+
+inherit eutils multilib autotools
+
+PATCH_VER="1"
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+SRC_URI="mirror://kernel/linux/daemons/${PN}/v5/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="hesiod ldap sasl"
+
+# currently, sasl code assumes the presence of kerberosV
+DEPEND="hesiod? ( net-dns/hesiod )
+ ldap? (
+ >=net-nds/openldap-2.0
+ sasl? (
+ dev-libs/cyrus-sasl
+ dev-libs/libxml2
+ virtual/krb5
+ )
+ )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/patches
+
+ # fixes bug #210762
+ epatch "${FILESDIR}"/${PN}-5.0.3-heimdal.patch
+
+ # Accumulated fixes for bugs
+ # #154797: Respect CC and CFLAGS
+ # #253412: Respect LDFLAGS
+ # #247969: Link order for --as-needed
+ epatch "${FILESDIR}"/${P}-respect-user-flags-and-fix-asneeded.patch
+
+ # do not include <nfs/nfs.h>, rather <linux/nfs.h>,
+ # as the former is a lame header for the latter (bug #157968)
+ sed 's@nfs/nfs.h@linux/nfs.h@' -i include/rpc_subs.h
+
+ epatch "${FILESDIR}"/${P}-fix-building-without-sasl.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+
+ if use sasl && ! use ldap; then
+ ewarn "USE=\"sasl\" adds SASL support to the LDAP module"
+ ewarn "which will not be build. If SASL support should be"
+ ewarn "available, please add \"ldap\" to the USE flags."
+ myconf="--with-openldap=no --with-sasl=no"
+ epause 5
+ else
+ myconf="$(use_with ldap openldap) $(use_with sasl)"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_with hesiod) \
+ --enable-ignore-busy
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+# make DESTDIR="${D}" install_kernel || die "make install failed"
+# make DESTDIR="${D}" install_samples || die "make install failed"
+
+ dodoc README* CHANGELOG CREDITS COPYRIGHT INSTALL || die "dodoc failed"
+
+ # kernel patches
+ docinto patches
+ dodoc patches/${PN}4-2.6.??{,.?{,?}}-v5-update-????????.patch \
+ || die "Installing patches failed"
+
+ newinitd "${FILESDIR}"/autofs5.rc1 autofs || die
+}
+
+pkg_postinst() {
+ elog "Note: You might need to patch your kernel to use this"
+ elog "version of ${PN}. Upstream kernel patches have been"
+ elog "installed into \"/usr/share/doc/${P}/patches\"."
+ elog "For further instructions, please refer to"
+ elog "\"/usr/share/doc/${P}/README\"."
+ elog ""
+ elog "Note: If you plan on using autofs for automounting"
+ elog "remote NFS mounts without having the NFS daemon running"
+ elog "please add portmap or rpcbind to your default run-level."
+}
diff --git a/net-fs/autofs/files/autofs-5.0.5-fix-building-without-sasl.patch b/net-fs/autofs/files/autofs-5.0.5-fix-building-without-sasl.patch
new file mode 100644
index 000000000000..ae93e2e028b0
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.0.5-fix-building-without-sasl.patch
@@ -0,0 +1,16 @@
+--- modules/lookup_ldap.c.old 2010-05-28 13:47:33.888723271 +0200
++++ modules/lookup_ldap.c 2010-05-28 13:58:32.048972838 +0200
+@@ -141,9 +141,13 @@
+ {
+ int rv;
+
++#ifdef WITH_SASL
+ if (ctxt->auth_required == LDAP_AUTH_USESIMPLE)
+ rv = ldap_simple_bind_s(ldap, ctxt->user, ctxt->secret);
+ else if (ctxt->version == 2)
++#else
++ if (ctxt->version == 2)
++#endif
+ rv = ldap_simple_bind_s(ldap, ctxt->base, NULL);
+ else
+ rv = ldap_simple_bind_s(ldap, NULL, NULL);
diff --git a/net-fs/autofs/files/autofs-5.0.5-respect-user-flags-and-fix-asneeded.patch b/net-fs/autofs/files/autofs-5.0.5-respect-user-flags-and-fix-asneeded.patch
new file mode 100644
index 000000000000..029dcc58c166
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.0.5-respect-user-flags-and-fix-asneeded.patch
@@ -0,0 +1,144 @@
+--- configure.in.old 2010-05-29 17:17:06.242996467 +0200
++++ configure.in 2010-05-29 17:19:23.453749422 +0200
+@@ -173,7 +173,7 @@ AC_ARG_WITH(hesiod,
+ : Search for Hesiod in normal directory path
+ else
+ : Search for Hesiod in specific directory
+- LDFLAGS="$LDFLAGS -L${withval}/lib"
++ LDFLAGS="$LDFLAGS -Wl,--no-as-needed -L${withval}/lib"
+ LIBHESIOD="-L${withval}/lib"
+ HESIOD_FLAGS="-I${withval}/include"
+ fi
+--- Makefile.conf.in.old 2010-05-27 16:25:30.136149753 +0200
++++ Makefile.conf.in 2010-05-27 16:27:29.736148646 +0200
+@@ -90,3 +90,5 @@
+ # Location for init.d files
+ initdir = @initdir@
+
++# Use the compiler determined by configure
++CC := @CC@
+--- Makefile.rules.old 2010-05-27 16:25:26.722150726 +0200
++++ Makefile.rules 2010-05-27 16:35:52.030400349 +0200
+@@ -16,8 +16,6 @@
+ AUTOFS_LIB = ../lib/autofs.a
+
+ # Compilers, linkers and flags
+-# The STRIP defined here *must not* remove any dynamic-loading symbols
+-
+ ifdef DMALLOCLIB
+ DEBUG=1
+ endif
+@@ -24,36 +24,24 @@
+
+ ifdef DEBUG
+ CFLAGS ?= -g -Wall -DDEBUG
+-LDFLAGS = -g
+-STRIP = :
+ else
+-ifdef DONTSTRIP
+ CFLAGS ?= -O2 -g
+-LDFLAGS = -g
+-STRIP = :
+-else
+-CFLAGS ?= -O2 -Wall
+-LDFLAGS = -s
+-STRIP = strip --strip-debug
+-endif
+ endif
++AUTOFS_LDFLAGS = -g
+
+-CC = gcc
+-CXX = g++
+ CXXFLAGS = $(CFLAGS)
+ LD = ld
+ SOLDFLAGS = -shared
+
+ CFLAGS += -D_REENTRANT -D_FILE_OFFSET_BITS=64
+-LDFLAGS += -lpthread
+
+ ifdef TIRPCLIB
+ CFLAGS += -I/usr/include/tirpc
+-LDFLAGS += $(TIRPCLIB)
++AUTOFS_LDFLAGS += $(TIRPCLIB)
+ endif
+
+ ifdef DMALLOCLIB
+-LDFLAGS += $(DMALLOCLIB)
++AUTOFS_LDFLAGS += $(DMALLOCLIB)
+ endif
+
+ # Standard rules
+@@ -56,4 +54,3 @@
+
+ .c.so:
+ $(CC) $(SOLDFLAGS) $(CFLAGS) -o $*.so $< $(AUTOFS_LIB) $(DMALLOCLIB) $(LIBNSL)
+- $(STRIP) $*.so
+--- daemon/Makefile.old 2010-05-27 16:37:18.755178257 +0200
++++ daemon/Makefile 2010-05-27 16:39:24.433440867 +0200
+@@ -2,8 +2,8 @@
+ # Makefile for autofs
+ #
+
+--include ../Makefile.conf
+ include ../Makefile.rules
++-include ../Makefile.conf
+
+ SRCS = automount.c indirect.c direct.c spawn.c module.c mount.c \
+ lookup.c state.c flag.c
+@@ -20,7 +20,7 @@
+ CFLAGS += -DAUTOFS_FLAG_DIR=\"$(autofsflagdir)\"
+ CFLAGS += -DVERSION_STRING=\"$(version)\"
+ LDFLAGS += -rdynamic
+-LIBS = -ldl
++LIBS = -ldl -lpthread
+
+ ifeq ($(LDAP), 1)
+ ifeq ($(SASL), 1)
+@@ -30,8 +30,7 @@
+ all: automount
+
+ automount: $(OBJS) $(AUTOFS_LIB)
+- $(CC) $(LDFLAGS) $(DAEMON_LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
+- $(STRIP) automount
++ $(CC) $(AUTOFS_LDFLAGS) $(DAEMON_LDFLAGS) $(LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
+
+ clean:
+ rm -f *.o *.s *~ automount
+--- lib/Makefile.old 2010-05-27 17:42:14.424151727 +0200
++++ lib/Makefile 2010-05-27 17:42:43.629174396 +0200
+@@ -41,14 +41,12 @@
+
+ mount_clnt.o: mount_clnt.c
+ $(CC) $(CFLAGS) -o mount_clnt.o -c mount_clnt.c
+- $(STRIP) mount_clnt.o
+
+ mount_xdr.c: mount.h
+ $(RPCGEN) -c -o mount_xdr.c mount.x
+
+ mount_xdr.o: mount_xdr.c
+ $(CC) $(CFLAGS) -Wno-unused-variable -o mount_xdr.o -c mount_xdr.c
+- $(STRIP) mount_xdr.o
+
+ master_tok.c: master_tok.l
+ $(LEX) -o$@ -Pmaster_ $?
+--- modules/Makefile.old 2010-05-27 17:42:18.726149315 +0200
++++ modules/Makefile 2010-05-27 17:43:01.581400805 +0200
+@@ -87,7 +87,6 @@
+ lookup_hesiod.so: lookup_hesiod.c
+ $(CC) $(SOLDFLAGS) $(CFLAGS) $(HESIOD_FLAGS) -o lookup_hesiod.so \
+ lookup_hesiod.c $(AUTOFS_LIB) $(LIBHESIOD) $(LIBRESOLV)
+- $(STRIP) lookup_hesiod.so
+
+ cyrus-sasl.o: cyrus-sasl.c
+ $(CC) $(CFLAGS) $(LDAP_FLAGS) -c $<
+@@ -96,10 +95,7 @@
+ $(CC) $(SOLDFLAGS) $(CFLAGS) $(LDAP_FLAGS) -o lookup_ldap.so \
+ lookup_ldap.c dclist.o $(SASL_OBJ) \
+ $(AUTOFS_LIB) $(LIBLDAP) $(LIBRESOLV)
+- $(STRIP) lookup_ldap.so
+
+ mount_nfs.so: mount_nfs.c replicated.o
+ $(CC) $(SOLDFLAGS) $(CFLAGS) -o mount_nfs.so \
+ mount_nfs.c replicated.o $(AUTOFS_LIB) $(LIBNSL)
+- $(STRIP) mount_nfs.so
+-
diff --git a/net-fs/autofs/metadata.xml b/net-fs/autofs/metadata.xml
index 9cf0428e990d..3b1e12ba2ad0 100644
--- a/net-fs/autofs/metadata.xml
+++ b/net-fs/autofs/metadata.xml
@@ -14,4 +14,9 @@
<email>gentoobugsie.20.dsurawicz@spamgourmet.com</email>
<name>Dustin Polke</name>
</maintainer>
+<use>
+ <flag name="hesiod">Install hesiod module</flag>
+ <flag name="ldap">Install LDAP module</flag>
+ <flag name="sasl">Enable SASL support in the LDAP module</flag>
+</use>
</pkgmetadata>