summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-12 00:19:08 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-12 00:19:08 +0000
commite7af8181bfbf29b3f859cf04ed8b53ed257f6866 (patch)
treee2edf652d3771596c9232206aa4472f967e3239d /net-fs
parentAdded RDEPEND=!app-misc/glimpse due to both providing /usr/bin/agrep. bug #53... (diff)
downloadgentoo-2-e7af8181bfbf29b3f859cf04ed8b53ed257f6866.tar.gz
gentoo-2-e7af8181bfbf29b3f859cf04ed8b53ed257f6866.tar.bz2
gentoo-2-e7af8181bfbf29b3f859cf04ed8b53ed257f6866.zip
fix #30522 #37004 #49444
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/ChangeLog13
-rw-r--r--net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r3 (renamed from net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r2)0
-rw-r--r--net-fs/nfs-utils/files/nfs-5 (renamed from net-fs/nfs-utils/files/nfs-4)20
-rw-r--r--net-fs/nfs-utils/files/nfs.confd7
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.6-r3.ebuild (renamed from net-fs/nfs-utils/nfs-utils-1.0.6-r2.ebuild)13
5 files changed, 37 insertions, 16 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index 323884b6fca0..61ab4fb7bc1b 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.39 2004/06/08 19:04:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.40 2004/06/12 00:19:08 vapier Exp $
+
+*nfs-utils-1.0.6-r3 (11 Jun 2004)
+
+ 11 Jun 2004; Mike Frysinger <vapier@gentoo.org> :
+ While i'm here, might as well fix more things :P.
+ Run make for the depend target so that we can then build everything
+ else in parallel. Add tweakable exportfs timeout to nfs init script
+ #37004 by Vlastimil Holer. Enable the '--enable-secure-statd' option
+ by default (seems to work fine on my nfs3 machines) #49444 by Juergen
+ Nagel. Make sure the emtpy state dirs dont get autocleaned #30522 by
+ Brave Cobra.
*nfs-utils-1.0.6-r2 (08 Jun 2004)
diff --git a/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r2 b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r3
index 319c3d94379e..319c3d94379e 100644
--- a/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r2
+++ b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r3
diff --git a/net-fs/nfs-utils/files/nfs-4 b/net-fs/nfs-utils/files/nfs-5
index d10b0b4b16c5..e99a563eb3b4 100644
--- a/net-fs/nfs-utils/files/nfs-4
+++ b/net-fs/nfs-utils/files/nfs-5
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/nfs-4,v 1.1 2004/06/08 19:04:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/nfs-5,v 1.1 2004/06/12 00:19:08 vapier Exp $
#---------------------------------------------------------------------------
# This script starts/stops the following
@@ -57,6 +57,12 @@ stop_statd() {
eend $? "Error stopping NFS statd"
}
+waitfor_exportfs() {
+ local pid=$1
+ ( sleep ${EXPORTFSTIMEOUT}; kill -9 $pid &>/dev/null ) &
+ wait $1
+}
+
start() {
# This is the new "kernel 2.6 way" to handle the exports file
if grep -q nfsd /proc/filesystems &>/dev/null; then
@@ -76,9 +82,7 @@ start() {
if grep -q '^/' /etc/exports &>/dev/null; then
ebegin "Exporting NFS directories"
$exportfs -r 1>&2 &
- pid=$!
- ( sleep 30; kill -9 $pid &>/dev/null ) &
- wait $pid
+ waitfor_exportfs $!
eend $? "Error exporting NFS directories"
fi
@@ -141,9 +145,7 @@ stop() {
# If that's the case, then try to kill it so the
# shutdown process can continue.
$exportfs -ua 1>&2 &
- pid=$!
- ( sleep 30; kill -9 $pid &>/dev/null ) &
- wait $pid
+ waitfor_exportfs $!
eend $? "Error unexporting NFS directories"
fi
@@ -156,9 +158,7 @@ reload() {
# bootup process can continue.
ebegin "Reloading /etc/exports"
$exportfs -r 1>&2 &
- pid=$!
- ( sleep 30; kill -9 $pid &>/dev/null ) &
- wait $pid
+ waitfor_exportfs $!
eend $? "Error exporting NFS directories"
}
diff --git a/net-fs/nfs-utils/files/nfs.confd b/net-fs/nfs-utils/files/nfs.confd
index 51089dabbdf9..fef0151232df 100644
--- a/net-fs/nfs-utils/files/nfs.confd
+++ b/net-fs/nfs-utils/files/nfs.confd
@@ -1,3 +1,7 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/nfs.confd,v 1.5 2004/06/12 00:19:08 vapier Exp $
+
# Config file for /etc/init.d/nfs
# Number of servers to be started up by default
@@ -10,3 +14,6 @@ RPCMOUNTDOPTS=""
# Options to pass to rpc.statd
# ex. RPCSTATDOPTS="-p 32765 -o 32766"
RPCSTATDOPTS=""
+
+# Timeout (in seconds) for exportfs
+EXPORTFSTIMEOUT=30
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.6-r2.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.6-r3.ebuild
index e66186d5be1d..c3b795fbbe85 100644
--- a/net-fs/nfs-utils/nfs-utils-1.0.6-r2.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.0.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6-r2.ebuild,v 1.1 2004/06/08 19:04:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6-r3.ebuild,v 1.1 2004/06/12 00:19:08 vapier Exp $
inherit gnuconfig
@@ -19,20 +19,22 @@ RDEPEND="${DEPEND}
>=sys-apps/util-linux-2.11f"
src_compile() {
- use ppc64 && gnuconfig_update
+ gnuconfig_update
econf \
--mandir=/usr/share/man \
--with-statedir=/var/lib/nfs \
--disable-rquotad \
--enable-nfsv3 \
+ --enable-secure-statd \
|| die "Configure failed"
if ! use tcpd; then
sed -i "s:\(-lwrap\|-DHAVE_TCP_WRAPPER\)::" config.mk
fi
- # parallel make still fails
- emake -j1 || die "Failed to compile"
+ # parallel make fails for depend target
+ make depend || die "failed to make depend"
+ emake || die "Failed to compile"
}
src_install() {
@@ -42,6 +44,7 @@ src_install() {
# Don't overwrite existing xtab/etab, install the original
# versions somewhere safe... more info in pkg_postinst
dodir /usr/lib/nfs
+ keepdir /var/lib/nfs/{sm,sm.bak}
mv ${D}/var/lib/nfs/* ${D}/usr/lib/nfs
keepdir /var/lib/nfs
keepdir /var/lib/nfs/v4root
@@ -56,7 +59,7 @@ src_install() {
insinto /etc ; doins ${FILESDIR}/exports
exeinto /etc/init.d
- newexe ${FILESDIR}/nfs-4 nfs
+ newexe ${FILESDIR}/nfs-5 nfs
newexe ${FILESDIR}/nfsmount nfsmount
insinto /etc/conf.d