summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2004-11-02 21:56:19 +0000
committerSimone Gotti <motaboy@gentoo.org>2004-11-02 21:56:19 +0000
commit5177a9beb5511a627d348f7d0527fff7c4aa4629 (patch)
treeffea60473b2adb069ad07f534066843c917b8c21 /net-ftp/kbear
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-5177a9beb5511a627d348f7d0527fff7c4aa4629.tar.gz
gentoo-2-5177a9beb5511a627d348f7d0527fff7c4aa4629.tar.bz2
gentoo-2-5177a9beb5511a627d348f7d0527fff7c4aa4629.zip
Added a patch to the configure script to honor the arts USE flag. Fixes bug #69790.
Diffstat (limited to 'net-ftp/kbear')
-rw-r--r--net-ftp/kbear/ChangeLog7
-rw-r--r--net-ftp/kbear/files/kbear-2.1.1-configure.patch141
-rw-r--r--net-ftp/kbear/kbear-2.1.1.ebuild5
3 files changed, 150 insertions, 3 deletions
diff --git a/net-ftp/kbear/ChangeLog b/net-ftp/kbear/ChangeLog
index 9fb4f353548d..ba86521d69da 100644
--- a/net-ftp/kbear/ChangeLog
+++ b/net-ftp/kbear/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/kbear
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/kbear/ChangeLog,v 1.19 2004/07/14 14:43:59 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/kbear/ChangeLog,v 1.20 2004/11/02 21:56:19 motaboy Exp $
+
+ 02 Nov 2004; Simone Gotti <motaboy@gentoo.org>
+ +files/kbear-2.1.1-configure.patch, kbear-2.1.1.ebuild:
+ Added a patch to the configure script to honor the arts USE flag. Fixes bug
+ #69790.
14 Jul 2004; Travis Tilley <lv@gentoo.org> +files/kbear-2.1.1-gcc-3.4.patch,
kbear-2.1.1.ebuild:
diff --git a/net-ftp/kbear/files/kbear-2.1.1-configure.patch b/net-ftp/kbear/files/kbear-2.1.1-configure.patch
new file mode 100644
index 000000000000..e4454f4c5924
--- /dev/null
+++ b/net-ftp/kbear/files/kbear-2.1.1-configure.patch
@@ -0,0 +1,141 @@
+--- configure.orig 2004-11-02 10:38:48.370909440 +0100
++++ configure 2004-11-02 10:39:38.251326464 +0100
+@@ -23867,138 +23867,6 @@
+ fi
+
+
+- echo "$as_me:$LINENO: checking for mcopidl" >&5
+-echo $ECHO_N "checking for mcopidl... $ECHO_C" >&6
+- if test -n "$MCOPIDL"; then
+- kde_cv_path="$MCOPIDL";
+- else
+- kde_cache=`echo mcopidl | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/mcopidl"; then
+- if test -n ""
+- then
+- evalstr="$dir/mcopidl 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- else
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- MCOPIDL=$kde_cv_path
+-
+- fi
+-
+-
+- echo "$as_me:$LINENO: checking for artsc-config" >&5
+-echo $ECHO_N "checking for artsc-config... $ECHO_C" >&6
+- if test -n "$ARTSCCONFIG"; then
+- kde_cv_path="$ARTSCCONFIG";
+- else
+- kde_cache=`echo artsc-config | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/artsc-config"; then
+- if test -n ""
+- then
+- evalstr="$dir/artsc-config 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- else
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- ARTSCCONFIG=$kde_cv_path
+-
+- fi
+-
+-
+ echo "$as_me:$LINENO: checking for kde-config" >&5
+ echo $ECHO_N "checking for kde-config... $ECHO_C" >&6
+ if test -n "$KDECONFIG"; then
diff --git a/net-ftp/kbear/kbear-2.1.1.ebuild b/net-ftp/kbear/kbear-2.1.1.ebuild
index 0089b0bf11c4..e1f35f990c99 100644
--- a/net-ftp/kbear/kbear-2.1.1.ebuild
+++ b/net-ftp/kbear/kbear-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/kbear/kbear-2.1.1.ebuild,v 1.5 2004/07/14 14:43:59 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/kbear/kbear-2.1.1.ebuild,v 1.6 2004/11/02 21:56:19 motaboy Exp $
inherit kde flag-o-matic eutils
@@ -21,6 +21,7 @@ src_unpack() {
use amd64 && append-flags -fPIC
kde_src_unpack
cd ${S}
- epatch ${FILESDIR}/kbear-2.1.1-gcc-3.4.patch
+ useq arts || epatch ${FILESDIR}/${P}-configure.patch
+ epatch ${FILESDIR}/${P}-gcc-3.4.patch
}