summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-07-31 13:11:52 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-07-31 13:11:52 +0000
commitb83bf8a433a8164d91f492e0f044dd2e20c7499b (patch)
tree52e6d3fb8505ab24b4e65df13ccee3711b66f909 /net-ftp/lftp
parentchanged maintainance to VDR-Project (diff)
downloadgentoo-2-b83bf8a433a8164d91f492e0f044dd2e20c7499b.tar.gz
gentoo-2-b83bf8a433a8164d91f492e0f044dd2e20c7499b.tar.bz2
gentoo-2-b83bf8a433a8164d91f492e0f044dd2e20c7499b.zip
version bump
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.5.23
-rw-r--r--net-ftp/lftp/lftp-3.5.2.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 393cc4cb0a8c..449aba8e9c46 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.110 2006/07/12 20:25:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.111 2006/07/31 13:11:52 dragonheart Exp $
+
+*lftp-3.5.2 (31 Jul 2006)
+
+ 31 Jul 2006; Daniel Black <dragonheart@gentoo.org> +lftp-3.5.2.ebuild:
+ version bump
12 Jul 2006; Aron Griffis <agriffis@gentoo.org> lftp-3.4.6.ebuild:
Mark 3.4.6 stable on ia64. #132525
diff --git a/net-ftp/lftp/files/digest-lftp-3.5.2 b/net-ftp/lftp/files/digest-lftp-3.5.2
new file mode 100644
index 000000000000..9498af098730
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.5.2
@@ -0,0 +1,3 @@
+MD5 60327450c824b47fe6f3217e83f604a5 lftp-3.5.2.tar.gz 1789513
+RMD160 c9339a8fb4709b2c2be1f5a71ff08882425b9b22 lftp-3.5.2.tar.gz 1789513
+SHA256 2e8329a642b0132ee8e593f5e7b3f69dbbdc14264bd6a67f2aaaa146f99b871f lftp-3.5.2.tar.gz 1789513
diff --git a/net-ftp/lftp/lftp-3.5.2.ebuild b/net-ftp/lftp/lftp-3.5.2.ebuild
new file mode 100644
index 000000000000..de520606b143
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.5.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.5.2.ebuild,v 1.1 2006/07/31 13:11:52 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+
+#SRC_URI="http://the.wiretapped.net/mirrors/lftp/${P}.tar.bz2"
+# Was a bit too slow and unreliable last time I tried (dragonheart)
+SRC_URI="ftp://lftp.yar.ru/lftp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? ( >=net-proxy/dante-1.1.12 )
+ socks5? ( virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ !ppc-macos? ( >=sys-libs/readline-5.1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+
+src_compile() {
+ local myconf="$(use_enable nls)"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ use ppc-macos && myconf="${myconf} --with-included-readline"
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}