summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-12-08 23:02:49 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-12-08 23:02:49 +0000
commite4d633a5eb3efed7afbd2e4f05487d1c98222537 (patch)
tree7eb9ba0de26dc33c597509696c63c068913c4c73 /net-ftp/lftp
parentdhcpcd-3 now works on freebsd and is supported by baselayout-1.13.0_alpha8 (diff)
downloadgentoo-2-e4d633a5eb3efed7afbd2e4f05487d1c98222537.tar.gz
gentoo-2-e4d633a5eb3efed7afbd2e4f05487d1c98222537.tar.bz2
gentoo-2-e4d633a5eb3efed7afbd2e4f05487d1c98222537.zip
version bump
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.5.73
-rw-r--r--net-ftp/lftp/lftp-3.5.7.ebuild62
3 files changed, 71 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index b9284b89852c..0845938a2bc8 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.121 2006/11/12 07:23:26 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.122 2006/12/08 23:02:49 dragonheart Exp $
+
+*lftp-3.5.7 (08 Dec 2006)
+
+ 08 Dec 2006; Daniel Black <dragonheart@gentoo.org> +lftp-3.5.7.ebuild:
+ version bump
12 Nov 2006; Daniel Black <dragonheart@gentoo.org> -lftp-3.0.13.ebuild:
punt old version
diff --git a/net-ftp/lftp/files/digest-lftp-3.5.7 b/net-ftp/lftp/files/digest-lftp-3.5.7
new file mode 100644
index 000000000000..3938dd5c6a95
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.5.7
@@ -0,0 +1,3 @@
+MD5 c0650de14101f05c1dbe63a5ffe94462 lftp-3.5.7.tar.bz2 1293219
+RMD160 ba04bc2b98aa4831aa6f509c7e415d2a656343c6 lftp-3.5.7.tar.bz2 1293219
+SHA256 cb37e3ff31e41606e924fc4e656cc36e31fb6eb626105b26a0a709c365851df6 lftp-3.5.7.tar.bz2 1293219
diff --git a/net-ftp/lftp/lftp-3.5.7.ebuild b/net-ftp/lftp/lftp-3.5.7.ebuild
new file mode 100644
index 000000000000..4d5263943cfb
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.5.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.5.7.ebuild,v 1.1 2006/12/08 23:02:49 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+
+#SRC_URI="http://the.wiretapped.net/mirrors/lftp/${P}.tar.bz2"
+# Was a bit too slow and unreliable last time I tried (dragonheart)
+SRC_URI="ftp://lftp.yar.ru/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ !ppc-macos? ( >=sys-libs/readline-5.1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ use ppc-macos && myconf="${myconf} --with-included-readline"
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}