summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-14 02:16:37 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-14 02:16:37 +0000
commit7353a81792b313b0e3614944e2471de5a7123c99 (patch)
tree52401fdb89f11a5111897eb322392191aed237ac /net-ftp/ncftp/files
parentStepping down from maintaining this package (diff)
downloadgentoo-2-7353a81792b313b0e3614944e2471de5a7123c99.tar.gz
gentoo-2-7353a81792b313b0e3614944e2471de5a7123c99.tar.bz2
gentoo-2-7353a81792b313b0e3614944e2471de5a7123c99.zip
Fix some parallel build issues #147371.
(Portage version: 2.1.1)
Diffstat (limited to 'net-ftp/ncftp/files')
-rw-r--r--net-ftp/ncftp/files/ncftp-3.1.9-build.patch8
-rw-r--r--net-ftp/ncftp/files/ncftp-3.2.0-build.patch47
2 files changed, 49 insertions, 6 deletions
diff --git a/net-ftp/ncftp/files/ncftp-3.1.9-build.patch b/net-ftp/ncftp/files/ncftp-3.1.9-build.patch
index d6d45b9ab0dc..447c2ef4308d 100644
--- a/net-ftp/ncftp/files/ncftp-3.1.9-build.patch
+++ b/net-ftp/ncftp/files/ncftp-3.1.9-build.patch
@@ -16,8 +16,8 @@ http://bugs.gentoo.org/146214
+++ sio/pch.mk.gcc-gch
@@ -1,5 +1,6 @@
syshdrs.h.gch: syshdrs.h sio.h usio.h
-- $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) syshdrs.h
-+ $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) syshdrs.h -o .tmp.$@
+- $(CCDV)$(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) syshdrs.h
++ $(CCDV)$(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) syshdrs.h -o .tmp.$@
+ mv -f .tmp.$@ $@
PCH=syshdrs.h.gch
@@ -35,8 +35,8 @@ http://bugs.gentoo.org/146214
+++ libncftp/pch.mk.gcc-gch
@@ -1,5 +1,6 @@
syshdrs.h.gch: syshdrs.h ncftp.h ncftp_errno.h util.h ftp.h
-- $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) syshdrs.h
-+ $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) syshdrs.h -o .tmp.$@
+- $(CCDV)$(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) syshdrs.h
++ $(CCDV)$(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) syshdrs.h -o .tmp.$@
+ mv -f .tmp.$@ $@
PCH=syshdrs.h.gch
diff --git a/net-ftp/ncftp/files/ncftp-3.2.0-build.patch b/net-ftp/ncftp/files/ncftp-3.2.0-build.patch
index 790ce1872efc..c7909d20f484 100644
--- a/net-ftp/ncftp/files/ncftp-3.2.0-build.patch
+++ b/net-ftp/ncftp/files/ncftp-3.2.0-build.patch
@@ -1,5 +1,9 @@
---- ncftp-3.2.0/Makefile.in
-+++ ncftp-3.2.0/Makefile.in
+Fix DESTDIR and parallel build bugs
+
+http://bugs.gentoo.org/147371
+
+--- Makefile.in
++++ Makefile.in
@@ -44,7 +44,7 @@
@( cd ./sh_util ; $(MAKE) "CC=$(CC)" "CFLAGS=$(CFLAGS)" )
@( cd ./vis ; $(MAKE) "CC=$(CC)" "CFLAGS=$(CFLAGS)" )
@@ -19,3 +23,42 @@
#
# The visual programs are only built if a working Curses was found.
#
+--- sio/Makefile.in
++++ sio/Makefile.in
+@@ -179,6 +179,7 @@
+ SClose.o: SClose.c $(SYSHDRS_DEP)
+ SConnect.o: SConnect.c $(SYSHDRS_DEP)
+ SConnectByName.o: SConnectByName.c $(SYSHDRS_DEP)
++SError.o: SError.c $(SYSHDRS_DEP)
+ SNew.o: SNew.c $(SYSHDRS_DEP)
+ SRead.o: SRead.c $(SYSHDRS_DEP)
+ SReadline.o: SReadline.c $(SYSHDRS_DEP)
+--- sio/pch.mk.gcc-gch
++++ sio/pch.mk.gcc-gch
+@@ -1,5 +1,6 @@
+ syshdrs.h.gch: syshdrs.h sio.h usio.h
+- $(CCDV)$(CC) $(CFLAGS) $(DEFS) $(CPPFLAGS) syshdrs.h
++ $(CCDV)$(CC) $(CFLAGS) $(DEFS) $(CPPFLAGS) syshdrs.h -o .tmp.$@
++ mv -f .tmp.$@ $@
+
+ PCH=syshdrs.h.gch
+ SYSHDRS_DEP=syshdrs.h.gch
+--- libncftp/Makefile.in
++++ libncftp/Makefile.in
+@@ -353,3 +353,6 @@
+
+ u_unmdtm.o: u_unmdtm.c $(SYSHDRS_DEP)
+ u_unmdtm.so: u_unmdtm.c $(SYSHDRS_DEP)
++
++u_feat.o: u_feat.c $(SYSHDRS_DEP)
++u_feat.so: u_feat.c $(SYSHDRS_DEP)
+--- libncftp/pch.mk.gcc-gch
++++ libncftp/pch.mk.gcc-gch
+@@ -1,5 +1,6 @@
+ syshdrs.h.gch: syshdrs.h ncftp.h ncftp_errno.h util.h ftp.h
+- $(CCDV)$(CC) $(CFLAGS) $(DEFS) $(CPPFLAGS) syshdrs.h
++ $(CCDV)$(CC) $(CFLAGS) $(DEFS) $(CPPFLAGS) syshdrs.h -o .tmp.$@
++ mv -f .tmp.$@ $@
+
+ PCH=syshdrs.h.gch
+ SYSHDRS_DEP=syshdrs.h.gch