summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-27 09:54:15 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-27 09:54:15 +0000
commit0084f12fa16e1ab0941699f565f9fb9fc51eadad (patch)
tree4bb38f8a3acab176b544a9c84c1aa12d0c8a632c /net-ftp
parentUpdate package. Fixes #2958 (diff)
downloadgentoo-2-0084f12fa16e1ab0941699f565f9fb9fc51eadad.tar.gz
gentoo-2-0084f12fa16e1ab0941699f565f9fb9fc51eadad.tar.bz2
gentoo-2-0084f12fa16e1ab0941699f565f9fb9fc51eadad.zip
Gtk2 tweak
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/gftp/ChangeLog14
-rw-r--r--net-ftp/gftp/files/digest-gftp-2.0.12-r11
-rw-r--r--net-ftp/gftp/gftp-2.0.12-r1.ebuild31
3 files changed, 42 insertions, 4 deletions
diff --git a/net-ftp/gftp/ChangeLog b/net-ftp/gftp/ChangeLog
index cf063905e80b..df5972c552ae 100644
--- a/net-ftp/gftp/ChangeLog
+++ b/net-ftp/gftp/ChangeLog
@@ -1,11 +1,12 @@
# ChangeLog for net-ftp/gftp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/ChangeLog,v 1.3 2002/05/24 07:54:42 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/ChangeLog,v 1.4 2002/05/27 09:54:15 spider Exp $
- 11 Apr 2002; Spider <spider@gentoo.org>
- Update all glib dependencies to use glib-1.2* in preparation of unmasking the glib-2.0.1 packages
-
+*gftp-2.0.12-r1 (27 May 2002)
+ 27 May 2002; Spider <spider@gentoo.org> gftp-2.0.12-r1.ebuild :
+ Updating the ebuild with a check for gtk+-2.0 and enabling that if
+ found, also changed the dependencies on gtk+ and glib
*gftp-2.0.12 (24 May 2002)
@@ -13,6 +14,11 @@
Updated version
+
+ 11 Apr 2002; Spider <spider@gentoo.org>
+ Update all glib dependencies to use glib-1.2* in preparation of unmasking the glib-2.0.1 packages
+
+
*gftp-2.0.11 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/net-ftp/gftp/files/digest-gftp-2.0.12-r1 b/net-ftp/gftp/files/digest-gftp-2.0.12-r1
new file mode 100644
index 000000000000..7130ef485bb1
--- /dev/null
+++ b/net-ftp/gftp/files/digest-gftp-2.0.12-r1
@@ -0,0 +1 @@
+MD5 cda2957361b42e51e80a1d63610ba8b0 gftp-2.0.12.tar.gz 940715
diff --git a/net-ftp/gftp/gftp-2.0.12-r1.ebuild b/net-ftp/gftp/gftp-2.0.12-r1.ebuild
new file mode 100644
index 000000000000..b2dd5853fe0a
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.0.12-r1.ebuild
@@ -0,0 +1,31 @@
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome based FTP Client"
+SRC_URI="http://www.gftp.org/${P}.tar.gz"
+HOMEPAGE="http://www.gftp.org"
+
+# very generic depends. it should be that way.
+DEPEND="x11-libs/gtk+
+ dev-libs/glib
+ >=x11-base/xfree-4.1.0
+ nls? ( sys-devel/gettext )"
+
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ pkg-config gtk+-2.0 && einfo "Gtk+ 2.0 found using that" || einfo "Using gtk+ 1.2"
+ pkg-config gtk+-2.0 && myconf="${myconf} --enable-gtk20"
+ ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+
+ dodoc COPYING ChangeLog README* THANKS TODO
+ dodoc docs/USERS-GUIDE
+
+}